Jump to content
You're invited! Join our 4.6 Live Event on ZOOM 6/24 ×

Community

Members Shop ( Support Topic )


TheJackal84

Recommended Posts

3 minutes ago, modman said:

So is it official or not?

You have no idea how important this application is to all of us and how much it has been overlooked all this time .... it really doesn't deserve such an end.

If this news is true I am sure that with @Adriano Faria it will get the attention it deserves!

Thank you

There is this thread. 
 

 

Link to comment
Share on other sites

3 hours ago, Adriano Faria said:

The hook in register method is right. If you want to check before 1.0.9 is out, download /applications/membersshop/hooks/RegisterHook.php. The _createMember method should look like this;


	public static function _createMember( $values, $profileFields, $postBeforeRegister = NULL, &$form )
	{
		$parent = parent::_createMember( $values, $profileFields, $postBeforeRegister, $form );

It requires 4 parameters.

Thanks, i will test registration process today with all plugins disabled. 

Link to comment
Share on other sites

I REALLY appreciate you taking over this incredible plugin. I hate to have to report an issue after the update, but on my forum, the 'Questions & Answers' section is not working correctly.

I can click into the section, it shows all the threads, but when I click on a thread, I get the following error:

 

 

Quote

 

This page isn’t working

www.website.com is currently unable to handle this request.

HTTP ERROR 500

 



I went into ACP and disabled Members Shop, went back to my 'Questions & Answers' section, clicked a thread, and it opened just fine. Any idea what could be causing this?

Thanks.
Link to comment
Share on other sites

On 3/24/2021 at 2:03 PM, SC36DC said:

I hate to have to report an issue after the update, but on my forum, the 'Questions & Answers' section is not working correctly.

I can click into the section, it shows all the threads, but when I click on a thread, I get the following error:

My bad. That happened when I had to clean every of 35 hook files from this app. There was a bunch of try/catch that is generated at every export. I messed two files.

Via FTP, upload the following files to applications/membersshop/hooks:

 

 

I prefer to wait a few more tests than to release a new version now and have to wait 3 or 4 days to be available on marketplace and something appears in the meantime.

Let me know. 👍

--------------------------------------

New version released fix this issue:

 

Edited by Adriano Faria
Link to comment
Share on other sites

5 minutes ago, Adriano Faria said:

My bad. That happened when I had to clean every of 35 hook files from this app. There was a bunch of try/catch that is generated at every export. I messed two files.

Via FTP, download the following files to applications/membersshop/hooks:

ReactHook.php 3.02 kB · 0 downloads

WarningProcess.php 878 B · 0 downloads

I prefer to wait a few more tests than to release a new version now and have to wait 3 or 4 days to be available on marketplace and something appears in the meantime.

Let me know. 👍

WOW. Thank you for the quick reply and fix. It worked.

I really do appreciate, YOU!

 

Link to comment
Share on other sites

7 minutes ago, Kellen Deming said:

Hello

 

I purchased this application from the flash modding website and now I cant get the new update.  Can anyone help me with this?

Contact @TheJackal84 and ask him to confirm. Sorry but he didn’t provide any list of purchases (from any resources) so I can’t do much.

——————-

EDIT: I just requested him a full list of purchases from all resources.

Edited by Adriano Faria
Link to comment
Share on other sites

Hello Adriano,

I have experienced an issue as well with the last update.  A number of user profiles return a completely empty (white) page.  Not only on the public website, but within the ACP as well.  When I turn off Member's shop all works again.  I don't want to uninstall and reinstall, possibly causing more issues, without your advice first.  I have cleared cache, restarted server, etc... all to no avail.  I don't see any specific error or system logs (not that I really know what to look for..)

Any thoughts?

 

3 minutes ago, SMen said:

Hello Adriano,

I have experienced an issue as well with the last update.  A number of user profiles return a completely empty (white) page.  Not only on the public website, but within the ACP as well.  When I turn off Member's shop all works again.  I don't want to uninstall and reinstall, possibly causing more issues, without your advice first.  I have cleared cache, restarted server, etc... all to no avail.  I don't see any specific error or system logs (not that I really know what to look for..)

Any thoughts?

 

Apologies, that was premature.  Seems the two hook files you uploaded fixed my issue as well!!

Many thanks!!

 

Link to comment
Share on other sites

On 12/9/2020 at 9:08 PM, Tripp★ said:

Looking at version 2.0.6, credits for reactions - still doesn't work properly. To be clear - it works fine for posts in a topic. However it doesn't work on:

  • Images in the Gallery
  • Image Albums in the Gallery
  • Statuses and their replies
  • And one or two other areas that I might have missed. 
    • If someone has Blogs does it work there?

I first reported this way back in August, and I'd like to inform you that it's still broken. Is there going to be a fix for this in the near future, @TheJackal84? Thanks in advance.

I can confirm that as of 2.0.7, this is still broken for me at least. I think it may have something to do with the fact that I had tried to set the FURL from "membersshop" to something else for branding purposes, a while back within the ACP. I'm not sure. But this still doesn't work, unfortunately. 

Edited by Tripp★
Link to comment
Share on other sites

On 2/1/2021 at 5:35 PM, modman said:

Having multiple currencies (EUR and Swiss Franc CHF) where the ratio is 1 EUR = 1.2 CHF there is no possibility to enter decimals in this setting.

It would be advisable to change the setting to accept decimals or to enter "Points per EUR / CHF" on a basis of x10, not x1...

I think many users (like me) prefer to have an exchange rate 1 = 1 example 10 points = 10 euros.

This is easier for users to understand but at the moment having multiple currencies it is not possible to manage this.

Do you have any suggestions?

Thank you

image.thumb.png.69a33e907b99746d87d6da56aa63834d.png

Please don't forget to help people who use multiple currencies like me .... using the plugin is impossible for us.

Link to comment
Share on other sites

1 hour ago, modman said:

Please don't forget to help people who use multiple currencies like me .... using the plugin is impossible for us.

 

3 hours ago, Adriano Faria said:

I will come back to view issues in a future release. I fixed now the quick ones that I was preventing the app from working properly. I still have other 20 or 30 resources to take a quick look. 👍

 

Link to comment
Share on other sites

I never used Basic Points but this is a points system:

Quote

This application will add a members shop and a avdanced point system to your site, where your members can earn and spend their well earned points they gained ( or bought if you have IPCommerce installed ) from this app,

 

Link to comment
Share on other sites

15 minutes ago, 403 - Forbiddeen said:

How i can fix it?

 

On 3/24/2021 at 3:19 PM, Adriano Faria said:

My bad. That happened when I had to clean every of 35 hook files from this app. There was a bunch of try/catch that is generated at every export. I messed two files.

Via FTP, upload the following files to applications/membersshop/hooks:

ReactHook.php 3.02 kB · 6 downloads

WarningProcess.php 878 B · 6 downloads

I prefer to wait a few more tests than to release a new version now and have to wait 3 or 4 days to be available on marketplace and something appears in the meantime.

Let me know. 👍

New version to fix this is awaiting approval. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy