Jump to content

site shows only text after upgrading from 4.1 to 4.2

Thaer Salameh

Recommended Posts

i have succesfully upgraded the forum from 3.4 to 4.1 but after upgrading to 4.2  the site shows only text no CSS or JS files are generated

i have searched in logs files in ngixn or php or IPS but no error is showed.


the html sources showed something like


but the directory css_built_2 is not there .. the uploads directory is writable

our server is running php 7 from debian stretch.

any help will be appreciated


Link to comment
Share on other sites

Are you using a third party custom theme ? :) If so please switch to the default IPS Suite theme as it is possible a 4.1.x theme on 4.2.x could cause something to this effect, you may be able to find an updated version if this is the case however.

Assuming you tried on the default theme / not using a custom one:

Go to the ACP and click on the Support link, you may have to use your browsers 'find' function if the css is missing from here, hopefully it will not be.

Click on the link and then the "Something is not working correctly" and let it run. You may get a message saying its cleared caches, click on "Check again" , keep going until it gets to the point where it wants you to submit a ticket. This will not take more than a minute or two to get this far with it anyway. :)

At that stage, stop and view your site again. Has the issue been rectified ?

If you are not sure about any of this, please just submit a ticket in the Client Area for assistance.

Link to comment
Share on other sites

thank you for your support.

i have tried some link in Support area in the admin and tring different link it works as i tried the option in the diagnostic

You are running the latest version, but an optional update is available to address the following issues:
  • Image proxy image rebuilds

Apply Patch

as i click it all files css & js are generated.

i forgot to mention

in windows it works only with the click

but in linux i should changed the entry in the table core_file_storage




Link to comment
Share on other sites

i think the issue that the old forum was hosted on a windows host and the new hosting was linux. i mixed the upgrade between xampp and linux.

we i done the upgrade from linux host from the beginning every thing works ..

only one think i should done manually, i can't use the utf8converter from the installation as it didn't converty my arabic posts, it convert them to "????"

the old forum use latin1 charset and has stored arabic data in utf8 encoding

i used the following converter to convert my old forum database to utf8 then i upgraded the forum to latest



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...