Jump to content

(NE) HTML5 Audio/Video Player


Nathan Explosion

Recommended Posts

You want access to the board to show you the issue? The board is pretty locked up and hasnt even launched yet, just been working on it a couple months. Launching a board in 2021 is only 13 years late so it must be special. Here is a public mp4 you can test with if that helps https://mlb-cuts-diamond.mlb.com/FORGE/2021/2021-07/01/0f91a225-cdda7716-7a3830d4-csvm-diamondx64-asset_1280x720_59_16000K.mp4

 

Thanks

Link to comment
Share on other sites

Posted (edited)
7 minutes ago, Kinzer said:

You want access to the board to show you the issue?

Yes please - a link to the post containing the code created via the API (happy for you to send link, and any login credentials to be able to view, via PM)

My application operates on the content of the post, manipulating it - I need to see the rendered HTML of a post that has been submitted via the API. Not the method used to create it, but the actual creation.

Once I see that, then I can probably suggest a change to your own API code.

Edited by Nathan Explosion
Link to comment
Share on other sites

Posted (edited)
18 minutes ago, Nathan Explosion said:

Yes please - a link to the post containing the code created via the API.

My application operates on the content of the post, manipulating it - I need to see the rendered HTML of a post that has been submitted via the API. Not the method used to create it, but the actual creation.

Once I see that, then I can probably suggest a change to your own API code.

Here you go thanks

Edited by Kinzer
Link to comment
Share on other sites

Posted (edited)

Thanks - add rel="external" to your <a> tag:

$data = array('forum' => '21', 'title' => $gameHi[$win]['Title'], 'post' => "<a href='$Hi[$win]' rel="external">$Hi[$win]</a>", 'author' => '1');

That should sort you out - let me know if it doesn't, and I'll check that link again for newer items.

Edited by Nathan Explosion
Link to comment
Share on other sites

3 minutes ago, Nathan Explosion said:

Thanks - add rel="external" to your <a> tag:

$data = array('forum' => '21', 'title' => $gameHi[$win]['Title'], 'post' => "<a href='$Hi[$win]' rel="external">$Hi[$win]</a>", 'author' => '1');

That should sort you out - let me know if it doesn't, and I'll check that link again for newer items.

Abracadabra! You the man, gracias

Link to comment
Share on other sites

  • 1 month later...

Quick check from an iOS device, and here is what it looks like:

received_156948999878693.thumb.jpeg.53e8051310401c102258101e0a6ef5c1.jpeg

Why? MOV files play natively on iOS, and I would expect Mac too. But on other platforms, you are going to need a codec on your machine/device that can handle the MOV format.

This is not really an issue with my application - I will be taking a look to see why it displays that way on your screenshot (collapsed to that single line), but if it won't play then that's not something I can, or will, help with.

Link to comment
Share on other sites

Posted (edited)

And here is what it looks like on my Windows 11 machine, in Firefox:

image.png.1502b87e30ca5a0fb08b05dd05f23cb7.png

It plays, but sound only (common occurrence with MOV files on machines that don't have the required codec)

However, on Chrome:

image.png.29813367186b107aca9069afa33177d7.png

Testing locally, and mov 'works' in all browsers (displays the player) however Chrome initially shows a player, but then it disappears and defaults back to what you see.

 

 

 

 

Interesting - the page source contains the correct html but when inspecting the element, the html is missing the <video tag.

Digging into this one.

 

Edited by Nathan Explosion
Link to comment
Share on other sites

Posted (edited)

Right, so it's not an issue with my application - the same thing happens with the native IPS functionality (test it yourself - disable the application in your app listing, and then go back and view the post in Firefox and Chrome - see below)

However, totally unrelated - I have spotted an issue with my application, whereby it is loading an incorrect Javascript file and not the "full bells and whistles" one I actually developed for this application. So there will be an update coming soon anyway. Scratch that - forgot about the flipping back to the backend stuff I did. No update due.

 

Firefox:

image.thumb.png.eeb6f67e637d2735155ab0015f5e1e8b.png

Chrome:

image.png.df57238f1313288d4bf53407d4884606.png

Edited by Nathan Explosion
Link to comment
Share on other sites

  • 2 weeks later...

Hi there Nathan!

Planning to update IPS to 4.6 but since I have a Pages music section where I use your plugin to play audio files instead of downloading them, is there something to be done? Wait for an update or not?  

Link to comment
Share on other sites

On 8/19/2021 at 6:14 PM, Nathan Explosion said:

Sorry, just seen that I didn't mark this one as IPS 4.6 compatible - I'll get to testing it over the weekend.

That would be cool, as I suddenly have a dire need for this application which I've been tinkering with up until now (and 4.6.x now "frowns" on version-unverified apps 😀).

Link to comment
Share on other sites

Posted (edited)

Testing today - initially not seeing any issues with the current version on IPS 4.6, but will do some more testing tomorrow once back at my dev machine.

Testing finished - not seeing any issues. Resource has been marked as IPS 4.6 compatible , and is pending review before it will appear as installable on that version. Existing installations don't need an update if running the current 2.1.1 version.

If anyone does spot a problem, please report it here.

Edited by Nathan Explosion
Update
Link to comment
Share on other sites

  • 2 weeks later...

Decided to take a day off today, so the weekend started early.

This was fun to figure out - will upload a new version to fix the issue, but if anyone has the following specific situation then contact me via PM for patch details:

  1. Self-hosted
  2. Is comfortable with downloading a file via FTP, editing it and uploading it.
  3. Using IPS 4.6.x
  4. Using v2.1.0 or v2.1.1 of this application
  5. Audio file attachments added to content are NOT converted to a player even though configured
Edited by Nathan Explosion
Link to comment
Share on other sites

v2.1.2 is currently pending approval

  • FIXES
    • Fixed issue affecting IPS 4.6.x where audio file attachments would not be converted to an audio player despite configured to do so
    • Fixed issue affecting IPS 4.6.x where 'Permissions' page in ACP would trigger an error if PHP 8 was in use
  • CHANGES
    • None
  • NEW
    • Nothing
Edited by Nathan Explosion
Link to comment
Share on other sites

  • 1 month later...

Nope, those are not reproduction steps...quelle surprise?

What is the content of the announcement? Exact content...or a link to the announcement itself. And if the announcement is not viewable to guests, you provide a login to your site.

What are your settings for the app?Screenshots of all settings

Edited by Nathan Explosion
Link to comment
Share on other sites

I do not want to put data from my website here but I will try to be detailed.

  • Announce type: Content, (also does not work with "Link to URL")
  • Select: Show to all
  • Select: show everywhere
  • Type: Floating bar at the top of the page
  • IPS: 4.6.7

App Settings HTML5 Audio/Video Player 2.1.2: view attachments


 

settings HTML 5 2.png

settingshtml5_3.png

settings HTML5 1.png

Link to comment
Share on other sites

9 minutes ago, pequeno said:

I do not want to put data from my website here

Then provide it by PM.

I need the actual content of the announcement itself.

Please also provide your permissions information.

Once you have provided more detail then I will look into it on Friday, when I have a day off from work.

Edited by Nathan Explosion
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...