Jump to content

Community

Nathan Explosion

(NE) HTML5 Audio/Video Player

Recommended Posts

On 1/18/2018 at 10:37 PM, Nathan Explosion said:

I haven't put the resize functionality in for the audio player, as I didn't see a reason for it.....you're not looking at the audio, unlike the video.

Is this something you would need then? Could you explain why, just for my own curiousity.

I run an English learning membersite; my students would upload their voice recordings, and it's useful to be able to move from one part of the recording to another—having a bigger player makes this significantly easier. I hope this helps!

Share this post


Link to post
Share on other sites

Very nice plugin, thank you :) 

Some limitations though

1 - The player doesn't show if the member is not allowed to "download attachments" 

2 - Would be nice to be able to remove the download button 

picrhly2.png

Share this post


Link to post
Share on other sites
Posted (edited)

1 - correct. Why show the player if user can't play the file? (Download rights are required....otherwise the player is just trying to play a HTML Page displaying an error message)

2 - can be done in Chrome, but not other browsers (feel free to Google the 'Control List Settings' functionality i added to the plugin)

Edited by Nathan Explosion

Share this post


Link to post
Share on other sites
4 hours ago, Nathan Explosion said:

1 - correct. Why show the player if user can't play the file? (Download rights are required....otherwise the player is just trying to play a HTML Page displaying an error message)

2 - can be done in Chrome, but not other browsers (feel free to Google the 'Control List Settings' functionality i added to the plugin)

It makes sense! Thank you :)

Share this post


Link to post
Share on other sites

Dumb question... So I can upload an avi/mpg/mp4 video to an article on Pages and it will appear as a video player when the article is viewed? I have been looking for something like this forever! I hope this is the case...

Share this post


Link to post
Share on other sites
Posted (edited)

Yup.

So you are aware...that functionality is now available in the editor natively for video files as of IPS 4.3. You don't need the plugin if you are running 4.3 - I know that potentially costs me a sale hehe

Edited by Nathan Explosion

Share this post


Link to post
Share on other sites
28 minutes ago, Nathan Explosion said:

Yup.

So you are aware...that functionality is now available in the editor natively for video files as of IPS 4.3. You don't need the plugin if you are running 4.3 - I know that potentially costs me a sale hehe

Seriously? That is terrific news!!! When is IPS 4.3 scheduled to be released? I guess I'll just wait and not have to buy this when it won't be needed for IPS 4.3

I will search your other addons and see what I can buy. Guys like you need to be supported! ?

Share this post


Link to post
Share on other sites
Just now, LDDG said:

When is IPS 4.3 scheduled to be released?

It's already available, via the client area. IPS will be making it available over the auto-upgrader in the near future....they are doing a 'slow release' at present.

Share this post


Link to post
Share on other sites
12 minutes ago, Nathan Explosion said:

It's already available, via the client area. IPS will be making it available over the auto-upgrader in the near future....they are doing a 'slow release' at present.

Oh wow!! I guess I will be busy this weekend! hahaha Thanks again, brother!

Share this post


Link to post
Share on other sites

Hi! Just updated to 4.3.1 and wanted to test this plugin, but it seems that my system doesn't see it... 

I can change any option, but just default forum features works (ex: there is no link under attached video, width size is always 100%, external mp4 or mp3 are not embedding)

What could it be my problem?

Share this post


Link to post
Share on other sites

FYI, it seems your plugin breaks emojis added in 4.3. See my thread here:

When your plugin is disabled emojis work fine.

Share this post


Link to post
Share on other sites
Posted (edited)

Just grabbed a few minutes to test this out, and I'm not seeing any obvious errors related to emoji when this plugin is enabled....no broken images like you display in the provided link above.

Scratch that - just spotted a possible problem.

Edited by Nathan Explosion

Share this post


Link to post
Share on other sites

@Rolle

Are you self-hosted? If so, would it be possible to get FTP access to your installations plugin\nehtml5audiovideoplayer folder?

I'd like to test out the fix for this issue to confirm it works (all good here, just want to be 100% sure) before I release the next update.

If it is possible, then send me over the ftp details and I'll login and put the fix in place manually.

Share this post


Link to post
Share on other sites

What's new in v1.2.0

What's fixed in v1.2.0

  • fixed a DOM parsing issue that resulted in emojis being presented in their ASCII format, causing a display issue if Twitter style or EmojiOne style emojis were being used.

Share this post


Link to post
Share on other sites
On 5/12/2018 at 12:49 PM, Nathan Explosion said:

causing a display issue if Twitter style or EmojiOne style emojis were being used.

Didn't fix on my board.

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/22/2018 at 9:38 AM, Abby Weng said:

I run an English learning membersite; my students would upload their voice recordings, and it's useful to be able to move from one part of the recording to another—having a bigger player makes this significantly easier. I hope this helps!

FYI: still looking in to ways of handling this. Unlike the video tag, the audio tag doesn't have a 'height' attribute. It does have a 'width' attribute so I can make the audio player wider....just not higher. Will figure something out (maybe switch the audio tag for an embed tag instead)

Edited by Nathan Explosion

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×