Jump to content
Invision Community
TAMAN

Backstretch - Backgrounds [ support topic ]

Recommended Posts

Hi @TAMAN.

Thank you for developed this plugin! :wub: I am currently playing with it and have a suggestion; the remove background image option should be moved to configuration tab. Because I tried the video background from Youtube and found that if the remove custom body background is not turned on from this page, the custom background will still overlay the Youtube video. (I tried with both IPS original theme and your Magnum theme)

I agree with @Azurette about background color in the slideshow dialog. Can you set it to use 

background-color: {theme="dialogbg"};

so it would be matched with current theme?

Also I think the character "r" is missing from the plugin name. :p

Edit: and the "e" in Textures section name too. :rofl:

BackgroundPickerRemoveImage.thumb.png.05d6eb7522ddb99ea886175a11d0c4e6.png

Edited by Foolboy

Share this post


Link to post
Share on other sites
11 hours ago, Azurette said:

Taman, is there a way to change the background color for the slideshow?  When it starts, the page is white before the images begin.  I'd like to change it to black.

9 hours ago, Foolboy said:

I agree with @Azurette about background color in the slideshow dialog. Can you set it to use 

9 hours ago, Foolboy said:

the remove background image option should be moved to configuration tab. Because I tried the video background from Youtube and found that if the remove custom body background is not turned on from this page, the custom background will still overlay the Youtube video. (I tried with both IPS original theme and your Magnum theme)

9 hours ago, Foolboy said:

Also I think the character "r" is missing from the plugin name. :p

Edit: and the "e" in Textures section name too. :rofl:

Thanks, I added a body background color and moved the remove body backgrounds to configuration tab :) 

 

Update 1.0.1

  • Adding Body background color setting.
  • Changing position of Remove body backgrounds setting to configurations.

 

Share this post


Link to post
Share on other sites
1 hour ago, Lucas James said:

The white back ground on refresh is terrible. I'd rather just have a default background then use this plugin and have a white flash background appear every page load.

I will improve that on next update hopfuly, i hate it too to be honest haha i couldn't notice because working on localhost is fast you can barely feel the loading's especially for images 

Edited by TAMAN

Share this post


Link to post
Share on other sites
11 hours ago, TAMAN said:

I will improve that on next update hopfuly, i hate it too to be honest haha i couldn't notice because working on localhost is fast you can barely feel the loading's especially for images 

Oh okay great! :)

Share this post


Link to post
Share on other sites

Works great @TAMAN Thanks for releasing. :)

Just wondering if you would consider adding an option to deactivate the plugin for certain pages? The setting "Remove body backgrounds" is so powerful it is affecting another plugin I use for custom user upload profile background images. 

Otherwise maybe easier if I try to find a way to wrap a conditional to exclude this plugin from executing for just member profile view?

Any ideas on approach would be appreciated.

Share this post


Link to post
Share on other sites

Is there any way to allow the site member to choose a background, or to stop a slideshow if it starts annoying them?  It looks as if this is all Admin controlled.

EDIT: never mind - I re-read the description, which says that users can choose their own background.  But I don't see a background picker on the demo page at http://hellshammers.net/tit/index.php?/background-slideshow/.

Edited by liquidfractal

Share this post


Link to post
Share on other sites
2 hours ago, liquidfractal said:

Is there any way to allow the site member to choose a background, or to stop a slideshow if it starts annoying them?  It looks as if this is all Admin controlled.

EDIT: never mind - I re-read the description, which says that users can choose their own background.  But I don't see a background picker on the demo page at http://hellshammers.net/tit/index.php?/background-slideshow/.

its background picker/ background slideshow/ background video 

the demo page uses background slideshow

Edited by TAMAN

Share this post


Link to post
Share on other sites
30 minutes ago, TAMAN said:

its background picker/ background slideshow/ background video 

the demo page uses background slideshow

lol....thanks!  But if it's a background slideshow, the site in the previous link seems to have only one static background.  How long until the slideshow changes?  Or I guess it's a background slideshow for the middle area?

Edited by liquidfractal

Share this post


Link to post
Share on other sites
40 minutes ago, liquidfractal said:

lol....thanks!  But if it's a background slideshow, the site in the previous link seems to have only one static background.  How long until the slideshow changes?  Or I guess it's a background slideshow for the middle area?

No its a slideshow but only one image xD 

i will add images when i get time i always forget 

Share this post


Link to post
Share on other sites

Not sure if anyone has asked this yet, but is it possible to make the background picker available on a per-group basis?  I'd prefer to enable it only for certain member groups.

EDIT: after tinkering with it a bit more, a couple more ideas in addition to making the Picker accessible to selected groups:

  • the ability to reorder slideshow images, if possible, would be really helpful
  • is there any way to keep the slideshow from resetting to the first (top) image every time the user clicks through to another page?  Someone who is casually browsing a site will always reset to the first image, which doesn't always look very good in the browsing experience.  For continuity's sake it would be nice to have the slideshow unaffected by user browsing.
Edited by liquidfractal

Share this post


Link to post
Share on other sites
32 minutes ago, The Asian said:

@TAMAN I noticed the background picker in the Userbar doesn't have a tooltip. How do I add this?

mmm unfortunately you cant, it is hardcoded, there are no templates to edit 

but i will add it on next update 

thank you.

Share this post


Link to post
Share on other sites
5 minutes ago, TAMAN said:

mmm unfortunately you cant, it is hardcoded, there are no templates to edit 

but i will add it on next update 

thank you.

Thanks, can I suggest the tooltip should be 'Change Background'.

Share this post


Link to post
Share on other sites
Just now, The Asian said:

Thanks, can I suggest the tooltip should be 'Change Background'.

I will use language strings

then you can change it here ACP > Customizations > Languages, look for Background picker and then change the phrase ;) 

Share this post


Link to post
Share on other sites
Posted (edited)

Hey @TAMAN on top of my last request, I found an issue with the plugin that you may be able to address in the next update.

I was setting up SSL certification for our forum and ran into this issue.

https://www.suttersolutions.com/2018/Forums_-_Allied-Gaming_2018-04-09_11-43-04.jpg

It seems this is happening with both this plugin and the Swiper Slider with most of your themes. If this could be fixed ASAP I'd greatly appreciate it.

Edited by The Asian

Share this post


Link to post
Share on other sites
Just now, The Asian said:

Hey @TAMAN on top of my last request, I found an issue with the plugin that you may be able to address in the next update.

I was setting up SSL certification for our forum and ran into this issue.

https://www.suttersolutions.com/2018/Forums_-_Allied-Gaming_2018-04-09_11-43-04.jpg

It seems this is happening with both this plugin and the Swiper Slider with most of your themes. If this could be fixed ASAP I'd greatly appreciate it.

This has nothing to do with any of my resources 

its due to your gametracker server banners served as http while your website is on https  

Share this post


Link to post
Share on other sites
Just now, The Asian said:

I've already changed my Gametracker Banners.

https://gyazo.com/8a2a87bdda48a8db456053f342a1b147

Console only shows errors coming from the Background changer.

what im saying is that these errors are not related to any of my resources :) 

try to clear caches and try to reupload the resources shows in the console  

for example this image

d2c5bba1ae7dd85935508e13c49263b2.png

wherever in the settings you have this image try to delete it and reupload it again :) 

if it is in a theme settings or in a plugin/app settings you must re-upload them 

this happens if you switched to SSL recently 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×