Jump to content

Community

Pages SuperTopics (Support Topic)


opentype
 Share

Recommended Posts

Hello, I have a problem with SuperTopics.  I installed per directions and everything seems to work fine unless I add a tag:

image.thumb.png.a4a0f66f7d9a76cd8f57815b5c30367a.png

When I add the tag, the block no longer renders....that's as far as I can determine the problem.  Put the tag in error- take it out, it functions.  Any thoughts on how to address?

Link to comment
Share on other sites

3 hours ago, BradTBP said:

When I add the tag, the block no longer renders....that's as far as I can determine the problem.  Put the tag in error- take it out, it functions.  Any thoughts on how to address?

SuperTopics doesn’t care about tags. 

I would suggest to test the same block with the stock template vs. the SuperTopics template activated. Does it show up with only with the stock template? That would point to a SuperTopics problem. Does it never show up with tags activated? That would point to a faulty blog setup – or maybe caching problems. 

Edited by opentype
Link to comment
Share on other sites

  • 7 months later...

I am having an issue with SuperTopics where I have created a latest posts feed block that is in my bottom-right area in the right column. If I put any other block below it, the additional blocks are broken and pushed into the center main area--so they are not in the right column. I have 3 items in my SuperTopics post bloc, and have noticed that the last item at the bottom doesn't accept the font formatting that the top 2 items use.

Because I was not able to edit any blocks that I added below my SuperTopics post feed in the right column, I created a support ticket with IPB, and they said that there is an issue with SuperTopics that is causing this. I am reporting this as a possible bug.

Link to comment
Share on other sites

2 minutes ago, sadams101 said:

I am having an issue with SuperTopics where I have created a latest posts feed block that is in my bottom-right area in the right column. If I put any other block below it, the additional blocks are broken and pushed into the center main area--so they are not in the right column. I have 3 items in my SuperTopics post bloc, and have noticed that the last item at the bottom doesn't accept the font formatting that the top 2 items use.

I looked at your forum page and see SuperTopics, but with customizations. Unless I can’t replicate it on a clean stock installation like my demo page, I won’t invest time looking for bugs, which might have been introduced by someone else change the original code. 

Link to comment
Share on other sites

  • 8 months later...
  • 6 months later...

Is it possible to somehow always tell it to always use the Featured image uploaded in the topic starter's post?

Sometimes if we switch an image out, it then displays the next image uploaded by a user. 

So for example, I post a topic and use an image.

A member replies with a photo, let's call it 1.jpg

I go back to my post in a week and upload a different image to display as the featured image, however it displays 1.jpg instead of the featured image I just uploaded. 

Hope that makes sense lol

Link to comment
Share on other sites

  • 1 month later...

Going to put this here in the correct thread just for future consideration 🙏 

Wondering... would it be possible to somehow force threads to use the image uploaded into the first post as the featured image?

When I "feature" topics currently, it uses the first-uploaded image.

Often times it uses a GIF or image a user uploaded (versus the one I want to show on the homepage). 

I have to manually go through each post and remove the GIF the user uploaded, then copy + paste the link instead. When there's a topic with hundreds of replies it's super time consuming 😩 

Below are several examples of users uploading a GIF/image before I uploaded the featured image and how it shows on the homepage.
 

1747351408_ScreenShot2020-08-26at12_00_57PM.png.04053520ee40c6cad3a96f19239ebbae.png

1765604358_ScreenShot2020-08-26at12_28_38PM.png.d4655a2c769d511e0bb6a5ca566bc059.png

117914356_ScreenShot2020-08-26at9_03_42AM.png.fc6d69a5b9372d86d85930a60ece325a.png

 

Thank you 🙏 

Edited by breatheheavy
Link to comment
Share on other sites

  • 4 weeks later...
  • 2 weeks later...

Hey there. @opentype I noticed something today.

After upgrading to 4.5 and the latest version of SuperTopics, it appears the featured thumbnail is chosen by the most-recent uploaded image in the topic.

What's happening is if I create a topic and feature it and choose the featured image, it gets replaced if someone uploads a GIF/image. 

Here's an example. They uploaded this GIF in a comment and it showed as the featured image on the homepage instead of the one I uploaded first into the OP.

1827839413_tiffemote.gif.ebc9068dd09a2e8

1342233802_ScreenShot2020-10-02at12_45_00PM.png.970500c0e2437fcc3824801ad7defa28.png

 

I can't disable member uploads into comments as it's a perk for subscribing.

Any suggestions would be greatly appreciated 🙏 

Link to comment
Share on other sites

9 hours ago, breatheheavy said:

Any suggestions would be greatly appreciated 🙏 

Just upload an attachment into the first post right when you create it. 
Topics do not have (stock) “featured images”. So they don’t get replaced. They don’t even exist. 

Edited by opentype
Link to comment
Share on other sites

11 hours ago, opentype said:

Just upload an attachment into the first post right when you create it. 
Topics do not have (stock) “featured images”. So they don’t get replaced. They don’t even exist. 

Interesting. This is what I was doing, yet it was displaying the most-recently uploaded image (versus the first uploaded image). 

Link to comment
Share on other sites

  • 2 weeks later...
On 10/2/2020 at 10:01 PM, opentype said:

Just upload an attachment into the first post right when you create it. 
Topics do not have (stock) “featured images”. So they don’t get replaced. They don’t even exist. 

Hey there. Was wondering if you could please help me with this. It's been a bit of a nightmare.

I had to disable the ability to upload images entirely for my premium subscribers. But even still, if they insert an image attachment they uploaded in the past, then the featured image changes to that (versus using the first uploaded image). 

1406156978_ScreenShot2020-10-13at9_42_22AM.png.2afc9792c44a0539f0a649336ef69d55.png


Please man, can we somehow change the app to use the first uploaded image versus the most-recent? @opentype

Link to comment
Share on other sites

3 minutes ago, breatheheavy said:

Please man, can we somehow change the app to use the first uploaded image versus the most-recent?

It’s not set to use the most recent. It takes the first attachment that IPS returns as “content image” (and IPS controls that function). 
You can see it on my demo site:
This topic has a monument as the first image and then later a street view. The SuperTopics page shows the monument, as expected. So I don’t see anything to change or fix. 

Link to comment
Share on other sites

  • 4 months later...

Hi,

Just installed this and its working lovely. In the block I have it set to display 6 items. When there is more in the forum that I'm pulling from , can it be set to purge the older ones and always display the newest BUT have a button to show the older ones on a slide , basically click the arrow and it shows older ones etc? Or a button that changes the block from Show 6 to show all?

 

Matt

Edited by alphamale
Link to comment
Share on other sites

8 hours ago, alphamale said:

Just installed this and its working lovely. In the block I have it set to display 6 items. When there is more in the forum that I'm pulling from , can it be set to purge the older ones and always display the newest BUT have a button to show the older ones on a slide , basically click the arrow and it shows older ones etc? Or a button that changes the block from Show 6 to show all?

Feed blocks are meant to show just a few entries (latest, featured, and so on). That’s by design. If you want to add a link, you would have to do that yourself, e.g. as a WYSIWYG block. 

Link to comment
Share on other sites

  • 1 month later...
On 2/26/2021 at 11:53 AM, alphamale said:

Does the articles one do the same?

So I can configure this to only show latest? Thats what I'm a after then. So basically its pulling from a forum "Articles" and showing own the homepage and I want 6 boxes , but to show the latest 6 all the time. So once I have more than 6 articles in that forum , it will always purge the ones older than the latest 6.

Link to comment
Share on other sites

32 minutes ago, alphamale said:

So I can configure this to only show latest? Thats what I'm a after then. So basically its pulling from a forum "Articles" and showing own the homepage and I want 6 boxes , but to show the latest 6 all the time. So once I have more than 6 articles in that forum , it will always purge the ones older than the latest 6.

Not perfectly sure what the question is. If you set the block to show 6 entries and if the ordering is set to “descending” then yes, you will always get the latest 6 entries. 

Link to comment
Share on other sites

24 minutes ago, opentype said:

Not perfectly sure what the question is. If you set the block to show 6 entries and if the ordering is set to “descending” then yes, you will always get the latest 6 entries. 

Yeah that's what I meant. SO I will have the content pulling from a forum called "news & rumours" for example. Say I have 6 entries in and have the settings for 6 entries in your plugin. When I put a 7th post in the news & rumours forum , it will purge the least latest post.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy