Jump to content

Beware upgrading to 4.2.3


Rafael Grecco
 Share

Recommended Posts

I had to delete my custom themes and reinstall them to get the colors like they were supposed to be. That and the background picker didn't work either, it would just immediately close.

Everything works like it's supposed to. Now all I have to do is install my custom backgrounds.

Link to comment
Share on other sites

It’s easy to get a false impressing from topics like this. There are thousands of sites that get upgraded without problems and no one is reporting it back. It’s the few problems that get reported—and we don’t even know what caused them. It might not even be IPS’ fault. There could be problems on the server or compatibility issues with 3rd-party software and so on …

I updated four sites to 4.2.3 yesterday. No problems whatsoever. 

Link to comment
Share on other sites

58 minutes ago, Soupy1985 said:

My menues have stopped working after update on my mobile version of my site.

Haven't upgraded yet but I just visited here today and the top menu bar with the stream search and menu button were not showing until I refreshed 

Edited by marklcfc
Link to comment
Share on other sites

I had the same problem with the upgrade 4.1.19.4- 4.2.1.
I have a topic here

In fact, such custom-themed problems always exist when a version goes up one floor

Also happened when 4.0.х ->4.1.x and 4.1.x -> 4.2.x:

This will happen and when 4.2.x -> 4.3.x

And why? Only IPS developers know and do.
Probably wake up thinking sleepy administrators ... ha ha ...:lol:

Edited by Adlago
Link to comment
Share on other sites

There is a bug in autocomplete fields that the field saves only one value instead of multiple values, i use autocomplete fields throughout my themes and plugins

now none of my themes and some plugins work properly in ips 4.2.3 and it is totally up to ips to fix it

 

 

Edited by TAMAN
Link to comment
Share on other sites

On my Site it fails after downloading files - > extracting.

Log gives me the following error

Email address or password incorrect. Make sure you are providing the details that you use to log into the IPS Client Area at invisionpower.com/clientarea.

But they are definetly correct...

Link to comment
Share on other sites

As has always been the case with upgrades, custom themes may not work and the author has to update the theme in MarketPlace, pain in the butt if happens with every release IPS make but the more complex a theme then the more chances of it not working in a new release.

It just depends what changes IPS have made if it affects any custom theme

Always better to wait and ask the author if will still work in next release when IPS make a release before upgrading, if needs upgrading then check with author and be patient and wait for author to update

 

Link to comment
Share on other sites

I don't use a custom theme from the MarketPlace, I have made a theme myself.

I just decided to report this problem because over the last year I don't remember having any theme issue while upgrading, this is the first time in a long time, so I just wanted to give a heads up to people.

There are forums/sites where a broken theme can be a big problem.

Link to comment
Share on other sites

2 hours ago, Rafael Grecco said:

I don't use a custom theme from the MarketPlace, I have made a theme myself.

I just decided to report this problem because over the last year I don't remember having any theme issue while upgrading, this is the first time in a long time, so I just wanted to give a heads up to people.

There are forums/sites where a broken theme can be a big problem.

I mentioned marketplace as people need to check with author if needs upgrading before upgrading their forum so same would apply to anyone creating their own theme

Link to comment
Share on other sites

On 8/30/2017 at 7:41 AM, Rafael Grecco said:

I don't use a custom theme from the MarketPlace, I have made a theme myself.

I just decided to report this problem because over the last year I don't remember having any theme issue while upgrading, this is the first time in a long time, so I just wanted to give a heads up to people.

There are forums/sites where a broken theme can be a big problem.

The fact that you made a theme yourself means you have a custom theme, and if you upgraded to 4.1.x --> 4.2.x then you should expect theme problems.  Theming was a well known issue in the community for 4.2.  

 I had the same problem with my theme, where I used the Live Theme Editor to simply re-color the default IPS skin.  You should think that a re-coloring would be fine, but the upgrade to 4.2 still messed up in certain areas, so I recreated it from scratch.  

 

Link to comment
Share on other sites

5 minutes ago, Joel R said:

The fact that you made a theme yourself means you have a custom theme, and if you upgraded to 4.1.x --> 4.2.x then you should expect theme problems.  Theming was a well known issue in the community for 4.2.  

 I had the same problem with my theme, where I used the Live Theme Editor to simply re-color the default IPS skin.  You should think that a re-coloring would be fine, but the upgrade to 4.2 still messed up in certain areas, so I recreated it from scratch.  

 

I see a sharp drop speed your site ...

Link to comment
Share on other sites

On 8/30/2017 at 3:50 AM, steve00 said:

As has always been the case with upgrades, custom themes may not work and the author has to update the theme in MarketPlace, pain in the butt if happens with every release IPS make but the more complex a theme then the more chances of it not working in a new release.

 

An effective template merge system would resolve many of those issues.  That is one area that XenForo is well beyond IPS in implementation.  It's one of the (now albeit few) things that I really miss from the XenForo script.  Their merge system works really nicely for the templating system.

Link to comment
Share on other sites

I've noticed how topics like this create a 'doomsday' scenario that really needs to stop. This creates panic in the eyes of those IPS clients who panic and avoid upgrading like the plague. I recently renewed my license and upgraded from 4.1.18 to 4.2.3 and I had no problems. Granted that everytime I upgrade to a new version 4.0 to 4.1, 4.1 to 4.3, etc, it's assumed that you have to reinstall your plugins, forum skins and modifications that work with the latest upgrade but that's no reason to jump on the support forums here and cry foul.

When I run into an issue, I post here on the forums trying to find a solution or if the problem is serious enough, I open a support ticket. The solution usually presents itself or someone from IPS finds a solution for the issue.

Link to comment
Share on other sites

30 minutes ago, Morisato said:

I've noticed how topics like this create a 'doomsday' scenario that really needs to stop. This creates panic in the eyes of those IPS clients who panic and avoid upgrading like the plague. I recently renewed my license and upgraded from 4.1.18 to 4.2.3 and I had no problems. Granted that everytime I upgrade to a new version 4.0 to 4.1, 4.1 to 4.3, etc, it's assumed that you have to reinstall your plugins, forum skins and modifications that work with the latest upgrade but that's no reason to jump on the support forums here and cry foul.

When I run into an issue, I post here on the forums trying to find a solution or if the problem is serious enough, I open a support ticket. The solution usually presents itself or someone from IPS finds a solution for the issue.

Although I like your reply, things are not quite that simple. At least for me there not. I do not have the time to spend upgrading and fixing issues all this summer with 4.2 version upgrades. I plan to deal with this sometime this winter and didn't want to waste all my summer upgrading and dealing with skin updates and issues. I have other things to deal with then deal with these issues. However, that is me and me alone. Others probably feel different. 

I have enjoyed my summer not dealing with these issues. I figured I will make some music and deal with these issues later. So far so good. But we'll see though. :) 

Link to comment
Share on other sites

6 minutes ago, CP said:

I do not have the time to spend upgrading and fixing issues all this summer with 4.2 version upgrades. I plan to deal with this sometime this winter and didn't want to waste all my summer upgrading and dealing with skin updates and issues. I have other things to deal with then deal with these issues. However, that is me and me alone. Others probably feel different. 

I have enjoyed my summer not dealing with these issues. I figured I will make some music and deal with these issues later. So far so good

Well, I'm pretty dang jealous here. So you can guess what I spent my summer doing in any free time I had :D 

 I'm a drummer also, so dealing with issues seem less stressful after a few hours playing :D 

Link to comment
Share on other sites

8 minutes ago, DesignzShop said:

Well, I'm pretty dang jealous here. So you can guess what I spent my summer doing in any free time I had :D 

 I'm a drummer also, so dealing with issues seem less stressful after a few hours playing :D 

With that said probably not the best thing to do this summer but needed a break. I will take care of things when the cold dark winter moves in where I live. :)_ 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...