Jump to content

CodingJungle's Apps [support topic]


CodingJungle

Recommended Posts

On 11/2/2019 at 5:18 PM, Square Wheels said:

Any updates?

yes i have it in testing with a few sites, to make sure it is working properly as it was broken in subtle and unsubtle ways, like it was causing like little words to disappear too and images in some cases, things are so far so good, no one has reported any thing major.

On 11/2/2019 at 3:02 PM, Blizzard098 said:

So I am getting this when installing the app:


1S111/1 Can't create table `web_forums`.`stratagem_comments` (errno: 1 "Operation not permitted")

 

However other applications install perfectly fine.

I am unfamiliar with this error, googling it says its a file/folder permission error on the OS and i can't reproduce it on my dev and a few of my live servers. are there anything like in the system log in IPS or your error log for the server, cause this error doesn't really tell me anything. the comments table is a pretty standard table setup from IPS documentation. 

Link to comment
Share on other sites

On 8/5/2019 at 10:19 AM, Chris027 said:

OK, I was helped by another member and shown where I can click Show Alts. This is cool. However, I see the duplicate user account but it says there are no Alts. How can this be?

 

411737024_ScreenShot2019-08-05at12_11_26PM.thumb.png.a4cbd519cbf2ec72da86c3538330bd58.png

For some reason this just started working for me. 

Link to comment
Share on other sites

On 11/4/2019 at 9:36 PM, CodingJungle said:

yes i have it in testing with a few sites, to make sure it is working properly as it was broken in subtle and unsubtle ways, like it was causing like little words to disappear too and images in some cases, things are so far so good, no one has reported any thing major.

I am unfamiliar with this error, googling it says its a file/folder permission error on the OS and i can't reproduce it on my dev and a few of my live servers. are there anything like in the system log in IPS or your error log for the server, cause this error doesn't really tell me anything. the comments table is a pretty standard table setup from IPS documentation. 

There are no error logs, no. Like I said, this error only shows up when attempting to install this addon. I can install any other perfectly fine.

Link to comment
Share on other sites

On 11/6/2019 at 10:03 PM, Blizzard098 said:

There are no error logs, no. Like I said, this error only shows up when attempting to install this addon. I can install any other perfectly fine.

check the system log for IPS, ACP->System->Support->System Logs, it should be under the type of 'multiredirect'
 

\IPS\Log::log( $e, 'multiredirect' );
\IPS\Output::i()->error( $e->getMessage(), '1S111/1', 403, '' );

cause where it is throwing the error, it logs with the stack trace and additional error info that i could use to determine what is causing it. cause the table is boilerplate and in all my years i've never seen a "errno 1", IPS is very good at truncated or giving junk/generic errors to end users, but logs the more detailed ones in the log. 

Link to comment
Share on other sites

20 hours ago, CodingJungle said:

check the system log for IPS, ACP->System->Support->System Logs, it should be under the type of 'multiredirect'
 


\IPS\Log::log( $e, 'multiredirect' );
\IPS\Output::i()->error( $e->getMessage(), '1S111/1', 403, '' );

cause where it is throwing the error, it logs with the stack trace and additional error info that i could use to determine what is causing it. cause the table is boilerplate and in all my years i've never seen a "errno 1", IPS is very good at truncated or giving junk/generic errors to end users, but logs the more detailed ones in the log. 

ah yes.. here is the backtrace:

#0 /srv/http/forums/public/system/Db/Db.php(1656): IPS\_Db->query('CREATE TABLE `s...')
#1 /srv/http/forums/public/system/Application/Application.php(1416): IPS\_Db->createTable(Array)
#2 /srv/http/forums/public/applications/core/modules/admin/applications/applications.php(973): IPS\_Application->installDatabaseSchema()
#3 /srv/http/forums/public/system/Helpers/MultipleRedirect/MultipleRedirect.php(92): IPS\core\modules\admin\applications\_applications->IPS\core\modules\admin\applications\{closure}(Array)
#4 /srv/http/forums/public/applications/core/modules/admin/applications/applications.php(1106): IPS\Helpers\_MultipleRedirect->__construct(Object(IPS\Http\Url\Internal), Object(Closure), Object(Closure))
#5 /srv/http/forums/public/system/Dispatcher/Controller.php(85): IPS\core\modules\admin\applications\_applications->install()
#6 /srv/http/forums/public/system/Node/Controller.php(62): IPS\Dispatcher\_Controller->execute()
#7 /srv/http/forums/public/applications/core/modules/admin/applications/applications.php(43): IPS\Node\_Controller->execute()
#8 /srv/http/forums/public/system/Dispatcher/Dispatcher.php(152): IPS\core\modules\admin\applications\_applications->execute()
#9 /srv/http/forums/public/admin/index.php(14): IPS\_Dispatcher->run()
#10 {main}

 

The log itself says 

Can't create table `web_forums`.`stratagem_comments` (errno: 1 "Operation not permitted")

 

Link to comment
Share on other sites

22 hours ago, Blizzard098 said:

ah yes.. here is the backtrace:


#0 /srv/http/forums/public/system/Db/Db.php(1656): IPS\_Db->query('CREATE TABLE `s...')
#1 /srv/http/forums/public/system/Application/Application.php(1416): IPS\_Db->createTable(Array)
#2 /srv/http/forums/public/applications/core/modules/admin/applications/applications.php(973): IPS\_Application->installDatabaseSchema()
#3 /srv/http/forums/public/system/Helpers/MultipleRedirect/MultipleRedirect.php(92): IPS\core\modules\admin\applications\_applications->IPS\core\modules\admin\applications\{closure}(Array)
#4 /srv/http/forums/public/applications/core/modules/admin/applications/applications.php(1106): IPS\Helpers\_MultipleRedirect->__construct(Object(IPS\Http\Url\Internal), Object(Closure), Object(Closure))
#5 /srv/http/forums/public/system/Dispatcher/Controller.php(85): IPS\core\modules\admin\applications\_applications->install()
#6 /srv/http/forums/public/system/Node/Controller.php(62): IPS\Dispatcher\_Controller->execute()
#7 /srv/http/forums/public/applications/core/modules/admin/applications/applications.php(43): IPS\Node\_Controller->execute()
#8 /srv/http/forums/public/system/Dispatcher/Dispatcher.php(152): IPS\core\modules\admin\applications\_applications->execute()
#9 /srv/http/forums/public/admin/index.php(14): IPS\_Dispatcher->run()
#10 {main}

 

The log itself says 


Can't create table `web_forums`.`stratagem_comments` (errno: 1 "Operation not permitted")

 

the only thing i got is the fact for whatever reason the comments table is being set to myisam for some reason. I'll send you a version here in a bit that has that changed to mysql default to see if it fixes the issue. 

Link to comment
Share on other sites

@CodingJungle: My themes miss containers, so I don't actually have a background. All I see is the text, images and the cards.

To solve this, I always add "<div class='ipsBox ipsPad'>" to the top of my templates.

Which template contains the cards? Could you please tell me?

I've managed to locate the 'projects' template, and the main page has a background container now. However, the actual sections don't. i.e whatever template uses this https://codingjungle.com/stratagem/projects/1-stratagem/

----

Requests

1] Could you add a private calendar, so all the tasks which have dates due can be seen at a glance? I'd love this feature, as it would allow me to plan carefully in advance, not just weekly, but months and yearly without overlapping anything.

2] Can 'projects' be removed from the URL's, it seems kinda redundant and, unnecessary.

If I remove https://codingjungle.com/stratagem/projects/

The page doesn't exist, so I'm not sure it's required. It just makes the URL seem longer, I'm not trying to nit pick, or anything.

3] Could the main index page be improved a little? I created a database via IP.Pages in the past, it was based on the ticket system. The main project page looks quite nice, I mean, there's nothing wrong with Stratagems. I just feel it would be nice to include the sections description there too, along with some stylization. May I PM you a screenshot, and the URL with login details to show you?

The app is wonderful, I can't wait to use it properly, and get organised better.

It will be a good thing for my site.

 

Edited by Joey_M
Link to comment
Share on other sites

On 11/18/2019 at 1:47 PM, Priyesh said:

@CodingJungle I am having a problem with it. This app is not sending a warning message to users. What should i do?

which app?

18 minutes ago, Joey_M said:

@CodingJungle: My themes miss containers, so I don't actually have a background. All I see is the text, images and the cards.

To solve this, I always add "<div class='ipsBox ipsPad'>" to the top of my templates.

Which template contains the cards? Could you please tell me?

I've managed to locate the 'projects' template, and the main page has a background container now. However, the actual sections don't. i.e whatever template uses this https://codingjungle.com/stratagem/projects/1-stratagem/

i'm not entirely sure i understand what you are saying here, you shouldn't have to add any thing to the templates. but anyway:

cards: this section contains anything to do with the cards that show in the columns.

columns: there is columns.phtml which is the wrapper once you go into a project, column.phtml is for the individual column. 

cardView: contains most of the templates for the stuff that displays when you click on a card.

 

25 minutes ago, Joey_M said:

1] Could you add a private calendar, so all the tasks which have dates due can be seen at a glance? I'd love this feature, as it would allow me to plan carefully in advance, not just weekly, but months and yearly without overlapping anything.

 

in 2.0, there are improvements to the my cards section that should aid in this, but i'll see about adding in a calendar section if calendar is installed, i wont make any promises tho on this :).

26 minutes ago, Joey_M said:

2] Can 'projects' be removed from the URL's, it seems kinda redundant and, unnecessary.

If I remove https://codingjungle.com/stratagem/projects/

The page doesn't exist, so I'm not sure it's required. It just makes the URL seem longer, I'm not trying to nit pick, or anything.

you can change the furl templates in the ACP->Advanced Configuration, Friendly URL tab, search for stratagem, there will be 3 of 'em.

stratagem.thumb.png.e3e04c8f3ebb9165f411c324ca4ee2f3.png

click on the pencil icon, it will open up the edit dialog, look for the Friendly URL box, and you can remove the /projects section of the friendly url there.

 

34 minutes ago, Joey_M said:

3] Could the main index page be improved a little? I created a database via IP.Pages in the past, it was based on the ticket system. The main project page looks quite nice, I mean, there's nothing wrong with Stratagems. I just feel it would be nice to include the sections description there too, along with some stylization. May I PM you a screenshot, and the URL with login details to show you?

 

it's intent is just for a quick landing page, not meant to hang out on for long 🙂 but feel free to pm me any screenshots you want that you believe could improve it.

Link to comment
Share on other sites

16 minutes ago, CodingJungle said:

i'm not entirely sure i understand what you are saying here, you shouldn't have to add any thing to the templates. but anyway:

cards: this section contains anything to do with the cards that show in the columns.

columns: there is columns.phtml which is the wrapper once you go into a project, column.phtml is for the individual column. 

cardView: contains most of the templates for the stuff that displays when you click on a card.

Sorry, I've PM'ed you.

I couldn't find the location, so I have sent my sites URL so you might be able to check for me. There's some inconsistencies with IPS, especially third party themes.

17 minutes ago, CodingJungle said:

you can change the furl templates in the ACP->Advanced Configuration, Friendly URL tab, search for stratagem, there will be 3 of 'em.

Thank you.

18 minutes ago, CodingJungle said:

in 2.0, there are improvements to the my cards section that should aid in this, but i'll see about adding in a calendar section if calendar is installed, i wont make any promises tho on this :).

I'm hoping! 2.0 sounds very interesting though.

A lot of social media management tools, such as Hootsuite have started to incorporate calendars. I'm not trying to twist your arm, but if it can be done - the added benefit is the overview and ability to properly plan things. 🙂

20 minutes ago, CodingJungle said:

it's intent is just for a quick landing page, not meant to hang out on for long 🙂 but feel free to pm me any screenshots you want that you believe could improve it.

I understand buddy, just feel the added benefits would approve the app.

PS. I won't keep making suggestions. Haha 😉 Great app! I will review it properly in detail soon.

Link to comment
Share on other sites

On 11/4/2019 at 9:36 PM, CodingJungle said:

yes i have it in testing with a few sites, to make sure it is working properly as it was broken in subtle and unsubtle ways, like it was causing like little words to disappear too and images in some cases, things are so far so good, no one has reported any thing major.

Any updates?  :)

Link to comment
Share on other sites

On 11/20/2019 at 1:56 AM, CodingJungle said:

you can change the furl templates in the ACP->Advanced Configuration, Friendly URL tab, search for stratagem, there will be 3 of 'em.

stratagem.thumb.png.e3e04c8f3ebb9165f411c324ca4ee2f3.png

click on the pencil icon, it will open up the edit dialog, look for the Friendly URL box, and you can remove the /projects section of the friendly url there.

Michael, I tried this but it didn't work.

I also tried to change /stratagem/ to /projects/ but the furls seem to be very awkward. This has little to do with your application, I have issues with others and devs have suggested making amendments to the FURL.jsn file. I tried this with the application, yet I couldn't figure out how to make it work.

Any chance you could help me make the base URL /projects/ and then anything after /project-title/.

So....

/media/

/content/

/whatever/

If you could, I'd be very grateful.

Thank you for considering my suggestions, and all your help so far.

Link to comment
Share on other sites

2 minutes ago, Joey_M said:

Michael, I tried this but it didn't work.

I also tried to change /stratagem/ to /projects/ but the furls seem to be very awkward. This has little to do with your application, I have issues with others and devs have suggested making amendments to the FURL.jsn file. I tried this with the application, yet I couldn't figure out how to make it work.

Any chance you could help me make the base URL /projects/ and then anything after /project-title/.

So....

/media/

/content/

/whatever/

If you could, I'd be very grateful.

Thank you for considering my suggestions, and all your help so far.

An old bug in Core:

 

Link to comment
Share on other sites

8 hours ago, Square Wheels said:

Any updates?  🙂

yes i released a fixed version the other day 😕, did you not see it?

1 hour ago, Joey_M said:

Michael, I tried this but it didn't work.

I also tried to change /stratagem/ to /projects/ but the furls seem to be very awkward. This has little to do with your application, I have issues with others and devs have suggested making amendments to the FURL.jsn file. I tried this with the application, yet I couldn't figure out how to make it work.

Any chance you could help me make the base URL /projects/ and then anything after /project-title/.

So....

/media/

/content/

/whatever/

If you could, I'd be very grateful.

Thank you for considering my suggestions, and all your help so far.

 

1 hour ago, Adriano Faria said:

There’s a manual way to do it. I say there in the topic. 

@Adriano Faria to the rescue 🙂 i was honestly unaware this was still a problem, as i tested i only quickly tested it on my local, appeared to work correctly. @Joey_M if need be, i can alter the furl.json for you and send you a "psuedo" update file. 

Link to comment
Share on other sites

57 minutes ago, CodingJungle said:

@Adriano Faria to the rescue 🙂 i was honestly unaware this was still a problem, as i tested i only quickly tested it on my local, appeared to work correctly. @Joey_M if need be, i can alter the furl.json for you and send you a "psuedo" update file. 

Please Michael, I apologise for seeming awkward.

I tried the manual fix, it's what I had to do with a music app which I use for my podcast (yet I couldn't get it to work).

PS. In the breadcrumb, once you click away from the index page. The FURL doesn't seem to work for the landing page, it shows the full address.

https://codingjungle.com/index.php?app=stratagem&module=view&controller=projects

Not
https://codingjungle.com/stratagem/

Nothing major, yet I thought I would pass it on. 👍

Thank you for everything, your helps truly amazing.

Link to comment
Share on other sites

  • Rhett locked this topic
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...