Jump to content

Community

CodingJungle

CodingJungle's Apps [support topic]

Recommended Posts

20 minutes ago, CodingJungle said:

so it is linking words its not suppose to be linking? what happens if you hover over 'em or click on 'em? do they do anything? are they similar to keywords you do have? 

No, it's worse than that.  It's randomly inserting words that are in the dictionary.  The three words I listed above are in the dictionary and show up as links and hovers.  They were not inserted by the user.  If I turn of keywords, the words go away altogether.

Share this post


Link to post
Share on other sites
Just now, Square Wheels said:

No, it's worse than that.  It's randomly inserting words that are in the dictionary.  The three words I listed above are in the dictionary and show up as links and hovers.  They were not inserted by the user.  If I turn of keywords, the words go away altogether.

oh okay, so its linking words that exist in it, but not in the content. hmm yeah that is def a bug.

Share this post


Link to post
Share on other sites

Hey @CodingJungle

i discovered 2 Bugs. 

First:

If a user who has no permissions to use stratagem wants to watch my profil he get an error, the system log shows the following:

TypeError: Argument 1 passed to IPS\stratagem\_Project::projectPerms() must be an instance of IPS\stratagem\Member, instance of IPS\Member given, called in /config/www/applications/stratagem/sources/Project/Project.php on line 552 (0)
#0 /config/www/applications/stratagem/sources/Project/Project.php(552): IPS\stratagem\_Project->projectPerms(Object(IPS\Member))
#1 /config/www/applications/stratagem/sources/Project/Card.php(532): IPS\stratagem\_Project->canView(Object(IPS\Member))
#2 /config/www/system/Content/Content.php(145): IPS\stratagem\Project\_Card->canView(Object(IPS\Member))
#3 /config/www/system/Content/Search/Results.php(546): IPS\_Content::loadAndCheckPerms(13)
#4 /config/www/applications/core/modules/front/members/profile.php(254): IPS\Content\Search\_Results->addExtraItems(Array, Object(IPS\Member))
#5 /config/www/system/Dispatcher/Controller.php(96): IPS\core\modules\front\members\_profile->manage()
#6 /config/www/applications/core/modules/front/members/profile.php(73): IPS\Dispatcher\_Controller->execute()
#7 /config/www/system/Dispatcher/Dispatcher.php(152): IPS\core\modules\front\members\_profile->execute()
#8 /config/www/index.php(13): IPS\_Dispatcher->run()
#9 {main}

Backtrace
#0 /config/www/init.php(938): IPS\_Log::log('TypeError: Argu...', 'uncaught_except...')
#1 [internal function]: IPS\IPS::exceptionHandler(Object(TypeError))
#2 {main}

Second:

I have no icon in the Admin ACP for the Stratagem Copyright Setting and some language strings are missing

Greets Sp4x

Share this post


Link to post
Share on other sites
On 6/1/2019 at 10:15 PM, CodingJungle said:

oh okay, so its linking words that exist in it, but not in the content. hmm yeah that is def a bug.

Thanks, do you know when you'll be able to fix it?

Share this post


Link to post
Share on other sites
Posted (edited)

I've just upgraded from version 3.1.8 two version 3.2 of keyword tooltips

it wouldn't install and I had huge problems and eventually I deleted the old version and then the new version installed perfectly. I've now discovered that it seems that our entire collection of keywords has disappeared.

Have they been erased? We had over a hundred and the system was working perfectly. Please could you let me know if they've been erased or I can recover them somewhere.

Thanks

Following on from the above post, we still have a full set of keywords on our test site – which upgraded perfectly, by the way.

If the keyword collection on our live site is a raised, are we able to access the keyword database on the test site and then copy them over to the live site? Thanks

Edited by BankFodder

Share this post


Link to post
Share on other sites

I've just discovered another problem and that is that when a keyword appears, all the text after it disappears.

I don't know if anybody else is having this problem but I'm afraid that the new version 3 point two seems to be faithful is unusable – in addition to having erased all of our keywords.

I've reinstalled version 3.1.8 which is now working correctly although all our keywords have gone and we are having to replace them manually and it's going to be a job lasting several days

Share this post


Link to post
Share on other sites
On 6/10/2019 at 11:59 AM, Square Wheels said:

Thanks, do you know when you'll be able to fix it?

I was moving when this issue came up, I'm mostly settled in now so i will be working on this, this weekend. sorry for the delay. 

On 6/11/2019 at 6:26 AM, BankFodder said:

I've just discovered another problem and that is that when a keyword appears, all the text after it disappears.

I don't know if anybody else is having this problem but I'm afraid that the new version 3 point two seems to be faithful is unusable – in addition to having erased all of our keywords.

I've reinstalled version 3.1.8 which is now working correctly although all our keywords have gone and we are having to replace them manually and it's going to be a job lasting several days

if you uninstall the app, then yes the keywords are lost (this is something IPS does, removing the tables when the app gets uninstalled). 

Share this post


Link to post
Share on other sites
4 hours ago, CodingJungle said:

I was moving when this issue came up, I'm mostly settled in now so i will be working on this, this weekend. sorry for the delay. 

if you uninstall the app, then yes the keywords are lost (this is something IPS does, removing the tables when the app gets uninstalled). 

Thank you.

Any possibility as a feature that there be an option to download or upload the database both to have a security backup but also to be able to transfer the data to a another installation.
In the meantime, are you able to tell me where the data is kept so that I can take a backup copy of it, please.

Share this post


Link to post
Share on other sites
15 hours ago, CodingJungle said:

I was moving when this issue came up, I'm mostly settled in now so i will be working on this, this weekend. sorry for the delay. 

Thank you

Share this post


Link to post
Share on other sites
On 6/9/2019 at 1:33 PM, Sp4x said:

Hey @CodingJungle

i discovered 2 Bugs. 

First:

If a user who has no permissions to use stratagem wants to watch my profil he get an error, the system log shows the following:


TypeError: Argument 1 passed to IPS\stratagem\_Project::projectPerms() must be an instance of IPS\stratagem\Member, instance of IPS\Member given, called in /config/www/applications/stratagem/sources/Project/Project.php on line 552 (0)
#0 /config/www/applications/stratagem/sources/Project/Project.php(552): IPS\stratagem\_Project->projectPerms(Object(IPS\Member))
#1 /config/www/applications/stratagem/sources/Project/Card.php(532): IPS\stratagem\_Project->canView(Object(IPS\Member))
#2 /config/www/system/Content/Content.php(145): IPS\stratagem\Project\_Card->canView(Object(IPS\Member))
#3 /config/www/system/Content/Search/Results.php(546): IPS\_Content::loadAndCheckPerms(13)
#4 /config/www/applications/core/modules/front/members/profile.php(254): IPS\Content\Search\_Results->addExtraItems(Array, Object(IPS\Member))
#5 /config/www/system/Dispatcher/Controller.php(96): IPS\core\modules\front\members\_profile->manage()
#6 /config/www/applications/core/modules/front/members/profile.php(73): IPS\Dispatcher\_Controller->execute()
#7 /config/www/system/Dispatcher/Dispatcher.php(152): IPS\core\modules\front\members\_profile->execute()
#8 /config/www/index.php(13): IPS\_Dispatcher->run()
#9 {main}

Backtrace
#0 /config/www/init.php(938): IPS\_Log::log('TypeError: Argu...', 'uncaught_except...')
#1 [internal function]: IPS\IPS::exceptionHandler(Object(TypeError))
#2 {main}

Second:

I have no icon in the Admin ACP for the Stratagem Copyright Setting and some language strings are missing

Greets Sp4x

sorry i missed this one, i have fixed this in the next version that will be release (1.2), i'm waiting for a bug fix on the sortable JS i'm using now to be fixed before i push out 1.2. 

17 hours ago, BankFodder said:

Thank you.

Any possibility as a feature that there be an option to download or upload the database both to have a security backup but also to be able to transfer the data to a another installation.
In the meantime, are you able to tell me where the data is kept so that I can take a backup copy of it, please.

there are 3 tables for keywords in you database. keywords_cats, keywords_stats and keywords_words (this is the one that holds the keyword data, the other two can safely be ignored, unless stats are important to you). 

Share this post


Link to post
Share on other sites

hey @Square Wheels could you do me a favor? can you enable debugging in your constants.php ( \define('DEBUG_LOG', true); ) and enable KW and go to the problem article, you can disable KW after this. then check your system log in support, to see if KW threw any errors? 

Share this post


Link to post
Share on other sites
7 hours ago, CodingJungle said:

hey @Square Wheels could you do me a favor? can you enable debugging in your constants.php ( \define('DEBUG_LOG', true); ) and enable KW and go to the problem article, you can disable KW after this. then check your system log in support, to see if KW threw any errors? 

Nothing in the error log or the system log.

Share this post


Link to post
Share on other sites
6 hours ago, Square Wheels said:

Nothing in the error log or the system log.

thanks, when i was looking at the code, seems i introduced a condition on one of the areas it can error out, it can remove all the content, was checking to make sure it wasn't also adding ghost to it. might have to go back to the old algorithm, that i was using to find and replace the words, as it was working and my attempt to improve it seems to have caused issues. you know what they say, don't fix what isn't broken :) 

Share this post


Link to post
Share on other sites

Love the ability to delete comments in Babble now... I have had reports from multiple people that the chat isn't working for them, and there were no problems before I updated.

 

Share this post


Link to post
Share on other sites
16 hours ago, Mark Spieker said:

Love the ability to delete comments in Babble now... I have had reports from multiple people that the chat isn't working for them, and there were no problems before I updated.

 

delete messages is still there, the only change there is it follows the global content delete permission for member groups instead of custom ones.

the "delete" option in permissions for the rooms has always been a "moderator" type permission, where if they have the permission from the room, then they can delete any messages, the global content delete permissions in groups only allows them to delete their own.

Share this post


Link to post
Share on other sites

I got two exceptions the other day when I went to uninstall Toolbox. I didn't keep the tracebacks but I think they were caused by removing "follows" using the a string ("toolbox") instead of an ID (integer type).

Sorry I didn't think of reporting this at the time, but you might want to uninstall Toolbox and see if you get the same two exceptions. I simply commented out the SQL that was causing the issue since the follows table didn't have any rows in it to remove anyway.

Share this post


Link to post
Share on other sites
1 hour ago, Kjell Iver Johansen said:

The babble chat is down atm - also on codingjungle site? Miss the option of changing server!

it wouldn't have helped to switch servers, it seems the problem is with my host. i'll contact their support to see how long it will be.

1 hour ago, KT Walrus said:

I got two exceptions the other day when I went to uninstall Toolbox. I didn't keep the tracebacks but I think they were caused by removing "follows" using the a string ("toolbox") instead of an ID (integer type).

Sorry I didn't think of reporting this at the time, but you might want to uninstall Toolbox and see if you get the same two exceptions. I simply commented out the SQL that was causing the issue since the follows table didn't have any rows in it to remove anyway.

i'll test it out, but i don't often uninstall it 🙂 

Share this post


Link to post
Share on other sites
On 6/16/2019 at 3:58 PM, CodingJungle said:

thanks, when i was looking at the code, seems i introduced a condition on one of the areas it can error out, it can remove all the content, was checking to make sure it wasn't also adding ghost to it. might have to go back to the old algorithm, that i was using to find and replace the words, as it was working and my attempt to improve it seems to have caused issues. you know what they say, don't fix what isn't broken :) 

bump

Share this post


Link to post
Share on other sites

Keywords Tooltip

I have two issues:

  1. If I use an URL Keyword on my live server, then the whole item content is replaced by the linked keyword. Like the text were: "Here is something about wonderful holiday." The keyword is "holiday". If enabled, the whole text is replaced by single linked word "holiday".
  2. There are language strings that are not assigned in search
    screenshot-2019_07_07-00-54-42.png.dfd15a91c64f3a95ef29fe41998ed723.png

 

Share this post


Link to post
Share on other sites

@CodingJungle, can you please look into issue #1 above. This is a very dangerous bug as it wipes out the whole content of the item instead of just linking one word in it. I can reproduce the error on the test and live server. 

Share this post


Link to post
Share on other sites

I'm interested in purchasing the Duplicate Member Logger, but I'm curious how users are fingerprinted so you can identify duplicate members?  Did you write the 3.4.x application of the same name?  I was using that on my 3.4.x forum and it worked well, at least until browsers started disabling Flash by default!  Now that I'm on 4.x, I'd like to use this again if it provides meaningful results. 

Thanks in advance for any insight.

 ..Al

Share this post


Link to post
Share on other sites
On 7/12/2019 at 10:55 AM, AtariAge said:

I'm interested in purchasing the Duplicate Member Logger, but I'm curious how users are fingerprinted so you can identify duplicate members?  Did you write the 3.4.x application of the same name?  I was using that on my 3.4.x forum and it worked well, at least until browsers started disabling Flash by default!  Now that I'm on 4.x, I'd like to use this again if it provides meaningful results. 

Thanks in advance for any insight.

 ..Al

Likewise! Hopefully @CodingJungle can provide some insight on how the app has been updated since the 3.4.x era (he did the original)

I do know that it uses PHP traits to fingerprint users, but not sure exactly how...

Share this post


Link to post
Share on other sites
Just now, Joy Rex said:

Likewise! Hopefully @CodingJungle can provide some insight on how the app has been updated since the 3.4.x era (he did the original)

 

On 7/12/2019 at 10:55 AM, AtariAge said:

I'm interested in purchasing the Duplicate Member Logger, but I'm curious how users are fingerprinted so you can identify duplicate members?  Did you write the 3.4.x application of the same name?  I was using that on my 3.4.x forum and it worked well, at least until browsers started disabling Flash by default!  Now that I'm on 4.x, I'd like to use this again if it provides meaningful results. 

Thanks in advance for any insight.

 ..Al

sorry these notifications must've gotten lost in the sea of emails i've been getting over the last few weeks.

I did not write the app for IPB 3, this is a new app from scratch. 

this app is very simplistic, it uses cookies to track the members. if they switch browsers or flush their cookie cache, it will be less effective in tracking them. with privacy being a big thing in Europe and the states atm, there aren't a whole lot of viable options when trying to persistently track users over multiple browsers or sessions. its intent is to give you an idea if account duplication is rampant on your site or not, its not meant to be an all encompassing tool. hope that helps.

oh i should mention, to those waiting for keywords update, i've been busy and should have an update out sometime this week, hopefully before the weekend. i made more changes than i thought (hence why i changed how it built keywords) and it wasn't just a simple drop back in the old code.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...