Jump to content

Make a link appear in the main menu ?


SecondSight
 Share

Recommended Posts

Hello ! )

I'm trying to make the link for the "Links Directory" app appear in the main menu for guests, but I can't make it... It appears for logged in members only (it's been like that for a long time and now I want to allow guest seeing it too).

=> I've checked the guests group's permissions in ACP/Membres/Groups/Permissions and it's ok (both "See category" and "View links" are checked).

guest-group-linsd.png.5b01b32dcfb9853a76125799f576a291.png

=> I've also checked ACP/Links/Categories/Permissions and it's ok too for all categories (guests translater is invite) :

category-permissions.thumb.png.4213cb850c0253491fdb1a4c51d13f90.png

=> I've checked ACP/System/Menu manager and I see the link does appear in the Main menu. But it doesn't appear for guests.

Edit : it appears now. :)

main-menu.thumb.png.c748a0fb160c63a6650d2426579ca6f9.png

I wonder what I've forgotten... What should I do now ?

Thank you ! :)

Edited by SecondSight
Link to comment
Share on other sites

@SecondSight

I the menu manager, click on the link you created, details should appear on the right side, Scroll to permission and select one of those:

Permissions REQUIRED

1) Show this item to users who can access its content.

2) I want to choose which groups can see this item. If you choose a group which cannot access the item's content, they will still be able to view the menu item.

I would pick the second option and select everyone.
Link to comment
Share on other sites

1 hour ago, Steph40 said:

1) Show this item to users who can access its content.

2) I want to choose which groups can see this item. If you choose a group which cannot access the item's content, they will still be able to view the menu item.

I would pick the second option and select everyone.

I tried both but it made no difference...

1 hour ago, CP said:

Have you checked the Applications/Links Directory permissions? 

It wasn't checked so I changed this and it made the link appear in the menu. :)

But I now have the "You do not have permission to access the Links Directory." message.

linksd.png.8718308f2fe379959460ab44ddf9dc06.png

What else can I try ?

Thank you. :)

Link to comment
Share on other sites

Go to Members/Groups then click "Edit" for guests then go to the Links Directory tab and make sure you have that turned on. I assume you must have it turned off. :) 

Edited by CP
Clarification
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...