Jump to content

Community

Raffles System


Adriano Faria

Recommended Posts

@Cyboman, I'm on a borrowed laptop.

The image on raffle view:

{template="thumbImage" group="global" app="raffles" params="$raffle->image, $raffle->title, 'medium', '', '', '', 'raffles_Image'"}

The extension name it's there (raffles_Image).

The extensions:

Capturar.png

It appears in the ACP -> System -> Files -> Storage Settings:

Capturar.png

 

Honestly, it seems right to me and I always used like that in all apps (Tutorials, Classifieds, Links, Quizzes, etc).

Link to comment
Share on other sites

10 hours ago, Adriano Faria said:

@Cyboman, I'm on a borrowed laptop.

The image on raffle view:


{template="thumbImage" group="global" app="raffles" params="$raffle->image, $raffle->title, 'medium', '', '', '', 'raffles_Image'"}

The extension name it's there (raffles_Image).

The extensions:

Capturar.png

It appears in the ACP -> System -> Files -> Storage Settings:

Capturar.png

 

Honestly, it seems right to me and I always used like that in all apps (Tutorials, Classifieds, Links, Quizzes, etc).

That's a bug in your app...

The extensions class name is Image and you're using Images  in view.php

\IPS\Output::i()->metaTags['og:image'] = \IPS\File::get( 'raffles_Images', $this->raffle->thumb )->url;

 

Link to comment
Share on other sites

Hello, my prize image is not showing up on the giveaway:

sniponeraf2.thumb.PNG.256c1118a25def61d18ed6b887f5041b.PNG

 

 

From the prize page:

sniponeraf1.thumb.PNG.52297be72da4bd5faf868d08008e5ce3.PNG

 

As far as I can tell the path to the uploaded image is (makes no sense):  

http://www.thebullspen.com/bradimages/wallpapers/downloads/monthly_2017_07/usfbottleopener.jpg.c36e59e70e893f9b503ca0228e7741d0.jpg

Now, when I try to upload new image I receive:

sniponeraf3.thumb.PNG.d6a3d7c917c6abc393b3309aa0787dcb.PNG

 

Here is the page: http://www.thebullspen.com/raffles/

 

What is wrong?

 

Thank you.

Edited by BradTBP
Link to comment
Share on other sites

There's nothing wrong with the image name, which is given by the framework; not something I can control. 

Regarding not showing and -200, please see: https://invisioncommunity.com/forums/topic/435365-there-was-a-problem-processing-the-uploaded-file-200/

Showing that it should be a image size limited by the host, I just added one test giveaway and works fine:

IMG_0806.thumb.PNG.273a27ddc59c46b825da0f0fa036ab80.PNG

 

IMG_0808.thumb.PNG.fc8c33374f6b9a39b81f007372067d96.PNG

 

 

IMG_0807.thumb.PNG.2627bb9ee407779b3b467212c02659d4.PNG

 

Both images, prize and giveaway, are the same. 

You have access to the support board: http://www.sosinvision.com.br/ips4/index.php?/raffles/raffle/2-test-adriano/

Edited by Adriano Faria
Link to comment
Share on other sites

17 hours ago, pilotguy said:

Ok.  I get the progress bar but nothing gets added.  I'll keep my eyes open here tomorrow.  Thanks friend.

Take a look here: http://www.sosinvision.com.br/ips4/index.php?/tracker/raffles/tried-to-add-membersgroups-r390/

Another user reported something similar, so I provided a quick fix. Definitive fix in a couple of days; I'll wait people test it a litte more.

:)

Btw, there are another two fixes there.

Link to comment
Share on other sites

The former error disappeared on the frontend, but now, if I try to edit my existing categories in ACP, as soon as I click on "edit":

Quote

Error: Class '\IPS\raffles\extensions\core\FileStorage\Icon' not found (0)
#0 /var/www/html/rxxxxxxx/system/File/Amazon.php(232): IPS\File\_Amazon->getGzipExtensions()
#1 /var/www/html/rxxxxxxx/system/File/Amazon.php(255): IPS\File\_Amazon->needsGzipVersion()
#2 /var/www/html/rxxxxxxx/system/File/File.php(499): IPS\File\_Amazon->load()
#3 /var/www/html/rxxxxxxx/applications/raffles/sources/Category/Category.php(215): IPS\_File::get('raffles_Icon', 'monthly_2017_07...')
#4 /var/www/html/rxxxxxxx/system/Node/Controller.php(467): IPS\raffles\_Category->form(Object(IPS\Helpers\Form))
#5 /var/www/html/rxxxxxxx/init.php(447) : eval()'d code(16): IPS\Node\_Controller->_addEditForm(Object(IPS\raffles\Category))
#6 /var/www/html/rxxxxxxx/system/Node/Controller.php(366): IPS\Node\rules_hook_ipsNodeController->_addEditForm(Object(IPS\raffles\Category))
#7 /var/www/html/rxxxxxxx/applications/raffles/modules/admin/raffles/categories.php(36): IPS\Node\_Controller->form()
#8 /var/www/html/rxxxxxxx/system/Dispatcher/Controller.php(85): IPS\raffles\modules\admin\raffles\_categories->form()
#9 /var/www/html/rxxxxxxx/system/Node/Controller.php(62): IPS\Dispatcher\_Controller->execute()
#10 /var/www/html/rxxxxxxx/applications/raffles/modules/admin/raffles/categories.php(31): IPS\Node\_Controller->execute()
#11 /var/www/html/rxxxxxxx/system/Dispatcher/Dispatcher.php(146): IPS\raffles\modules\admin\raffles\_categories->execute()
#12 /var/www/html/rxxxxxxx/admin/index.php(13): IPS\_Dispatcher->run()
#13 {main}

Seems to be a similar problem.

Additional information: I noticed before, that the category icons never worked. Uploading was ok in the category settings, but they weren't displayed.

Edited by Cyboman
Link to comment
Share on other sites

10 minutes ago, Cyboman said:

The former error disappeared on the frontend, but now, if I try to edit my existing categories in ACP, as soon as I click on "edit":

Seems to be a similar problem.

Additional information: I noticed before, that the category icons never worked. Uploading was ok in the category settings, but they weren't displayed.

In the tracker, please!

Link to comment
Share on other sites

@ekforum @BradTBP @Cyboman and all Raffles clientes: I just released Raffles 1.0.2 Beta 1: http://www.sosinvision.com.br/ips4/index.php?/files/file/28-raffles/

Please, download and test to see if the issues reported by you are fixed. If you find anything else, please report it in the Trarcker: http://www.sosinvision.com.br/ips4/index.php?/tracker/raffles/

Tks. :)

Link to comment
Share on other sites

3 hours ago, Adriano Faria said:

@ekforum @BradTBP @Cyboman and all Raffles clientes: I just released Raffles 1.0.2 Beta 1: http://www.sosinvision.com.br/ips4/index.php?/files/file/28-raffles/

Please, download and test to see if the issues reported by you are fixed. If you find anything else, please report it in the Trarcker: http://www.sosinvision.com.br/ips4/index.php?/tracker/raffles/

Tks. :)

I can`t access or download from your site.  I do have an account.  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy