Jump to content

Community

Raffles System


Adriano Faria

Recommended Posts

6 minutes ago, CyanideBurial said:

also if you have more than 2 prizes you can see the rest of the prizes in mobile view

As stated in this file description, post a bug in the Tracker if you believed you found a bug: http://www.sosinvision.com.br/ips4/index.php?/tracker/raffles/

Create an account and I’ll transfer you to the proper group then you can report. 

All reports will be fixed and available in a further version. 

Link to comment
Share on other sites

2 hours ago, CyanideBurial said:

also if you have more than 2 prizes you can't see the rest of the prizes in mobile view

Fixed.

 

On 8/28/2019 at 11:19 AM, me78569 said:

We are getting this same error again on Mopar1973man.com/raffles/ after trying to buy a ticket.  

 

We are on 1.3.1 and IPS was just updated to 4.4.6,  does the update to 1.3.2 fix this?

I can't reproduce.

Try yourself: https://www.sosinvision.com.br/ips4/index.php?/raffles/raffle/2-a-test-raffle/

Same set-up as you: Raffle using Commerce and no Members Shop installed.

I see you created and account (you already had one). I will release a new version during the weekend, probably... so if you have steps to reproduce, let me know by submitting a bug in the Tracker.

Edited by Adriano Faria
Link to comment
Share on other sites

@Adriano Faria  

 

I am trying to get the site owner to put in a ticket etc for our issue to sort it.  My account doesn't seem to be linked to the purchase so I can't do much. 

 

It appears to be linked to the members shop, but I dont see that installed in our system.  Again waiting for hte site owner.  we will put in a bug tracker when we get everything together.

Link to comment
Share on other sites

25 minutes ago, me78569 said:

My account doesn't seem to be linked to the purchase so I can't do much. 

I already changed your group to Raffles.

26 minutes ago, me78569 said:

It appears to be linked to the members shop, but I dont see that installed in our system. 

The message comes from the integration, yes, but as you can see in my screen video, I can't reproduce.

Anyway, we're not in same page, even if you can still reproduce in the marketplace version, you're not using it, so I won't do much. I only work with current version... and I can't reproduce on it.

Link to comment
Share on other sites

Alright well I figured it out.  For some reason the raffle creation process was not asking for a Ticket amount even though it was set to be a raffle in our admin side. 

 

I rechecked the raffle and saved then recreated the raffle and now it is working.  pretty weird.

Link to comment
Share on other sites

1 minute ago, me78569 said:

Alright well I figured it out.  For some reason the raffle creation process was not asking for a Ticket amount even though it was set to be a raffle in our admin side. 

 

I rechecked the raffle and saved then recreated the raffle and now it is working.  pretty weird.

Still can't reproduce:

zEZz4gS.png

 

Anyway, I will (re) take a look in the whole process. At least it's working for you now.

Link to comment
Share on other sites

What's New in Version 1.3.3:

New Feature:

  • From now on you can convert a review to a comment. A new moderator permission will control who can use the feature.

Enhancements:

  • Added ability to choose extra field position per field (sidebar or below raffle/giveaway description)
  • Script optimization due to new marketplace guidelines
    • drop columns from members table and use own table to store members preferences
  • Random sorting in Raffle feed widget
  • Rework in raffle post screen to make fields (type of payment, money and points) appears only when necessary
  • Rework in some templates

Fix:

  • Can't see all prizes in mobile devices
  • Participants messed up in mobile devices
Link to comment
Share on other sites

  • 4 weeks later...

@Adriano Faria

After updating from 1.3.1 to 1.3.3 we are getting Locked Task: Queue and throws error when hit Run button and the system logs show following:

SELECT member_id, raffle_access, raffle_submit, raffle_ban_participation FROM `core_members` WHERE raffle_access=0 OR raffle_submit=0 OR raffle_ban_participation=1 ORDER BY member_id ASC LIMIT 0,500
IPS\Db\Exception: Unknown column 'raffle_access' in 'field list' (1054)
#0 /xxxxxx/forum/system/Db/Select.php(373): IPS\_Db->preparedQuery('/*IPS\\raffles\\e...', Array, true)
#1 /xxxxxx/forum/system/Db/Select.php(578): IPS\Db\_Select->runQuery()
#2 /xxxxxx/forum/applications/raffles/extensions/core/Queue/membersTable.php(68): IPS\Db\_Select->count()
#3 /xxxxxx/forum/system/Task/Task.php(47): IPS\raffles\extensions\core\Queue\_membersTable->run(Array, 0)
#4 /xxxxxx/forum/applications/core/tasks/queue.php(43): IPS\_Task::runQueue()
#5 /xxxxxx/forum/system/Task/Task.php(356): IPS\core\tasks\_queue->IPS\core\tasks\{closure}()
#6 /xxxxxx/forum/applications/core/tasks/queue.php(55): IPS\_Task->runUntilTimeout(Object(Closure))
#7 /xxxxxx/forum/system/Task/Task.php(255): IPS\core\tasks\_queue->execute()
#8 /xxxxxx/forum/applications/core/modules/admin/settings/advanced.php(709): IPS\_Task->run()
#9 /xxxxxx/forum/system/Dispatcher/Controller.php(85): IPS\core\modules\admin\settings\_advanced->runTask()
#10 /xxxxxx/forum/applications/core/modules/admin/settings/advanced.php(34): IPS\Dispatcher\_Controller->execute()
#11 /xxxxxx/forum/system/Dispatcher/Dispatcher.php(152): IPS\core\modules\admin\settings\_advanced->execute()
#12 /xxxxxx/forum/admin/index.php(14): IPS\_Dispatcher->run()
#13 {main}

Please fix this.

Link to comment
Share on other sites

  • 3 weeks later...

I'm testing my Raffle System and using a test user to enter.  Upon raffle expiration, there is no message to me to pick a winner, and my ACP widget doesn't have any expired raffles listed.

 

EDIT: It finally appeared.  I wasn't sure it took some time.

Edited by LittleFang
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy