Jump to content

Community

Clubs Enhancements


Adriano Faria

Recommended Posts

On 9/6/2018 at 3:09 PM, Nebthtet said:

Somehow an option to manually add members disappeared for me (it's enabled in admin panel for sure, I've checked). Reinstalling the addon / clearing cache didn't help. It persists regardless of skin / language. It shouldn't be caused by any apps / plugins since I didn't add anything new. Also turning off everything except this didn't help. Any ideas how can I get this functionality back? It's super useful.

 

On 2/6/2019 at 4:50 AM, Nigel Moore said:

Hi there - we have this plugin setup and previously used it to manually add members to a club (instead of inviting them and waiting for them to accept).

However, we've just tried to do it again and we seem to be missing this "Add Members" button in our setup.

image.thumb.png.d0a3c121b8857144a70699cc135ab30e.png

Ours looks like this:

image.thumb.png.a8ea004b80cc8e4078d5acc854ad830d.png

@InvisionHQ and others - any ideas what we've broken?

There is a setting to allow to add members manually: Allow Club Owners to manually ADD MEMBERS?. It also requires to be an admin OR the club owner.

 

Link to comment
Share on other sites

On 2/11/2019 at 1:56 AM, Sonya* said:

Can we give a leader of the club this option? Any chance that you can implement this?

Can you please comment this? Is it possible to implement? We need homepage to be editable by leader as well (not only owner or admin).

Another question discussed here: can admins or owners disable Member tabs, so that nobody can see the list of the club?

 

Link to comment
Share on other sites

Hi, we've got another issue here trying to migrate data from custom club field into new_home_page_content of your plugin. Our custom field of type Editor has MEDIUMTEXT as type defined in database. But your field new_home_page_content is of type TEXT. When we try to migrate the data we get an SQL error:

#1406 - Data too long for column 'new_home_page_content' at row 2

Can you please consider to change the column type in the next version, so that Editor field can be safely used on it?

Edited by Sonya*
Link to comment
Share on other sites

This is happening with the 4.4 (beta 1) update

The program is great! My only complaint would be 'I renamed 'Clubs' to 'Support Groups' in the language which should not have an effect.

2019-02-23_12-33-25.jpg.4d1777fe690119cbbcd515d60e93426c.jpg

does not work at all; I have fiddled with it since the beginning, while it might work on other sites it does not on my IPS Hosted Cloud from Invisionpowerboard.

If you could look into this it would be great.

 

---

The issue is coming from this option in the Club Enhancements. Again I will stress this, while it might work on others, it is NOT working on mine.

When this option is turned on I get a blank map. 

---

Things I do see;

The google mapping system.

---

Things I don't see;

The markers when the addresses are put in.

Edited by Humanastorian
Link to comment
Share on other sites

So just purchased the plugin to convert some groups to clubs.

I think the Closed Club is precisely what we want.... I just think it is silly to not be able to "add members" as admin when it is closed?

Was there a reason for this?  I suppose have to make it an open or private club, add members, then switch the type. 

Link to comment
Share on other sites

3 hours ago, Maksim said:

So just purchased the plugin to convert some groups to clubs.

I think the Closed Club is precisely what we want.... I just think it is silly to not be able to "add members" as admin when it is closed?

Was there a reason for this?  I suppose have to make it an open or private club, add members, then switch the type. 

Yes, but I'll add "add members" also for "closed clubs" very soon.

Link to comment
Share on other sites

Hello, When you send a message to Club members, a conversation is created for each member. I sent a message to a Club with 81 members and ... 81 conversations were closed !!
I think it would be better if you created a conversation that included all the members.

Link to comment
Share on other sites

9 minutes ago, pequeno said:

Hello, When you send a message to Club members, a conversation is created for each member. I sent a message to a Club with 81 members and ... 81 conversations were closed !!
I think it would be better if you created a conversation that included all the members.

If you want that all members participate and reply in a conversation, then you should perhaps create a topic. Personal (or private) message (or conversation) is meant to be... private. 

Edited by Adriano Faria
Link to comment
Share on other sites

  • 2 weeks later...

There are two issues with the plugin:

  1. Manage Features -> Delete does not respect permissions. The owner of the club is able to delete the feature AND move all the contents of the club in any other forum on the site. This would make a big mess as the topics are just merged somewhere in the community and this cannot be redone. Can you please make this optional? Deleting features is already a default option as well as reordering. 
  2. Change Type. If a group the owner belongs to is not allowed to create clubs (no types are allowed) then the window is empty. There should be a check if changing club type makes sense.
    screenshot-localhost-2019_03.16-21-23-40.png.402ff1f76136d4c11a1e6c48d8c19fda.png

 

Link to comment
Share on other sites

When viewing a homepage on the club, for some reason - sometimes, the images don't show up. I suspect it's a lazy load problem because I do have that enabled, and it's something I have seen with other mods on here that seems to be a problem. When you go to edit the homepage for the club the image does show up, but when you save the image disappears again.

As you can see here (What's blurred isn't relevant) the image seems to be a thin line:

image.thumb.png.7fed288d7f8a1f2de39dbcbd5f1b45c3.png

This is something I have experienced with the FAQ and Member Notes app of which for the former @Daniel F suggested that this is because the mod isn't compatible with Lazy Load.

Edited by Tripp★
Link to comment
Share on other sites

On 3/26/2019 at 4:54 PM, Tripp★ said:

When viewing a homepage on the club, for some reason - sometimes, the images don't show up. I suspect it's a lazy load problem because I do have that enabled, and it's something I have seen with other mods on here that seems to be a problem. When you go to edit the homepage for the club the image does show up, but when you save the image disappears again.

As you can see here (What's blurred isn't relevant) the image seems to be a thin line:

image.thumb.png.7fed288d7f8a1f2de39dbcbd5f1b45c3.png

This is something I have experienced with the FAQ and Member Notes app of which for the former @Daniel F suggested that this is because the mod isn't compatible with Lazy Load.

Thanks for reporting. I'm working to a maintenance release and I'll add also this fix.

 

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy