Jump to content

Even chmod 777 does not work?

Recommended Posts


I've been struggling with this issue for a few days now... and it seems i'm not able to solve this matter by googling it so i hope somebody has an idea what to do...

I got myself a new Centos 7 VPS and installed/configured everything to my best knowledge .. and got the board transferred from the "old" vps to this new one.

i added a vhosts configuration to apache which is working for a few sites and seems fine.

I transferred all files and database to the new machine and everything went fine untill i wanted to open the website and everything was F**'d up getting this message:


Sorry, there is a problem

Something went wrong. Please try again.

Error code: EX0

Technical Details

RuntimeException: COULD_NOT_WRITE_FILE (0)
#0 /var/vhosts/website/public_html/forum/system/File/File.php(240): IPS\File\_FileSystem->save()
#1 /var/vhosts/website/public_html/forum/system/Output/Javascript/Javascript.php(964): IPS\_File::create('core_Theme', 'front_front_wid...', ';(function($,_,...', 'javascript_core', true)
#2 /var/vhosts/website/public_html/forum/system/Output/Javascript/Javascript.php(931): IPS\Output\_Javascript::_writeJavascript(';(function($,_,...', 'front_widgets.j...', 'core', 'front')
#3 /var/vhosts/website/public_html/forum/system/Output/Javascript/Javascript.php(874): IPS\Output\_Javascript::_writeJavascriptFromResultset(Array, 'front_widgets.j...', 'core', 'front')
#4 /var/vhosts/website/public_html/forum/system/Output/Output.php(480): IPS\Output\_Javascript::compile('core', 'front', 'front_widgets.j...')
#5 /var/vhosts/website/public_html/forum/system/Output/Output.php(291): IPS\_Output::_getJavascriptFileObject('core', 'front', 'front_widgets.j...')
#6 /var/vhosts/website/public_html/forum/system/Dispatcher/Front.php(570): IPS\_Output->js('front_widgets.j...', 'core', 'front')
#7 /var/vhosts/website/public_html/forum/system/Dispatcher/Front.php(67): IPS\Dispatcher\_Front::baseJs()
#8 /var/vhosts/website/public_html/forum/system/Dispatcher/Dispatcher.php(86): IPS\Dispatcher\_Front->init()
#9 /var/vhosts/website/public_html/forum/index.php(13): IPS\_Dispatcher::i()
#10 {main}


So whatever i tried  it didn't work out ..   so i figured  to check the upgrade page in the admin folder to checkout the rights and server specs..  it gave me this:




Ahh  the permissions.. off course...  so i chmodded these folders.... but it seems that it doesnt work... and whatever i try ...  i doesnt work. But on the shell it shows me this:

  • drwxrwxrwx. 169 777 user 393216 Jun 20 20:31 uploads
  • drwxrwxrwx.   2 777 user 4096 Jun 17 21:15 plugins
  • drwxrwxrwx.   5 777 user 4096 Jun 17 21:15 applications

Here some commands in random order i tried to fix this issue ..   but i'm lost ..

  • chmod -R 777 uploads/
  • chown user:apache public_html/
  • chown apache:apache public_html/
  • chmod -R u+x plugins/
  • usermod -a -G apache user
  • usermod -a -G user apache
  • chcon -R -t httpd_sys_content_t /var/vhosts/website/
  • ....


Does anybody has an idea what to do/check?

Thanks in advance!






Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...