Jump to content

Community

TheJackal84

(DF42) Profile Video

Recommended Posts

1 hour ago, Lucas James said:

@TheJackal84

The new version 1.0.2 is not updated in IPS Downloads. Please do that as I can only download available 1.0.1

I thought I already updated it here sorry, Its been updated now to 1.0.2

Added missing language strings

  • Show profile video
  • Hide profile video
Edited by TheJackal84

Share this post


Link to post
Share on other sites

From what I can tell if someone who has permission to set a song and then they get that permission revoked they still have the song and can't remove it. Is there any way for me to fix this? Or could you do a fix for it.

Share this post


Link to post
Share on other sites
Just now, Dylan Clancy said:

From what I can tell if someone who has permission to set a song and then they get that permission revoked they still have the song and can't remove it. Is there any way for me to fix this? Or could you do a fix for it.

if you / the admin goes to their profiles you will have access to edit / remove it, I will look into adding a setting to remove all from certain usergroups in a update if you wanted

Share this post


Link to post
Share on other sites
3 minutes ago, TheJackal84 said:

if you / the admin goes to their profiles you will have access to edit / remove it, I will look into adding a setting to remove all from certain usergroups in a update if you wanted

Yes, but we have monthly donator thingies and having to go through every time can be a pain. Would be nice for it to check if the user is in the groups selected which can use the profile song and if they aren't in that then it won't show on their profile.

Share this post


Link to post
Share on other sites
Just now, Dylan Clancy said:

Yes, but we have monthly donator thingies and having to go through every time can be a pain. Would be nice for it to check if the user is in the groups selected which can use the profile song and if they aren't in that then it won't show on their profile.

to be honest it is not that much of a advanced plugin to add tasks etc to it, I could add a simple setting so if you remove certain usergroups from being able to use it you will then select that user group again and it will remove them all from members in that group, It will take about another 5 seconds to acomplish afer you choose to disallow certain groups from using it

Share this post


Link to post
Share on other sites
7 minutes ago, TheJackal84 said:

to be honest it is not that much of a advanced plugin to add tasks etc to it, I could add a simple setting so if you remove certain usergroups from being able to use it you will then select that user group again and it will remove them all from members in that group, It will take about another 5 seconds to acomplish afer you choose to disallow certain groups from using it

I'm sorry I don't follow what you're saying here.

Share this post


Link to post
Share on other sites
Just now, Dylan Clancy said:

I'm sorry I don't follow what you're saying here.

the plugin itself it not that advanced to automatically check if the user is still in the groups what can use it and then remove any what ain't, I might be able to write a code what you will run yourself to remove any from users what are no longer in the groups it will be a simple click on a button

Share this post


Link to post
Share on other sites
8 minutes ago, TheJackal84 said:

the plugin itself it not that advanced to automatically check if the user is still in the groups what can use it and then remove any what ain't, I might be able to write a code what you will run yourself to remove any from users what are no longer in the groups it will be a simple click on a button

Alright, if you could please yes. Just need it to check if they are in any of the listed groups and then remove the profile song if they aren't

Share this post


Link to post
Share on other sites
Just now, Dylan Clancy said:

Alright, if you could please yes. Just need it to check if they are in any of the listed groups and then remove the profile song if they aren't

will do, I got a couple more update to other stuff to finish then I will get started on this ?

Share this post


Link to post
Share on other sites

Just bought your plugin - didn't see it doesn't work with 4.3 yet. Installed and definately not working. When will you have an 4.3 update?

Edited by Blisslandia

Share this post


Link to post
Share on other sites
28 minutes ago, Blisslandia said:

Just bought your plugin - didn't see it doesn't work with 4.3 yet. Installed and definately not working. When will you have an 4.3 update?

It says in the version compatibility 4.2, 4.3, I would not put 4.3 if it definitely didn't work on 4.3, as you can see from the demo link on the file

https://ipsdev.org/index.php?/profile/1-thejackal/

it is working on 4.3.

What theme are you using and are you adding the correct embed url and not the page's url?

Share this post


Link to post
Share on other sites
13 minutes ago, TheJackal84 said:

It says in the version compatibility 4.2, 4.3, I would not put 4.3 if it definitely didn't work on 4.3, as you can see from the demo link on the file

https://ipsdev.org/index.php?/profile/1-thejackal/

it is working on 4.3.

What theme are you using and are you adding the correct embed url and not the page's url?

I have 4.3.3, all plugins and applications except for yours and default IPS are disabled.

Screenshot shows the attempt at the sidebar video.

836140522_ScreenShot2018-06-04at11_24_43PM.thumb.png.5620c10cb20e3c8794e7410c59213e9c.png

 

Screenshot of video URL attached as well.

imageproxy.php?img=&key=dc6d6c31aa595442321399351_ScreenShot2018-06-04at11_26_18PM.thumb.png.b75187f1c9caafa0e5a80efd59ec8e43.png

 

using this theme

 

 

 

Edited by Blisslandia
theme addition

Share this post


Link to post
Share on other sites
4 minutes ago, Blisslandia said:

321399351_ScreenShot2018-06-04at11_26_18PM.thumb.png.b75187f1c9caafa0e5a80efd59ec8e43.png

Look at the url you added and look at the way it says to add youtube url's.

Use the embed url, not the pages url

https://www.youtube.com/embed/0-EF60neguk

is OK

https://www.youtube.com/watch?=4&v=0-EF60neguk

is not

Edited by TheJackal84

Share this post


Link to post
Share on other sites
2 minutes ago, TheJackal84 said:

Look at the url you added and look at the way it says to add youtube url's.

Use the embed code not the pages url


https://www.youtube.com/embed/0-EF60neguk

is OK


https://www.youtube.com/watch?=4&v=0-EF60neguk

is not

AH-HA! YEP that's the issue. I think general users will miss that detail and want to cut and paste the URL from youtube like I did.

Is there an easy cut and paste step or does everyone have to edit the code there?

1 minute ago, Blisslandia said:

AH-HA! YEP that's the issue. I think general users will miss that detail and want to cut and paste the URL from youtube like I did.

Is there an easy cut and paste step or does everyone have to edit the code there?

hmmm... on my dev site it works. Live site it does not. Must be conflicting with something...

2 minutes ago, Blisslandia said:

AH-HA! YEP that's the issue. I think general users will miss that detail and want to cut and paste the URL from youtube like I did.

Is there an easy cut and paste step or does everyone have to edit the code there?

hmmm... on my dev site it works. Live site it does not. Must be conflicting with something...

ACTIVITY it works, sidebar it does not...

Share this post


Link to post
Share on other sites
8 minutes ago, Blisslandia said:

I think general users will miss that detail and want to cut and paste the URL from youtube like I did.

I will check it and see what I can come up with, But you should always read things, that could of said by adding a embed you argree to x/y/z ( lol just kidding but true )

Edited by TheJackal84

Share this post


Link to post
Share on other sites
On 6/4/2018 at 11:34 PM, Blisslandia said:

I think general users will miss that detail and want to cut and paste the URL from youtube like I did.

You we should be giving people easy ways to use tools, or it's possible they won't really use them. Make it easier for them. The users on our site are not developers and wouldn't look for this type of detail.

Share this post


Link to post
Share on other sites
26 minutes ago, Blisslandia said:

You we should be giving people easy ways to use tools, or it's possible they won't really use them. Make it easier for them. The users on our site are not developers and wouldn't look for this type of detail.

you can always change the language in the ACP, go to languages and search ProfileVideo_desc then change it to however you want it to display.

and you gotta remember this is not a youtube profile video, it allows embedding any video via iframe

Edited by TheJackal84

Share this post


Link to post
Share on other sites
Just now, Matthew March said:

the plugin as a whole uploaded it added the embed link went to my profile and nothing showed up 

are you using a youtube video? if so you need to add the embed code not the url,

example, Normal youtube video link https://www.youtube.com/watch?v=qeMFqkcPYcg

link you would use will be https://www.youtube.com/embed/qeMFqkcPYcg

I did write a update what tranfsers the url so if it was the top one you added it will automatically change the url to the embed one, but I have not got round to uploading it yet, I will get it out this week at some point

Share this post


Link to post
Share on other sites
7 minutes ago, TheJackal84 said:

are you using a youtube video? if so you need to add the embed code not the url,

example, Normal youtube video link https://www.youtube.com/watch?v=qeMFqkcPYcg

link you would use will be https://www.youtube.com/embed/qeMFqkcPYcg

I did write a update what tranfsers the url so if it was the top one you added it will automatically change the url to the embed one, but I have not got round to uploading it yet, I will get it out this week at some point

yeah I added the embed url  I'll try again

Share this post


Link to post
Share on other sites
1 minute ago, Matthew March said:

yeah I added the embed url  I'll try again

let me know, if not send me a PM with your site and your profile on your site etc, ( make sure a video link is added to your profile, don't remove it etc )

Share this post


Link to post
Share on other sites
3 minutes ago, TheJackal84 said:

let me know, if not send me a PM with your site and your profile on your site etc, ( make sure a video link is added to your profile, don't remove it etc )

will do

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...