Jump to content

Community

TheJackal84

(DF42) Members Social Info (Support Topic)

Recommended Posts

3 minutes ago, BDD said:

Beautiful. Thank you.

Cancel your renewal of it and when it expires send me a message I will give you a years free, Sorry for the delay in support I missed some past support posts etc and was not ignoring you etc

Share this post


Link to post
Share on other sites
8 hours ago, MagicalFire said:

@TheJackal84 

you can add, e.g. teamspeak or uid address ???

So far if all goes well I won't need to add any more ever again

spacer.png

You can do them all yourself :biggrin:

As I said so far it's going good but I need to do more testing then write in the code to manually add any existing ones to the new way and then transfer the data in the database over to the new one etc when upgrading, But it should not take too long

More good new, because I loop everything over and over the new code replacing the old one is about 90% smaller than the older one ( I love cutting code down and it still do the same or even more than before lol )

Share this post


Link to post
Share on other sites
56 minutes ago, TheJackal84 said:

So far if all goes well I won't need to add any more ever again

spacer.png

You can do them all yourself :biggrin:

Oh, that's gonna be awesome!

Share this post


Link to post
Share on other sites

Updated to 3.0.0

New Features

  • You can now create your own social links :biggrin:
  • Create unlimited social links
  • Create tabs to place the social link settings in
  • Re-wrote lots of php & html

Note...

  • If upgrading it will run a code that will convert all the old settings / icons / images over to the new database columns and will also create all 31 social links what will either be disabled or enabled depending your current setup, it will also transfer all current member data over to link up with the newly created social links
Edited by TheJackal84

Share this post


Link to post
Share on other sites
On 10/24/2019 at 11:54 AM, TheJackal84 said:

Updated to 3.0.0

New Features

  • You can now create your own social links :biggrin:
  • Create unlimited social links
  • Create tabs to place the social link settings in
  • Re-wrote lots of php & html

Note...

  • If upgrading it will run a code that will convert all the old settings / icons / images over to the new database columns and will also create all 31 social links what will either be disabled or enabled depending your current setup, it will also transfer all current member data over to link up with the newly created social links

Looking good! Is there a way (other than deleting the tab and other than the CSS hack you gave me previously) to NOT use a particular tab?

I can disable/enable individual sites within a tab, but I can't see a way to disable a tab.

EDIT TO ADD: I just checked, and the tab that was previously hidden by the CSS is showing up again on the site (without anything on it).

Edited by BDD

Share this post


Link to post
Share on other sites
1 minute ago, BDD said:

Looking good! Is there a way (other than deleting the tab and other than the CSS hack you gave me previously) to NOT use a particular tab?

I can disable/enable individual sites within a tab, but I can't see a way to disable a tab.

Just delete them, Only when updating it added those tabs and all the sites, there is a setting where you can add all those default ones listed so if you did delete and want any again they are all there, I can't be sure who had what settings enabled so wrote the update to add them all and just have them disabled or enabled depending on the actual setting of it, If it was a new install etc they all would be blank and you would add your own tabs and then either the default sites or your own ones

Share this post


Link to post
Share on other sites
Just now, TheJackal84 said:

Just delete them, Only when updating it added those tabs and all the sites, there is a setting where you can add all those default ones listed so if you did delete and want any again they are all there, I can't be sure who had what settings enabled so wrote the update to add them all and just have them disabled or enabled depending on the actual setting of it, If it was a new install etc they all would be blank and you would add your own tabs and then either the default sites or your own ones

Got it. Will do. Thanks.

Share this post


Link to post
Share on other sites
Just now, BDD said:

Got it. Will do. Thanks.

I will add a setting though to toggle them enabled or disabled like you can do on the social sites, but will wait for a few more ideas etc before I release a new update, So if any of you lot have any ideas let me know

Share this post


Link to post
Share on other sites

After update, this is what I'm seeing on my own profile:

image.png.e06cac2578a5d242df8eb25c8e84fc14.png

When I login as someone else (a test account), I'm not seeing the Social Info section on my main profile at all.

I'm not seeing it on the test account profile, either, even though social info is filled in.

I'm also seeing "Currently MSI__loc_editing_social_info" in the ABOUT section for these users.

Share this post


Link to post
Share on other sites
9 minutes ago, BDD said:

When I login as someone else (a test account), I'm not seeing the Social Info section on my main profile at all.

I'm not seeing it on the test account profile, either, even though social info is filled in.

what settings do you have to view?

{{if \IPS\Settings::i()->MSI__GroupsView == 'all' or \IPS\Member::loggedIn()->inGroup( explode(',', \IPS\Settings::i()->MSI__GroupsView ) )}}

that basically says if all groups can view then allow or if member in group your-settings to allow then view, if not don't show

10 minutes ago, BDD said:

I'm also seeing "Currently MSI__loc_editing_social_info" in the ABOUT section for these users.

Missing lang string, I will sort that

Share this post


Link to post
Share on other sites
13 minutes ago, TheJackal84 said:

what settings do you have to view?


{{if \IPS\Settings::i()->MSI__GroupsView == 'all' or \IPS\Member::loggedIn()->inGroup( explode(',', \IPS\Settings::i()->MSI__GroupsView ) )}}

that basically says if all groups can view then allow or if member in group your-settings to allow then view, if not don't show

Missing lang string, I will sort that

Thanks. For some reason the Members group wasn't selected (just the New Members group). That's fixed now. 

What about the repeated icons over and over?

Share this post


Link to post
Share on other sites
23 hours ago, BDD said:

What about the repeated icons over and over?

@TheJackal84 This is an issue that the update introduced that was not a problem before -- can you please tell me when this will be fixed/anything I can do to address it in the meantime? Thanks.

Share this post


Link to post
Share on other sites
35 minutes ago, BDD said:

@TheJackal84 This is an issue that the update introduced that was not a problem before -- can you please tell me when this will be fixed/anything I can do to address it in the meantime? Thanks.

when you hover them what is showing as the title?

Share this post


Link to post
Share on other sites
1 hour ago, TheJackal84 said:

when you hover them what is showing as the title?

Okay. Weird. Looking at this a bit more, it looks like it's showing icons from other profiles -- some are profiles that don't exist anymore -- and it's also changing info on the tabs in multiple profiles when I change them on the one profile. I'll provide more detail here. Let me know if you have other questions. 

Is there a way for me to revert to the older version of this while you get it sorted out? (Unless you think you can get it done very soon -- I was about to launch my community.)

So I have 3 profiles set up right now -- my main admin profile, and 2 testing member profiles. I initially set up the social icons using my main admin profile, but when I go into the other 2 testing member profiles, what I put into the main admin profile is showing on the Social Info tabs when when I click on the Social Info icon. On the 2 testing member profiles themselves, one does not show any icons on the profile, and the other shows all the same icons as what I put in my main admin profile (even though both profiles show the info in tabs when I select the Social Info icon to edit).

The second set of icons shown here were the ones for this profile. The other sets are from old profiles (of members from testing that have since been deleted).

(I don't remember setting up Social Info for my testing profile that's showing the icons now -- can't be 100% sure since it's been a while.)

In answer to your question, what's showing for the hovers looks fine (just not for the right people). So for example, the FB icon has "Facebook: https://www.facebook.com/username/" (with the correct username, just not listing it here).

More details that probably don't matter since it seems like it's an issue of showing the wrong profile icons:

The span class is "MSI__BlockContent" for each.

Not sure if it matters, but here's the FA span info, too:

<span class="fa-stack fa-2x">
	<i class="fa fa-circle fa-stack-2x"></i>
	<i class="fa fa-facebook fa-stack-1x fa-inverse"></i>
</span>

Thanks.

Edited by BDD

Share this post


Link to post
Share on other sites
20 hours ago, BDD said:

Okay. Weird. Looking at this a bit more, it looks like it's showing icons from other profiles -- some are profiles that don't exist anymore -- and it's also changing info on the tabs in multiple profiles when I change them on the one profile. I'll provide more detail here. Let me know if you have other questions. 

A reply regarding anticipated timeline on this would be appreciated. If it's going to be a while, please let me know the best way to revert to the old version.

(I have a copy of it downloaded -- I suppose I could just uninstall this version and reinstall the old one. I'll lose my customizations, I know, but then at least it wouldn't be showing something broken. I was about to go live and I'd rather not have to do it with this broken.)

Thanks.

Share this post


Link to post
Share on other sites
1 hour ago, BDD said:

A reply regarding anticipated timeline on this would be appreciated. If it's going to be a while, please let me know the best way to revert to the old version.

(I have a copy of it downloaded -- I suppose I could just uninstall this version and reinstall the old one. I'll lose my customizations, I know, but then at least it wouldn't be showing something broken. I was about to go live and I'd rather not have to do it with this broken.)

Thanks.

What are they showing like in the ACP? are they duplicated there or are they just there once? if they are duplicated there just delete the duplicated ones, If you want to send me ACP login via PM I can look into it

EDIT

My fault 👊 should be OK now download and update :biggrin:

Edited by TheJackal84

Share this post


Link to post
Share on other sites
53 minutes ago, TheJackal84 said:

What are they showing like in the ACP? are they duplicated there or are they just there once? if they are duplicated there just delete the duplicated ones, If you want to send me ACP login via PM I can look into it

EDIT

My fault 👊 should be OK now download and update :biggrin:

Looking good so far, thank you. 😊

For future reference, where would I see this kind of info in the ACP?

Share this post


Link to post
Share on other sites
2 minutes ago, BDD said:

For future reference, where would I see this kind of info in the ACP?

Go to the tabs on the left hand side and look for the members one, inside there you will see the members social info tab and its all in there

Share this post


Link to post
Share on other sites
2 hours ago, TheJackal84 said:

Go to the tabs on the left hand side and look for the members one, inside there you will see the members social info tab and its all in there

When I go there, I just see the info for the tabs -- ohhhh -- is that what you meant? Were you thinking the tabs were duplicated somehow?

(I thought you were saying I should look at the list of icons used for each member, and I wasn't seeing that.)

Share this post


Link to post
Share on other sites
Just now, BDD said:

When I go there, I just see the info for the tabs -- ohhhh -- is that what you meant? Were you thinking the tabs were duplicated somehow?

(I thought you were saying I should look at the list of icons used for each member, and I wasn't seeing that.)

I thought it may of duplicated the social links etc in the list there, but it didn't it was a missing section in the query to pull the members links, it's all sorted now so shouldn't be any problems, I will be adding a update soon to place them in more places so if you have any ideas / thoughts let me know  

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy