Jump to content

Community

Fosters

Bookmarks - Support Topic

Recommended Posts

Just discovered this app causing an issue with the Moderator Reported Content page. When I disable the app, everything works perfect on the moderator page. 

I just upgraded to 4.4 and Bookmarks version 1.6

https://example.com/modcp/reports/

[[Template core/front/tables/rows is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

 

854168122_ScreenShot2019-02-26at12_30_21AM.thumb.png.5666f7cef9b5a477b06346f263274e31.png

 

 

Here is the system error

 

1289000984_ScreenShot2019-02-26at12_32_54AM.thumb.png.9eff7a0369871c79d8661fdfaad0e638.png

Edited by Chris027

Share this post


Link to post
Share on other sites
4 hours ago, Fosters said:

This seems to be a bug in IPS 4.4.0 😞

I made a support request and they replied that the problem comes from a third-party application. I had to look for myself that it came from bookmarks.

Share this post


Link to post
Share on other sites

bookmark is causing an error with receiving report notifications.

If I disable the bookmark app I can see the report notifications. 

When the bookmark app is on I get error.

See the error in the photo below.

This in on a clean install 4.4 with only the bookmarks app installed.

[[Template core/front/modcp/reportListOverview is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

1219283277_ScreenShot2019-06-11at19_21_31.png.01eee6132d230caeb7d3b88e5263e6ae.png

 

Share this post


Link to post
Share on other sites
10 hours ago, beats23 said:

bookmark is causing an error with receiving report notifications.

If I disable the bookmark app I can see the report notifications. 

When the bookmark app is on I get error.

See the error in the photo below.

This in on a clean install 4.4 with only the bookmarks app installed.

[[Template core/front/modcp/reportListOverview is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

1219283277_ScreenShot2019-06-11at19_21_31.png.01eee6132d230caeb7d3b88e5263e6ae.png

 

Do you see any logged errors in the system log?

Share this post


Link to post
Share on other sites

Yes I see this error.

 

 

 

The URL of page the error occurred on was http://www.testsite.com/index.php?app=core&module=modcp&controller=modcp&tab=reports&overview=1&csrfKey=9cd25948acd84b96ceba4252ddc98f44

IPS\Db\Exception::105

SELECT core_rc_comments.*, author.*, bookmark.* FROM `_betacore_rc_comments` AS `core_rc_comments`  LEFT JOIN `_betacore_members` AS `author` ON author.member_id = core_rc_comments.comment_by  LEFT JOIN `_betabookmark_items` AS `bookmark` ON bookmark.member_id=1 AND bookmark.class='IPS\core\Reports\Comment' AND bookmark.content_id=core_rc_comments.id WHERE id=0 LIMIT 0,1
Column 'id' in where clause is ambiguous

 

BACKTRACE

#0 /Users/nice/Sites/www.testsite.com/system/Db/Select.php(373): IPS\_Db->preparedQuery('/*IPS\\Content\\_...', Array, true)
#1 /Users/nice/Sites/www.testsite.com/system/Db/Select.php(436): IPS\Db\_Select->runQuery()
#2 /Users/nice/Sites/www.testsite.com/system/Content/Item.php(3733): IPS\Db\_Select->rewind()
#3 /Users/nice/Sites/www.testsite.com/system/Content/Item.php(3445): IPS\Content\_Item->_comments('IPS\\core\\Report...', 1, 0, NULL, NULL, NULL, NULL, NULL, NULL, false, NULL)
#4 /Users/nice/Sites/www.testsite.com/system/Theme/Theme.php(840) : eval()'d code(3455): IPS\Content\_Item->comments(1, 0, 'date', 'desc')
#5 /Users/nice/Sites/www.testsite.com/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_core_front_modcp->reportListOverview(Object(IPS\Helpers\Table\Content), Array, Array, NULL, false)
#6 /Users/nice/Sites/www.testsite.com/system/Helpers/Table/Table.php(555): IPS\Theme\_SandboxedTemplate->__call('reportListOverv...', Array)
#7 /Users/nice/Sites/www.testsite.com/applications/core/extensions/core/ModCp/Reports.php(99): IPS\Helpers\Table\_Table->__toString()
#8 /Users/nice/Sites/www.testsite.com/applications/core/modules/front/modcp/modcp.php(104): IPS\core\extensions\core\ModCp\_Reports->manage()
#9 /Users/nice/Sites/www.testsite.com/system/Dispatcher/Controller.php(96): IPS\core\modules\front\modcp\_modcp->manage()
#10 /Users/nice/Sites/www.testsite.com/system/Dispatcher/Dispatcher.php(152): IPS\Dispatcher\_Controller->execute()
#11 /Users/nice/Sites/www.testsite.com/index.php(13): IPS\_Dispatcher->run()
#12 {main}

 

Share this post


Link to post
Share on other sites
On 6/12/2019 at 11:04 AM, beats23 said:

Yes I see this error.

 

 

 

The URL of page the error occurred on was http://www.testsite.com/index.php?app=core&module=modcp&controller=modcp&tab=reports&overview=1&csrfKey=9cd25948acd84b96ceba4252ddc98f44

IPS\Db\Exception::105


SELECT core_rc_comments.*, author.*, bookmark.* FROM `_betacore_rc_comments` AS `core_rc_comments`  LEFT JOIN `_betacore_members` AS `author` ON author.member_id = core_rc_comments.comment_by  LEFT JOIN `_betabookmark_items` AS `bookmark` ON bookmark.member_id=1 AND bookmark.class='IPS\core\Reports\Comment' AND bookmark.content_id=core_rc_comments.id WHERE id=0 LIMIT 0,1
Column 'id' in where clause is ambiguous

 

BACKTRACE


#0 /Users/nice/Sites/www.testsite.com/system/Db/Select.php(373): IPS\_Db->preparedQuery('/*IPS\\Content\\_...', Array, true)
#1 /Users/nice/Sites/www.testsite.com/system/Db/Select.php(436): IPS\Db\_Select->runQuery()
#2 /Users/nice/Sites/www.testsite.com/system/Content/Item.php(3733): IPS\Db\_Select->rewind()
#3 /Users/nice/Sites/www.testsite.com/system/Content/Item.php(3445): IPS\Content\_Item->_comments('IPS\\core\\Report...', 1, 0, NULL, NULL, NULL, NULL, NULL, NULL, false, NULL)
#4 /Users/nice/Sites/www.testsite.com/system/Theme/Theme.php(840) : eval()'d code(3455): IPS\Content\_Item->comments(1, 0, 'date', 'desc')
#5 /Users/nice/Sites/www.testsite.com/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_core_front_modcp->reportListOverview(Object(IPS\Helpers\Table\Content), Array, Array, NULL, false)
#6 /Users/nice/Sites/www.testsite.com/system/Helpers/Table/Table.php(555): IPS\Theme\_SandboxedTemplate->__call('reportListOverv...', Array)
#7 /Users/nice/Sites/www.testsite.com/applications/core/extensions/core/ModCp/Reports.php(99): IPS\Helpers\Table\_Table->__toString()
#8 /Users/nice/Sites/www.testsite.com/applications/core/modules/front/modcp/modcp.php(104): IPS\core\extensions\core\ModCp\_Reports->manage()
#9 /Users/nice/Sites/www.testsite.com/system/Dispatcher/Controller.php(96): IPS\core\modules\front\modcp\_modcp->manage()
#10 /Users/nice/Sites/www.testsite.com/system/Dispatcher/Dispatcher.php(152): IPS\Dispatcher\_Controller->execute()
#11 /Users/nice/Sites/www.testsite.com/index.php(13): IPS\_Dispatcher->run()
#12 {main}

 

Are you using the last IPS version?
This was an bug in IPS which was fixed in 4.4.2 

 

Share this post


Link to post
Share on other sites
22 hours ago, Fosters said:

Are you using the last IPS version?
This was an bug in IPS which was fixed in 4.4.2 

 

no I'm on 4.4.0 Ill update later and see

Share this post


Link to post
Share on other sites
On 6/21/2019 at 1:37 PM, jair101 said:

It seems that members cannot delete bookmarks. Is this intentional?

No, the bookmark link should be replaced with a "remove_bookmark" link

Share this post


Link to post
Share on other sites
2 hours ago, Fosters said:

No, the bookmark link should be replaced with a "remove_bookmark" link

OK, Then a future suggestion to be able to remove bookmarks from the bookmarks panel as well :)

Share this post


Link to post
Share on other sites

@Fosters Template error

Quote

Error: Call to undefined method IPS\forums\Topic\Post::canBookmark() in /home/nginx/domains/adonismale.com/public/system/Theme/Theme.php(845) : eval()'d code:1073
Stack trace:
#0 /home/nginx/domains/mycommunity.com/public/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_forums_front_topics->post(Object(IPS\forums\Topic), Object(IPS\forums\Topic\Post), 'topic_comment', 'forums', 'forums', 'forums_Topic')
#1 /home/nginx/domains/mycommunity.com/public/system/Theme/Theme.php(845) : eval()'d code(1609): IPS\Theme\_SandboxedTemplate->__call('post', Array)
#2 /home/nginx/domains/mycommunity.com/public/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_forums_front_topics->postContainer(Object(IPS\forums\Topic), Object(IPS\forums\Topic\Post), Array, '')
#3 /home/nginx/domains/mycommunity.com/public/system/Theme/Theme.php(845) : eval()'d code(3854): IPS\Theme\_SandboxedTemplate->__call('postContainer', Array)
#4 /home/nginx/domains/mycommunity.com/public/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_forums_front_topics->topic(Object(IPS\forums\Topic), Array, NULL, Array, NULL, '\n\n\n\t\n\t<ul class...', Array)
#5 /home/nginx/domains/mycommunity.com/public/applications/forums/modules/front/forums/topic.php(434): IPS\Theme\_SandboxedTemplate->__call('topic', Array)
#6 /home/nginx/domains/mycommunity.com/public/system/Dispatcher/Controller.php(96): IPS\forums\modules\front\forums\_topic->manage()
#7 /home/nginx/domains/mycommunity.com/public/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
#8 /home/nginx/domains/mycommunity.com/public/applications/forums/modules/front/forums/topic.php(39): IPS\Content\_Controller->execute()
#9 /home/nginx/domains/mycommunity.com/public/system/Dispatcher/Dispatcher.php(152): IPS\forums\modules\front\forums\_topic->execute()
#10 /home/nginx/domains/mycommunity.com/public/index.php(13): IPS\_Dispatcher->run()
#11 {main}

 

Share this post


Link to post
Share on other sites

Hi,

I may be missing something - running version 1.6.0 on ips 4.4.5 - when I try to show bookmarks by category as a user, it shows all bookmarks no matter which category I select. Should the chosen category on the right side filter the shown posts on the left? Thanks.

2073605319_Screenshot2019-08-13at10_31_20.thumb.png.36ee3ea30acb34bbc25721d2b6bab6d4.png

Share this post


Link to post
Share on other sites
Just now, Michael Collins said:

Hi,

I may be missing something - running version 1.6.0 on ips 4.4.5 - when I try to show bookmarks by category as a user, it shows all bookmarks no matter which category I select. Should the chosen category on the right side filter the shown posts on the left? Thanks.

2073605319_Screenshot2019-08-13at10_31_20.thumb.png.36ee3ea30acb34bbc25721d2b6bab6d4.png

Yes, it should indeed show and filter only the links from this category. I'll take a look later today.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...