Jump to content

Javascript disabled for security


Recommended Posts

We are trying to add just simple javascript affiliate adverts for amazon products.

But when we try to add them in the invision inbuilt advertisements system we get this error message - Javascript disabled for security

How can we monetize our sites using affiliate marketing when the invision software is blocking our affiliate codes from running?

There must be a workaround to allow javascript?

Please help and thanks in advance


Link to comment
Share on other sites


Well that was the thing, the adverts were not shoing on the front of the site.

But we have worked it out and will let you know as this might catch out other members moving from HTTP to HTTPS

Amazon link code for their widgets is set to use http.

This is the issue the remote amazon script didn't use https only http and here all that goes on http is blocked

In our files the request should be issued with https on the url not http to resolve this , the amazon side is ok they usually have working urls on http and https , but the requesting url here must be written with https otherwise it will not pass

So I have manually edited the widget code to https and it has worked


Link to comment
Share on other sites


I've just reactivated my Amazon Affilliate ads on now that I'm using https and they are not showing up for me either.

The code supplied doesn't specify http or https, it just uses the double slash format which I believe is meant to work whatever the site is using.

<div class="alignleft">
     <script type="text/javascript">
       	amzn_assoc_ad_type = "banner";
	amzn_assoc_marketplace = "amazon";
	amzn_assoc_region = "US";
	amzn_assoc_placement = "assoc_banner_placement_default";
	amzn_assoc_campaigns = "audible";
	amzn_assoc_banner_type = "category";
	amzn_assoc_isresponsive = "true";
	amzn_assoc_banner_id = "inserttrackingidhere";
	amzn_assoc_tracking_id = "millenniumdes-20";
	amzn_assoc_linkid = "c0396d4cbacb07db3a532184451b449f";
     <script src="//z-na.amazon-adsystem.com/widgets/q?ServiceVersion=20070822&Operation=GetScript&ID=OneJS&WS=1"></script>

Has anyone else had this problem? They don't supply a https specific code, it's just meant to work on either.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...