Jump to content

Community

(itzverified) member verification


tsdevelopment
 Share

Recommended Posts

  • 2 months later...
  • 2 weeks later...
  • 2 weeks later...

 

On 7/14/2019 at 1:44 PM, KIKI_ said:

How can we implement premium fa icons into this? As it does not recognise we have purchased the pro icons. Or a way to upload it directly?

If you use premium fa icons in your forum you can use it. You only have to find a way ho to use the premium file in you application. 

Link to comment
Share on other sites

18 hours ago, KIKI_ said:

Are you able to add this or provide a way to upload custom ones? Or give us some words on how to get this working

I think it's possible to customize your template themes. You could change the global html template and add font awesome premium links there. But a more cleaner way would be a plugin to add font awesome premium. Maybe there already exists one.

I've seen you already opened another thread with that question:

It's the same anwer I would give.

Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...
  • 2 months later...
21 hours ago, GTAPoliceMods said:

@tsdevelopment Great plugin however do you plan on adding a feature that shows the badge across the whole community (posts, threads, etc)?

Because at the moment it only shows on their profile page.

Thank you!

Hi,

thank you for purchasing my plugin. Currently the verification icon will be displayed next to the username in the user's profile and forum posts. I am always open for feature requests.

Link to comment
Share on other sites

23 hours ago, tsdevelopment said:

Hi,

thank you for purchasing my plugin. Currently the verification icon will be displayed next to the username in the user's profile and forum posts. I am always open for feature requests.

At the moment it only shows on their profile page. Is there a setting to enable it to show on their forum posts/community content?

Also for the "Custom Icons" setting is there a way to make the icon smaller? Because I feel it's way bigger than the default "verified" icon. @tsdevelopment

Edited by GTAPoliceMods
Link to comment
Share on other sites

18 hours ago, GTAPoliceMods said:

At the moment it only shows on their profile page. Is there a setting to enable it to show on their forum posts/community content?

Also for the "Custom Icons" setting is there a way to make the icon smaller? Because I feel it's way bigger than the default "verified" icon. @tsdevelopment

Maybe you are using a custom theme so my hooks are not working?

10 hours ago, jmw253 said:

Getting the following error when installing on 4.4.9:

image.thumb.png.0395505b0f9bc1fb56ec03cf0f296696.pngimageproxy.php?img=&key=45efd0820426aabfimageproxy.php?img=&key=45efd0820426aabfimageproxy.php?img=&key=45efd0820426aabf

I will check this. Maybe there were changes in 4.4.9

Link to comment
Share on other sites

11 hours ago, tsdevelopment said:

Maybe you are using a custom theme so my hooks are not working?

I will check this. Maybe there were changes in 4.4.9

I even tried the Default theme that comes with IPB and still does not show up next to their posts/content (only on their profile page)

Also, it does work with 4.4.9 but when I assign a custom icon to someone I get this error but it still assigns them the icon haha

--disregard, had to update another application--

 

Edited by GTAPoliceMods
Link to comment
Share on other sites

40 minutes ago, GTAPoliceMods said:

Also, it does work with 4.4.9 but when I assign a custom icon to someone I get this error but it still assigns them the icon haha

This error is from Raffles System. The error is about didn’t find columns in core_members table. 

These columns were dropped from core tables a few versions behind. Update Raffles System if you’re not using latest version. 

Link to comment
Share on other sites

1 minute ago, Adriano Faria said:

This error is from Raffles System. The error is about didn’t find columns in core_members table. 

These columns were dropped from core tables a few versions behind. Update Raffles System if you’re not using latest version. 

If I have a raffle active right now will it cause a conflict if I update it? 

(sorry for going off topic)

Link to comment
Share on other sites

11 hours ago, tsdevelopment said:

Okay. I wil check this ASAP. I already got an email from Invision and with a bug ticket 😮 

Looks that the code that I posted was because of a different application (my bad!)

Only thing left at the moment is

  • Figuring out why the check mark/icon is only showing up on their profile and not everywhere else
  • Help make the "Custom Icon" smaller (the custom icon compared to the default "verified" icon is so much bigger) See here: http://prntscr.com/qb0mki

Look forward in hearing back :)

Thank you @tsdevelopment!

Edited by GTAPoliceMods
Link to comment
Share on other sites

13 hours ago, GTAPoliceMods said:

Looks that the code that I posted was because of a different application (my bad!)

Only thing left at the moment is

  • Figuring out why the check mark/icon is only showing up on their profile and not everywhere else
  • Help make the "Custom Icon" smaller (the custom icon compared to the default "verified" icon is so much bigger) See here: http://prntscr.com/qb0mki

Look forward in hearing back 🙂

Thank you @tsdevelopment!

So, I updated my test environment to the latest version and checked all the discussed things. Now I can say:

  • I will add a class to make custom icons the same size as the verification icon
  • In my fresh environment the custom icon will be displayed in profile and in posts. See this picture here:

    itzverified-icon-in-posts.png.268282113af49c6f587483e94957685a.png

    Maybe another plugin removes several classes from the HTML markup. I will check if I can use another hook.

    Update: I looked for the icon in the posts. I use the class cAuthorPane_author to add these icons. Maybe the class is missing in your installation b/c of another plugin?

    itzverified-icon-in-posts-class.png.826d94fa704c8e43fdee84dee433ebf4.png
Edited by tsdevelopment
See update
Link to comment
Share on other sites

5 hours ago, tsdevelopment said:

So, I updated my test environment to the latest version and checked all the discussed things. Now I can say:

  • I will add a class to make custom icons the same size as the verification icon
  • In my fresh environment the custom icon will be displayed in profile and in posts. See this picture here:

    itzverified-icon-in-posts.png.268282113af49c6f587483e94957685a.png

    Maybe another plugin removes several classes from the HTML markup. I will check if I can use another hook.

    Update: I looked for the icon in the posts. I use the class cAuthorPane_author to add these icons. Maybe the class is missing in your installation b/c of another plugin?

    itzverified-icon-in-posts-class.png.826d94fa704c8e43fdee84dee433ebf4.png

Good to hear!

However it's not just me having that issue, others too. I disabled all my plugins/apps and used the default theme, still no sign of the icon on posts/content sadly 😕

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy