Jump to content

Community

TAMAN

Advanced Footer [ Support topic ]

Recommended Posts

37 minutes ago, InsideEdge said:

thanks again for your help,  the data-height="200"  doesn't work and I'm not seeing a scroll effect.  Maybe I can just try using a latest topics list instead.

Sorry, i just realize that it only works if the tweet limit is auto 

<a class="twitter-timeline" href="https://twitter.com/TwitterDev?ref_src=twsrc%5Etfw" data-height="200" data-theme="dark">Tweets by TwitterDev</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>

 

Share this post


Link to post
Share on other sites

Hi @TAMAN,

Sorry that I am not following this topic in details. Can you advise the best way to upgrade now that this is an app, but with preserving the previous settings? Do I need to delete the old plugin and create all blocks from scratch?

Share this post


Link to post
Share on other sites
Just now, jair101 said:

Hi @TAMAN,

Sorry that I am not following this topic in details. Can you advise the best way to upgrade now that this is an app, but with preserving the previous settings? Do I need to delete the old plugin and create all blocks from scratch?

Yes the plugin is no longer supported. there is no upgrade from plugin to the new app.

this is an application now, and way better than before, you must install this as an application now.

Share this post


Link to post
Share on other sites

Hi @TAMAN

Thanks for this Application, well worth every penny.

Would it be possible that you could add another option for the Position Configuration? The ability to show Outside the main body layout but contained (using the ipsLayout_container css style).

Share this post


Link to post
Share on other sites
Just now, TDBF said:

Hi @TAMAN

Thanks for this Application, well worth every penny.

Would it be possible that you could add another option for the Position Configuration? The ability to show Outside the main body layout but contained (using the ipsLayout_container css style).

Hi,

Sorry, the main purpose of this potion is so the footer layout will be outside of ips body layout and without any width.

ipsLayout_container has a fixed with and padding's.

But you can apply the styles with a custom css if you wanted 🙂 

 

-Set the footer outside the main body layout 

-add in custom.css

.af_Container {
    max-width: 1340px; /*Change if needed*/
    margin: 0 auto;
}

 

Share this post


Link to post
Share on other sites
1 hour ago, TAMAN said:

Hi,

Sorry, the main purpose of this potion is so the footer layout will be outside of ips body layout and without any width.

ipsLayout_container has a fixed with and padding's.

But you can apply the styles with a custom css if you wanted 🙂 

 

-Set the footer outside the main body layout 

-add in custom.css


.af_Container {
    max-width: 1340px; /*Change if needed*/
    margin: 0 auto;
}

 

Yeah I was too quick to hit the post button on this matter, I realised this afterwards. I also had to change the hook to be displayed before the footer and not after the body, as I have other plugins which need to be displayed before this one.

I really like they changes you have done recently, makes it much easier 'things' they way I want. Cheers.

Share this post


Link to post
Share on other sites
39 minutes ago, TDBF said:

Yeah I was too quick to hit the post button on this matter, I realised this afterwards. I also had to change the hook to be displayed before the footer and not after the body, as I have other plugins which need to be displayed before this one.

I really like they changes you have done recently, makes it much easier 'things' they way I want. Cheers.

You’re welcome welcome! 🙂 

 

Share this post


Link to post
Share on other sites

Found a bug or issue.

If you create a block row, then create a copy of the original row (a couple of duplicates) and then add new blocks to the original container, you cannot reorder the blocks within that container (Block Row).

If you move a block to another block row, it will move, but you cannot move it back to its original container.

I had to delete all the blocks and their containers and start again, but not creating a duplicate (copy) of the block container, and it worked as expected.

Share this post


Link to post
Share on other sites
Just now, TDBF said:

If you create a block row, then create a copy of the original row (a couple of duplicates) and then add new blocks to the original container, you cannot reorder the blocks within that container (Block Row).

Not bug, unfortunately this is how the IPS node reorder works i guess

I have a put a limit on how many blocks can be added in a row. blocks can not be reordered if the row container is full.

 

Here is a simple solution. if your row is full and you want to reorder the blocks, take one of the blocks out by drag and doping into another row and then move it back. you will be able to reorder now. sometimes a page refresh is required if you cant move the block outside.

To me, the problem is totally fine because the solution is a simple drag and drop task 🙂 

Just now, TDBF said:

it will move, but you cannot move it back to its original container.

A page refresh is required here.

 

Just now, TDBF said:

I had to delete all the blocks and their containers and start again, but not creating a duplicate (copy) of the block container, and it worked as expected.

just create an empty row and disable it so it doesn't show anywhere. now use this row whenever you want to reorder a row if it is full

Share this post


Link to post
Share on other sites
4 minutes ago, TAMAN said:

Not bug, unfortunately this is how the IPS node reorder works i guess

I have a put a limit on how many blocks can be added in a row. blocks can not be reordered if the row container is full.

 

Here is a simple solution. if your row is full and you want to reorder the blocks, take one of the blocks out by drag and doping into another row and then move it back. you will be able to reorder now. sometimes a page refresh is required if you cant move the block outside.

To me, the problem is totally fine because the solution is a simple drag and drop task 🙂 

A page refresh is required here.

 

just create an empty row and disable it so it doesn't show anywhere. now use this row whenever you want to reorder a row if it is full

Yeah I have just been playing around and noticed this.

Is there anyway I can remove the 4 block limitation to a row?

Just now, TDBF said:

Yeah I have just been playing around and noticed this.

Is there anyway I can remove the 4 block limitation to a row?

Nvm, I found how I can change this 🙂

Share this post


Link to post
Share on other sites

Hi Taman, 

I am trying to replicate the old plugin layout with the app and I am facing two issues. 

1. Is it possible to use the compact block for facebook?

With the plugin it used to be like that:

image.png.a2bf3e024d039317cd97e7076f8fc74c.png

Now with the app it is:

image.thumb.png.8b9cff4c14043a2bd527ac45b09ba540.png

 

2. Is it possible to use two block one above the other? In the plugin I could add About us and Members below each other:

image.png.12d38ff7523a1f18203d99c2e8d222b4.png

Now it looks like there could be only a single block in a column per row...

Share this post


Link to post
Share on other sites
Posted (edited)

Also is it possible to display just the members profile picture like in my screenshot above? Or they are always shown with names and groups?

Edit - I did it with css.

Still, a bit disappointing that we lost quite a few settings. 

Edited by jair101

Share this post


Link to post
Share on other sites
2 hours ago, jair101 said:

1. Is it possible to use the compact block for facebook?

With the plugin it used to be like that:

Facebook, and twitter embeds will be removed on next version, you need to use the custom html block for that

create a custom html block and your facebook embed page https://developers.facebook.com/docs/plugins/page-plugin/

<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.0&appId=377652052627662&autoLogAppEvents=1';
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<div class="fb-page" data-href="https://www.facebook.com/facebook/" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"></div>

 

2 hours ago, jair101 said:

2. Is it possible to use two block one above the other? In the plugin I could add About us and Members below each other:

Not possible any more, sorry.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi @TAMAN,

I think I've discovered a potential conflict between Advanced Footer and @Kevin Carwile's Collabs app.

I've configured the AF to display feeds from recent forum posts and media.  Normally, AF displays fine, like this:

AF1.thumb.jpg.55bbfadc908b45f66e18e8baf810e977.jpg

When I am in a Collab ("Domain" on my site) category listing, everything is fine.  However, when I am actually inside a Domain things change drastically: in many cases the feeds disappear completely:

AF2.thumb.jpg.7a301f02314c79c13a4868d697d6f244.jpg

and in other Domains the Forums feed changes to conform to whatever is in the Domain currently being viewed (below, the topics are in the example Domain forum):

AF3.thumb.jpg.7a0aaec64840d8440aafc008c4aff306.jpg

Just in case AF is for some reason somehow supposed to display only what's in the viewed Domain, I uploaded a test image into said Domain and refreshed the AF.  Nothing new shows up in Recent Media.  So the Collab/Domain seems to be messing with the AF feed block settings.

I'm hoping a fix for this can be found, as the AF obviously can't be restricted by app (which might be a good idea for a later version)?

Thanks!

Edited by liquidfractal

Share this post


Link to post
Share on other sites
33 minutes ago, liquidfractal said:

Hi @TAMAN,

I think I've discovered a potential conflict between Advanced Footer and @Kevin Carwile's Collabs app.

I've configured the AF to display feeds from recent forum posts and media.  Normally, AF displays fine, like this:

 

When I am in a Collab ("Domain" on my site) category listing, everything is fine.  However, when I am actually inside a Domain things change drastically: in many cases the feeds disappear completely:

 

and in other Domains the Forums feed changes to conform to whatever is in the Domain currently being viewed (below, the topics are in the example Domain forum):

 

Just in case AF is for some reason somehow supposed to display only what's in the viewed Domain, I uploaded a test image into said Domain and refreshed the AF.  Nothing new shows up in Recent Media.  So the Collab/Domain seems to be messing with the AF feed block settings.

I'm hoping a fix for this can be found, as the AF obviously can't be restricted by app (which might be a good idea for a later version)?

Thanks!

mmm, Have you contacted Kevin about this? 

Share this post


Link to post
Share on other sites
Posted (edited)
41 minutes ago, TAMAN said:

mmm, Have you contacted Kevin about this? 

I will...but thought I'd mention it here in case you could see anything glaringly apparent in the code.  But in the meantime I'll try getting in touch.

Do you have any plans to add a per-app configurability to the AF?  Selfish question I know, but thought I'd ask anyway. 🙂

 

Edited by liquidfractal

Share this post


Link to post
Share on other sites

Its because of the way that collabs works. It filters all content queries to the context of a specific collab when a collab is the container of a page being viewed.

Thats just how the collabs app is able to do what it does in an abstract way. 

Share this post


Link to post
Share on other sites
On 5/14/2018 at 11:24 AM, TAMAN said:

[data-pagemodule="system"][data-pagecontroller="register"] .af_Container,[data-pagemodule="system"][data-pagecontroller="login"] .af_Container {display:none}

 

Hi,

This is weird.

I applied that code and the footer does not show on

https://www.walkingfootball.com/login/

So all should be good.

However I have just recieved - AdSense Publisher Policy Violation for that very page

Any ideas?

Share this post


Link to post
Share on other sites
Just now, Unlucky said:

Hi,

This is weird.

I applied that code and the footer does not show on

https://www.walkingfootball.com/login/

So all should be good.

However I have just recieved - AdSense Publisher Policy Violation for that very page

Any ideas?

No idea.

This is a css style hides an element on a page, thats all.

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

Hello, first off I am a big Taman fan.

Having a problem though getting the advanced footer to work or even be visible. I must be missing something very basic since this seems to be working for others.

I had the Magnum theme and Advanced Footer plugin and left site alone for a while. Came back today and did forum upgrades and then the colors/contrast/everything essentially broke. So, I installed the latest Magnum theme and lost all customization. This fixed all of the contrast issues from the upgrade and I've updated most of the configs by now.  

Unfortunately, as would be predicted, the advanced footer was no longer working right -- but I did read this support thread and do understand that it's an application now. However, I've tried installing/reinstalling the app (after uninstalling the plugin) and now I cannot get anything to appear as an advanced footer. For a short moment I got one column to work but cannot reproduce that. 

I've been trying every tweak I could think of on the settings but so far not getting anything, so unless I can resolve this it's goodbye to my advanced footer, which makes me sad because it was perfect for its purpose and also gave me a Twitter feed.

I'm on IPS cloud hosting using the latest versions: IPB 4.3.4.

Edited by Eric Allione

Share this post


Link to post
Share on other sites
Posted (edited)
Just now, Eric Allione said:

Hello, first off I am a big Taman fan.

Having a problem though getting the advanced footer to work or even be visible. I must be missing something very basic since this seems to be working for others.

I had the Magnum theme and Advanced Footer plugin and left site alone for a while. Came back today and did forum upgrades and then the colors/contrast/everything essentially broke. So, I installed the latest Magnum theme and lost all customization. This fixed all of the contrast issues from the upgrade and I've updated most of the configs by now.  

Unfortunately, as would be predicted, the advanced footer was no longer working right -- but I did read this support thread and do understand that it's an application now. However, I've tried installing/reinstalling the app (after uninstalling the plugin) and now I cannot get anything to appear as an advanced footer. For a short moment I got one column to work but cannot reproduce that. 

I've been trying every tweak I could think of on the settings but so far not getting anything, so unless I can resolve this it's goodbye to my advanced footer, which makes me sad because it was perfect for its purpose and also gave me a Twitter feed.

I'm on IPS cloud hosting using the latest versions: IPB 4.3.4.

Hi,

Here is how you can create footer rows and blocks in the new application


First off check the advanced footer main settings.

  • Customization -> Advanced footer -> Settings -> Configurations - >  Who can see? 
    Check the "who can see" here and make sure that everyone can see it. 

     

After that you need to create footer rows and blocks, and it is quite easy. just like forums when you create Categories and then forums inside the categories. 🙂 

In the advanced footer, you create rows and then blocks in the rows.

 

Create a row

  1. Go to Customization -> Advanced footer -> Blocks.
    Click on Create New button on top right corner of the page. make sure the "Themes" setting is selected to all. when you create the row.
    91174afaa694befb7550492ac3bd6859.png


     
  2. After creating a footer row, now you need to add blocks in this row.
    Click on Create block button and add your blocks.
    f757b5f513b17001b1192f13dd28d35b.png

    d929e4dec10df41ad6329cf4403656f4.png

 

After following this steps, the advanced footer should show on your website. 

 

Edited by TAMAN

Share this post


Link to post
Share on other sites

I just doublechecked, and as far as I know I followed each of those instructions exactly. Have been repeatedly emptying my cache.

I'm willing to settle for the native footer in Magnum -- but I would lose my Twitter feed or it seems the ability to use raw HTML such as to embed Twitter with raw html. 

However, this little bit in custom.css is no longer doing its trick to get rid of the dotted lines and make them solid:

.af_Container .linksBlo .ipsDataList li, .af_Container .articlesBlo li {border-bottom: 1px solid;}

Maybe that's because this only ever applied to the advanced footer, but it would be nice to get rid of those dotted lines in the native footer in the absence of the advanced footer.

Share this post


Link to post
Share on other sites
Just now, Eric Allione said:

However, this little bit in custom.css is no longer doing its trick to get rid of the dotted lines and make them solid:


.af_Container .linksBlo .ipsDataList li, .af_Container .articlesBlo li {border-bottom: 1px solid;}

Maybe that's because this only ever applied to the advanced footer, but it would be nice to get rid of those dotted lines in the native footer in the absence of the advanced footer.

.ta-Footer .quicklinks .ipsDataList li, .ta-Footer .mArticles li {
    border-style: solid;
    border-width: 0 0 1px 0;
}

 

Just now, Eric Allione said:

I just doublechecked, and as far as I know I followed each of those instructions exactly. Have been repeatedly emptying my cache.

 

Have you checked if the row you created is enabled? 

7995adde81f094e198f84a2e20e062af.png

 

Have you checked if the blocks you create has the right permissions 

f2d60012747add94c52e42701f77f735.png

 

Have you checked if the row you created is for ALL themes?

06a42a27813a40abdcd3c1c825fcb798.png

 

 

If still no hope then send a message with a login info i can check it for you.

Share this post


Link to post
Share on other sites
Posted (edited)

Your custom css worked and it looks much better like that. Thank you!

But rows are enabled, yes. Will send you credentials. 

Edit: Taman resolved my issue. Turned out the Magnum theme just needed to be reinstalled again, and for some reason something became corrupted in my global template the first time I tried to reinstall it.

ADVANCED FOOTER IS WORKING 🙂

Edited by Eric Allione

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×