Jump to content

Discord Integration


Ahmad E.

Recommended Posts

5 hours ago, Vanucci said:

I asked a while back for blogs too. 

Yeah, I haven't been able to work on this for a while due to work and life.

5 hours ago, Vanucci said:

Be great if it worked on any kind of topic created, especially applications 

I'm working on an update which I'll be releasing soon (once I get my renewal sorted out and can test on 4.2.x myself).

Link to comment
Share on other sites

1 hour ago, Ahmad E. said:

Yeah, I haven't been able to work on this for a while due to work and life.

I'm working on an update which I'll be releasing soon (once I get my renewal sorted out and can test on 4.2.x myself).

Great to hear it. If you want to use my site as testing you can, its only up for showcase purposes so doesnt actually do anything, so if you break it, no issues. 

Link to comment
Share on other sites

On 27/07/2017 at 4:36 PM, Vanucci said:

Great to hear it. If you want to use my site as testing you can, its only up for showcase purposes so doesnt actually do anything, so if you break it, no issues. 

Thanks for the offer but I actually prefer to do testing locally using my development stack that I have setup :).

Link to comment
Share on other sites

Hey,

would a few of you please do me a favor and test out this build: https://github.com/ABSAhmad/IpsDiscordIntegration/releases/tag/v1.2.0-alpha?

As it states, it should not be used in production but on a test server (or locally).
I just want to know how well it performs (hoping a few have staging servers setup that they can test on).
Everything should be working except for name syncing.

Link to comment
Share on other sites

1 hour ago, Logan Ferezy said:

When will this be updated for 4.2?

I'm working on a major update which will support 4.2.x: https://github.com/ABSAhmad/IpsDiscordIntegration/releases/tag/v1.2.0-alpha.3
Unfortunately, there are only few testers which is the main reason it is taking so long.

While not officially supported, the latest 1.1.x version seems to be working on 4.2.x too. A few clients seem to be using it without reporting any problems.

Link to comment
Share on other sites

6 minutes ago, Vanucci said:

ok, uploaded and overwritten old files, killed website, 500 error. 

 

Made fresh IPS install, installed app as new and gave 500 error 

This page isn’t working

www.thisdomain.that is currently unable to handle this request.

HTTP ERROR 500

When you say "uploaded and overwritten old files", does that mean that you do this manually? Please use the provided release and upload it using the ACP tools: https://github.com/ABSAhmad/IpsDiscordIntegration/releases

Link to comment
Share on other sites

42 minutes ago, QualeDesigns said:

Hi, I just purchased your app, but I'm having some issues with getting the Discordbot to function.

I'll send you a PM with my questions

Thanks in advance :)

Curious as im seeing alot of people saying they have issues with the discord bot. 

 

This app isnt a bot per say like 

9c89fd7754217cabb2b49bc9b9f2099b.png

 

This is a bot i have running on my server. 

Do you see something similar on your offline list b0a6d9ac40ae51f967ec0e5fcc5335f8.png

 

But the same bot as the top pic does my posting 

bc003bfb1aab6ea3c1bd8d2fa6bd90d3.png

 

so when you say you're struggling to get it to function, what is it thats not happening ? 

I have version 4.2.1 with latest github version of this app and php7.1

Link to comment
Share on other sites

I'm also running the latest IPS, Github Release and PHP versions on my server.

The bot comes online when I handshake, so it appears to be working, however:

First, I didn't change the discord role of usergroups, but those are now adjusted accordingly (I think?).
Next, there should be additional configuration available per forum / blog / gallery on which threads to relay new posts/content from?

I can't find those settings anywhere?
Of course I tried searching for the settings by typing "Discord" in AdminCP, but that would be too easy haha

 

(I installed locally with composer from source and uploaded to where the files need to be)

 

What am I missing?

Edited by QualeDesigns
Link to comment
Share on other sites

the forum specific setting are on the forums part of the acp 

99a2bd89e35decd80dea6b760adf22d1.png

 

cick forums, then edit forum of choice, click posting settings and you should see the below. 

 

The bot will not stay online as this application isnt about that. Hard to explain, but for the bot to stay online you need to host a bot, such as Red Discord Bot  Which is what I use and host myself hence mine always being online. Whether it says online of offline, the bot will still post using this application. 

 

8afb1eb0caa6fbaca125c20a72289f75.png

 

 

I havent changed any roles and left them alone for now. 

Edited by Vanucci
Link to comment
Share on other sites

I installed https://github.com/ABSAhmad/IpsDiscordIntegration/releases/tag/v1.2.0-alpha.3 on my forum with "IPB 4.2.1".

I am able to get New Topics to post my specified announcements channel on discord.

I am also able to see when replies are made to those Topics.

Will there be a way for the Post Reply to actually show a preview or a snippet of the reply?
 

After making sure everything was working properly. 

I upgraded my forum from 4.2.1 to 4.2.2 and the forum posting integration still works.

I have received no errors at all.

Link to comment
Share on other sites

Hi Ahamad,

I purchased your product and love it so far. 

I'm having one complication that I hope you can assist with. 

I have a group created in my IPB. For this example I will use Group "Rank 21: Brigadier General". 

On the admin cp in members-> groups I click this specific group, navigate to discord tab and select the role "Rank 21: Brigadier General" (which is already listed because I created the role in our Discord) and click "Save". 

I then go to members tab -> members in the admin cp and go to my own name on the member list. I have my Group set as "Rank 21: Brigadier General" with secondary groups set as admin. 

After this, if I go to our discord (I'm running the windows client) and click my own name  on the users list I do not see the role set as "Rank 21: Brigadier General". 

If you could please explain how to correct this I would appreciate it. 

Edited by Aaron Figueroa
Link to comment
Share on other sites

Hello, thanks for you app ! =)
When I put the
redirect URIs ".../ applications / discord / interface / oauth / auth.php" in the app discord , I have the following message :

2017-08-13_21h52_25.png.e9ce2255298c94c6dd1e9a26d34b8ae4.png

 

After entering the IDs I am redirected, the bot is created but I do not have the additional tab for the posts that appeared


 
When I want to edit a forum :
UPDATE `ibf_forums_forums` forums_forums  SET `parent_id`=121,`redirect_url`=NULL,`skin_id`='0',`can_view_others`=true,`permission_showtopic`=false,`show_rules`='0',`qa_rate_questions`='*',`qa_rate_answers`='*',`forum_allow_rating`=false,`disable_sharelinks`=false,`inc_postcount`=true,`allow_poll`=true,`discord_channel_approved`='337952230160203778',`discord_channel_unapproved`='337952230160203778',`discord_post_topics`=true,`discord_post_unapproved_topics`=false,`discord_post_posts`=true,`discord_post_unapproved_posts`=false,`discord_topic_format`='{poster} has just posted a new topic called: "{title}". Read more: {link}',`discord_post_format`='{poster} has just posted a new post to the topic: "{title}". Read more: {link}',`sub_can_post`=true,`redirect_on`=false WHERE id=3 
IPS\Db\Exception: Unknown column 'discord_channel_approved' in 'field list' (1054)
#0 /home/forum/www/system/Db/Db.php(990): IPS\_Db->preparedQuery('UPDATE `ibf_for...', Array)
#1 /home/forum/www/system/Patterns/ActiveRecord.php(492): IPS\_Db->update('forums_forums', Array, Array)
#2 /home/forum/www/system/Node/Model.php(2202): IPS\Patterns\_ActiveRecord->save()
#3 /home/forum/www/system/Node/Model.php(2986): IPS\Node\_Model->save()
#4 /home/forum/www/system/Node/Controller.php(391): IPS\Node\_Model->saveForm(Array)
#5 /home/forum/www/applications/forums/modules/admin/forums/forums.php(123): IPS\Node\_Controller->form()
#6 /home/forum/www/system/Dispatcher/Controller.php(85): IPS\forums\modules\admin\forums\_forums->form()
#7 /home/forum/www/system/Node/Controller.php(62): IPS\Dispatcher\_Controller->execute()
#8 /home/forum/www/applications/forums/modules/admin/forums/forums.php(39): IPS\Node\_Controller->execute()
#9 /home/forum/www/system/Dispatcher/Dispatcher.php(146): IPS\forums\modules\admin\forums\_forums->execute()
#10 /home/forum/www/admin/index.php(13): IPS\_Dispatcher->run()
#11 {main}

 

Edited by Julien Costes
Link to comment
Share on other sites

18 hours ago, Julien Costes said:

Hello, thanks for you app ! =)
When I put the
redirect URIs ".../ applications / discord / interface / oauth / auth.php" in the app discord , I have the following message :

2017-08-13_21h52_25.png.e9ce2255298c94c6dd1e9a26d34b8ae4.png

 

After entering the IDs I am redirected, the bot is created but I do not have the additional tab for the posts that appeared


 
When I want to edit a forum :

UPDATE `ibf_forums_forums` forums_forums  SET `parent_id`=121,`redirect_url`=NULL,`skin_id`='0',`can_view_others`=true,`permission_showtopic`=false,`show_rules`='0',`qa_rate_questions`='*',`qa_rate_answers`='*',`forum_allow_rating`=false,`disable_sharelinks`=false,`inc_postcount`=true,`allow_poll`=true,`discord_channel_approved`='337952230160203778',`discord_channel_unapproved`='337952230160203778',`discord_post_topics`=true,`discord_post_unapproved_topics`=false,`discord_post_posts`=true,`discord_post_unapproved_posts`=false,`discord_topic_format`='{poster} has just posted a new topic called: "{title}". Read more: {link}',`discord_post_format`='{poster} has just posted a new post to the topic: "{title}". Read more: {link}',`sub_can_post`=true,`redirect_on`=false WHERE id=3 
IPS\Db\Exception: Unknown column 'discord_channel_approved' in 'field list' (1054)
#0 /home/forum/www/system/Db/Db.php(990): IPS\_Db->preparedQuery('UPDATE `ibf_for...', Array)
#1 /home/forum/www/system/Patterns/ActiveRecord.php(492): IPS\_Db->update('forums_forums', Array, Array)
#2 /home/forum/www/system/Node/Model.php(2202): IPS\Patterns\_ActiveRecord->save()
#3 /home/forum/www/system/Node/Model.php(2986): IPS\Node\_Model->save()
#4 /home/forum/www/system/Node/Controller.php(391): IPS\Node\_Model->saveForm(Array)
#5 /home/forum/www/applications/forums/modules/admin/forums/forums.php(123): IPS\Node\_Controller->form()
#6 /home/forum/www/system/Dispatcher/Controller.php(85): IPS\forums\modules\admin\forums\_forums->form()
#7 /home/forum/www/system/Node/Controller.php(62): IPS\Dispatcher\_Controller->execute()
#8 /home/forum/www/applications/forums/modules/admin/forums/forums.php(39): IPS\Node\_Controller->execute()
#9 /home/forum/www/system/Dispatcher/Dispatcher.php(146): IPS\forums\modules\admin\forums\_forums->execute()
#10 /home/forum/www/admin/index.php(13): IPS\_Dispatcher->run()
#11 {main}

 

Please send me FTP&ACP access through PM so that I can have a look.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...