Jump to content

Trophies and Medals - Supporttopic


Fosters

Recommended Posts

38 minutes ago, Dean_ said:

In the signature is it meant to just display trophies or both medals and trophies? Because in the settings it appears as separate, however it shows both? So I'm totally confused, plus why is it called awards, I thought it was medals and trophies?

Where do you see awards? It's saying "Trophies and Medals" for me.

The image size is working for me on https://fosters.space/index.php?/profile/1-admin/&tab=node_trophies_TrophiesAndMedals and https://fosters.space/index.php?/trophies/ 😞

 

Link to comment
Share on other sites

30 minutes ago, Fosters said:

Where do you see awards? It's saying "Trophies and Medals" for me.

Not sure why the toggle switch says awards? I mean, I know what it is but I don't think the term 'awards' suits it here. (I know you award people but as a setting it doesn't make sense).
awards.thumb.JPG.d1e81c3987462c1803987fdd390af11b.JPG

I think if we have the option to display in postbit and signatures, maybe it might be good idea to have them split up? Medals under signatures, and trophies in postbit (avatar). Then have the option to swap them around if we wish.

  

30 minutes ago, Fosters said:


I set to 10px10px, but they don't change while on the forums.

Edited by Dean_
Link to comment
Share on other sites

37 minutes ago, Fosters said:

Is the setting "Allow Moderator to Award Medal?" enabled and does the moderator have permissions to award medals?

There's a button on a profile if the setting is enabled and if the moderator has the proper permissions!

award.png

Button doesn't show for me with the option enabled (cache cleared).
award2.thumb.JPG.3a79e13f895fad9a4a8bfddf1e55d1ab.JPG

Link to comment
Share on other sites

1 minute ago, EmpireKicking said:

I did had a template error but now that's gone I get another error.

Saving and edited the seeing is not making any changes at all 😞   even set to 1 max trophies does nothing

asdsadsadsadsadsa.thumb.PNG.6447e98ee71094ce706f09cc0c6d0739.PNG

I’ve reported this. Also, are you using Enhanced User Info? If so you need to disable it as you can see it’s not supported and maybe causing you issues.

Link to comment
Share on other sites

1 hour ago, EmpireKicking said:

I did had a template error but now that's gone I get another error.

Saving and edited the seeing is not making any changes at all 😞   even set to 1 max trophies does nothing

asdsadsadsadsadsa.thumb.PNG.6447e98ee71094ce706f09cc0c6d0739.PNG

Have you ever customized the postbit template manually?
Is there any other 3rd party app changing the postbit?

Link to comment
Share on other sites

#0 /home/xxx/xxx/xxx.se/applications/trophies/sources/Trophy/MemberTrophy.php(109): IPS\Patterns\_ActiveRecord::load('')
#1 /home/xxx/xxx/xxx.se/applications/trophies/sources/Trophy/MemberTrophy.php(54): IPS\trophies\Trophy\_MemberTrophy::getFromCache(Object(IPS\Member), 'postbit')
#2 /home/xxx/xxx/xxx.se/applications/trophies/sources/Trophy/MemberTrophy.php(42): IPS\trophies\Trophy\_MemberTrophy::fetchForPostbit(Object(IPS\Member))
#3 /home/xxx/xxx/xxx.se/system/Theme/Theme.php(854) : eval()'d code(292): IPS\trophies\Trophy\_MemberTrophy::fetchForSignature(Object(IPS\Member))
#4 /home/xxx/xxx/xxx.se/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_trophies_front_global->signature(Object(IPS\Member))
#5 /home/xxx/xxx/xxx.se/system/Theme/Theme.php(854) : eval()'d code(1805): IPS\Theme\_SandboxedTemplate->__call('signature', Array)
#6 /home/xxx/xxx/xx.se/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_forums_front_topics->post(Object(IPS\forums\Topic), Object(IPS\forums\Topic\Post), 'topic_comment', 'forums', 'forums', 'forums_Topic')
#7 /home/xxx/xxx/xx.se/system/Theme/Theme.php(854) : eval()'d code(2613): IPS\Theme\_SandboxedTemplate->__call('post', Array)
#8 /home/xxx/xxx/xx.se/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_forums_front_topics->postContainer(Object(IPS\forums\Topic), Object(IPS\forums\Topic\Post), Array, '')
#9 /home/xxx/xxx/xxx.se/system/Theme/Theme.php(854) : eval()'d code(4974): IPS\Theme\_SandboxedTemplate->__call('postContainer', Array)
#10 /home/xxx/xxx/xxx.se/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_forums_front_topics->topic(Object(IPS\forums\Topic), Array, NULL, Array, NULL, NULL, Array)
#11 /home/xxx/xxx/xxx.se/applications/forums/modules/front/forums/topic.php(459): IPS\Theme\_SandboxedTemplate->__call('topic', Array)
#12 /home/xxx/xxx/xxx.se/init.php(886) : eval()'d code(24): IPS\forums\modules\front\forums\_topic->manage()
#13 /home/xxx/xxx/xxx.se/system/Dispatcher/Controller.php(101): IPS\forums\modules\front\forums\badges_hook_post->manage()
#14 /home/xxx/xxx/xxx.se/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
#15 /home/xxx/xxx/xxx.se/applications/forums/modules/front/forums/topic.php(39): IPS\Content\_Controller->execute()
#16 /home/xxx/xxx/xxx.se/system/Dispatcher/Dispatcher.php(152): IPS\forums\modules\front\forums\_topic->execute()
#17 /home/xxx/xxx/xxx.se/index.php(13): IPS\_Dispatcher->run()
#18 {main}

1. System log full of this  , using font awesome icons don't work at all

2. Tried with graphics and its start work better, but still error in postbit , now for members

3. Only shows one trophy in postbit and signature field

4. Serie of trophys and you add one and remove one at same time trigger new errors (replace one)

5. copy one medal change some values does not save

 

 

Link to comment
Share on other sites

Like others I am seeing the following error in postbit:

image.png.de08b20c08e5e3dd976005d8f1f893cc.png

I believe I've narrowed the issue specifically to this line in the code:

{{$items = \IPS\trophies\Trophy\MemberTrophy::fetchForPostbit($author);}}

If I JUST include that line in the postbit, I see the error. 

Further, the error only seem to show for people with no trophies/medals. As you can see above the first person has some showing, while the second person throws an error.

Any fix?

Link to comment
Share on other sites

Noticed something weird with my install recently.

Guests are triggering trophies achievements? The widget displays new user in the list, with no name or display picture. When clicking on it profile it takes you to this link; 

www.mywebsite.com/profile/706-{%3F}/?tab=activity

The profile is blank, and the user group is showing as 'guests'.

After around 10 minutes, the link doesn't work and then the page displays this;

Sorry, there is a problem

We could not locate the item you are trying to view.

Error code: 2C138/1


There's no member, no spam accounts, and no logs...

Very weird behaviour.

Edited by Dean_
Link to comment
Share on other sites

21 hours ago, Dean_ said:

Noticed something weird with my install recently.

Guests are triggering trophies achievements? The widget displays new user in the list, with no name or display picture. When clicking on it profile it takes you to this link; 


www.mywebsite.com/profile/706-{%3F}/?tab=activity

The profile is blank, and the user group is showing as 'guests'.

After around 10 minutes, the link doesn't work and then the page displays this;


Sorry, there is a problem

We could not locate the item you are trying to view.

Error code: 2C138/1


There's no member, no spam accounts, and no logs...

Very weird behaviour.

Hvave you deleted any members recently?

Link to comment
Share on other sites

23 hours ago, Douglas Glover said:

Like others I am seeing the following error in postbit:

image.png.de08b20c08e5e3dd976005d8f1f893cc.png

I believe I've narrowed the issue specifically to this line in the code:


{{$items = \IPS\trophies\Trophy\MemberTrophy::fetchForPostbit($author);}}

If I JUST include that line in the postbit, I see the error. 

Further, the error only seem to show for people with no trophies/medals. As you can see above the first person has some showing, while the second person throws an error.

Any fix?

What's the logged error? ( You can see in in your ACP => System => Support - System Log) 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...