Jump to content

Trophies and Medals - Supporttopic


Fosters

Recommended Posts

9 hours ago, Blisslandia said:

I need some help! Trophies are not applying for specific groups that members are in. It just doesn't update. Can you help? Let me know what you need.

Have you tried the criteria debug tools? Are they reporting that the members should get the trophy?
Have the members logged in in the meanwhile?

Trophies are awarded when a member logs in and also via a cron job which can take a while to iterate over all members on boards with many members and/or trophies.

Link to comment
Share on other sites

I created a trophy where if a user uploaded an avatar, they get a trophy (Face To A Name).  However, it seems like everybody is getting the trophy, even if they don't have an avatar.  Is there a different setting I'm missing?

I had to delete the Trophy before it goes through my entire user database.

 

 

image.png.375d1b4005433c18b7f32089e303c138.png

image.thumb.png.e4d65966d113c96850d9d6c85b92b2fd.png

Edited by rayzir
Link to comment
Share on other sites

On 20.3.2018 at 11:59 PM, rayzir said:

I created a trophy where if a user uploaded an avatar, they get a trophy (Face To A Name).  However, it seems like everybody is getting the trophy, even if they don't have an avatar.  Is there a different setting I'm missing?

I had to delete the Trophy before it goes through my entire user database.

 

 

image.png.375d1b4005433c18b7f32089e303c138.png

image.thumb.png.e4d65966d113c96850d9d6c85b92b2fd.png

Have you run the criteria checker? Did it give a false positive result?

Link to comment
Share on other sites

10 hours ago, rayzir said:

Where do I find the criteria checker?  I created a trophy as shown.  When I clicked save, it started going through my database and awarding everybody the trophy.

On the ACP page where you manage the trophies (next to the edit, delete links)
If you want, just drop me a PM with the ACP credentials and I'll take a look:)

Link to comment
Share on other sites

On 3/6/2018 at 1:32 PM, emttim said:

I have a curious bug I found... I have a fresh install of 1.3.2 as of today. Under the "Award this trophy if" tab, I am unable to save the variable under "User gave at least X reactions" all others will save. When I hit "Save and Reload" it states "save" at the top, but once reloaded, it is set to '0'. 

Like I said, all others save correctly. Thanks for your input. 

 

On 3/7/2018 at 1:39 PM, Fosters said:

Can you let us know what version of php you have?

What version of IPS are you using?  

Did you run the support tool to clear cache?  

If none of those above options work, please send us a PM with SUBJ: "SUPPORT: Trophies & Medals" and reference this post.  

Thanks,

FostersJ

Can confirm, also happening to me on latest version of T&M. IPS Cloud Hosting, so I don't know the specific details.

Any time you edit a trophy with criteria set for "user gave at least x reactions" it resets to zero. :D

Link to comment
Share on other sites

On 4/10/2018 at 5:37 PM, Mousie said:

Any time you edit a trophy with criteria set for "user gave at least x reactions" it resets to zero

This is small bug in \applications\trophies\extensions\trophies\TrophyCriteria\Core.php :smile:

line #95

$form->add( new \IPS\Helpers\Form\Number( 'trophy_repgiven', isset( $trophy->id, $trophy->crdata['trophy_repgiven'] ) ? $trophy->crdata['trophy_repgiven'] : NULL ) );

should be:

$form->add( new \IPS\Helpers\Form\Number( 'trophy_repgiven', isset( $trophy->id, $trophy->crdata['repgiven'] ) ? $trophy->crdata['repgiven'] : NULL ) );

 

Link to comment
Share on other sites

Hi.  I logged into my dashboard and I see around 68 of these background processes.  I noticed it yesterday morning and has been going on for at least 24 hours.  If I refresh, some of the percentages change, so there is some movement.  Is each of these for each trophy?  Or should there be only 1?  How long should it take?  I'm not sure if it's stuck in a loop.  Between yesterday and today, it added 8 more processes.  It seems to be chewing up my CPU load on my server.

 

 

image.thumb.png.5c730edcdc897a6c9b0d2d1f5477b1f6.png

Link to comment
Share on other sites

As of this AM, there are 82 of these processes.  I think I only have maybe 60 trophies, so I think something is going wrong.  I disabled the application and waited for the background processes to clear out and then reactivated the application.  We'll see if that works.

How many of these instances should show up in the Background Processes?

Link to comment
Share on other sites

I'm sorry to see that you're facing problems.  how many members and trophies do you have? We have made some improvements to our delete old content app which had a similar issue, once we get some feedback from the people, we'll implement this changes to trophies app too 

Link to comment
Share on other sites

On 4/17/2018 at 12:22 PM, MIXOH said:

This is small bug in \applications\trophies\extensions\trophies\TrophyCriteria\Core.php :smile:

line #95


$form->add( new \IPS\Helpers\Form\Number( 'trophy_repgiven', isset( $trophy->id, $trophy->crdata['trophy_repgiven'] ) ? $trophy->crdata['trophy_repgiven'] : NULL ) );

should be:


$form->add( new \IPS\Helpers\Form\Number( 'trophy_repgiven', isset( $trophy->id, $trophy->crdata['repgiven'] ) ? $trophy->crdata['repgiven'] : NULL ) );

 

Thanks, fixed for next release which is scheduled for today. Just want to wait for @rayzirs feedback

Edited by Fosters
Link to comment
Share on other sites

On 4/21/2018 at 3:50 AM, Fosters said:

I'm sorry to see that you're facing problems.  how many members and trophies do you have? We have made some improvements to our delete old content app which had a similar issue, once we get some feedback from the people, we'll implement this changes to trophies app too 

 

We have about 17000 members.  Around 60 or so trophies.  

Thanks!

Link to comment
Share on other sites

A new version was released to fix some compatibility issues with IPS 4.3.0

2 hours ago, rayzir said:

 

We have about 17000 members.  Around 60 or so trophies.  

Thanks!

Are you on IPS 4.3.0? If yes, could you please try the new version. Please upgrade, then remove all existing trophy queue items and let me know if it improved.

Link to comment
Share on other sites

15 hours ago, jair101 said:

Now that IPS supports emojis natively, I want to make a suggestion to include the possibility to create trophies and medals with emojis ?

Interesting idea.

On 4/25/2018 at 12:02 PM, Vladimir Orendarchuk said:

Hello!

First sorry about my bad English

So

1. When I award the user a second time with the same Medal, I get an error

Screenshot_113.thumb.png.b63edaee0788a8e835712f86f658689f.png

2. And question. One and the same medal can be issued for various reasons. I would like to indicate at the award for which the medal was given and see it in the profile

Thanks

Hello,

thats indeed not possible , but it wasn’t often requested so we’ll try to include this into the next release ? 

On 4/24/2018 at 10:26 PM, Ezaco said:

Quoting to ask again.. seems to have been missed.

Sorry, I missed this indeed, but it should be answered now ?

On 4/22/2018 at 5:43 PM, rayzir said:

 

We have about 17000 members.  Around 60 or so trophies.  

Thanks!

Is it better with the recent release ?

Link to comment
Share on other sites

Hi, any idea why this is happening? Running latest plugin version on IPS 4.3.1 ! Thanks.

https://www.linkmania.ro/profile/789057-brook/

Something went wrong. Please try again.

Error code: EX0

This error was probably caused by application Trophies & Medals.
If the issue persists, disable it and contact the author for further assistance.

OutOfRangeException:  (0)
#0 /srv/http/applications/trophies/sources/Trophy/MemberTrophy.php(86): IPS\Patterns\_ActiveRecord::load(14)
#1 /srv/http/system/Patterns/ActiveRecord.php(307): IPS\trophies\Trophy\_MemberTrophy->get_item()
#2 /srv/http/applications/trophies/extensions/core/StreamItems/Award.php(53): IPS\Patterns\_ActiveRecord->__get('item')
#3 /srv/http/system/Content/Search/Results.php(646): IPS\trophies\extensions\core\StreamItems\_Award->extraItems(Object(IPS\Member), 1516665033, NULL)
#4 /srv/http/applications/core/modules/front/members/profile.php(237): IPS\Content\Search\_Results->addExtraItems(Array, Object(IPS\Member))
#5 /srv/http/system/Dispatcher/Controller.php(96): IPS\core\modules\front\members\_profile->manage()
#6 /srv/http/applications/core/modules/front/members/profile.php(65): IPS\Dispatcher\_Controller->execute()
#7 /srv/http/system/Dispatcher/Dispatcher.php(146): IPS\core\modules\front\members\_profile->execute()
#8 /srv/http/index.php(13): IPS\_Dispatcher->run()
#9 {main}

Link to comment
Share on other sites

@Fosters when I add a trophy with the contingency of being a part of a user group, it doesn’t provide the award to the user.

The group was made first and the user was added next. Then the award was made. Any suggestions (this is a trophy and not a medal). Debugging shows it should work and testing it validates that the user should receive the award.

Link to comment
Share on other sites

2 hours ago, Agent Shark said:

@Fosters when I add a trophy with the contingency of being a part of a user group, it doesn’t provide the award to the user.

The group was made first and the user was added next. Then the award was made. Any suggestions (this is a trophy and not a medal). Debugging shows it should work and testing it validates that the user should receive the award.

Then just wait till the user logs in or till the cronjob runs and awards the trophy.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...