Jump to content

TXT & PHP Widget


Pete T

Recommended Posts

  • 2 weeks later...
3 hours ago, The Old Man said:

Hi @Pete T

Just tried this plug-in, and it doesn't seem to honour the WYSIWYG text. Once saved it appears as plain text, no paragraphs or formatting, just a line of plain text. Am I doing something wrong?

The plugin design so if html codes not the WYSIWYG editor way when will automatically do all this for you the plugin made by old dev and just get update fixes allow it to work with latest version of IPS when 4.3.x comes may review how plugin designed and works as might get redesign from the ground up.

Link to comment
Share on other sites

I have put in some faulty code into the widget, and now the particular page with the code returns a 500 error. How can i remove that particular block if I cant load the page?

edit: for anyone wondering, the cms blocks are found in db under table cms_page_widget_areas.

Edited by Dan Richardson
Link to comment
Share on other sites

  • 2 months later...

This widget is great for me, the only problem I have is that "groups who can see this", behaves differently to the way it does on advertisements (native invision)

If I have a member who is in group A and group B, and I decide to hide show adverts to everyone except group B, they are hidden from that member.

However, if I do the same for TXT & PHP Widget, the member will still be able to see the widget, because he is in Group A.

Logically your way makes the most sense compared to the description of the field, but it's less useful in my experience.

Link to comment
Share on other sites

On 10/4/2017 at 5:48 AM, Dan Richardson said:

For anyone who is interested in the future, this is how I did it.


// Initialize IPS4 Framework
require_once('./init.php');

// Indicate that we should consider this a front-end session so we can obtain the currently logged in users information.
\IPS\Session\Front::i();

// Fetch linked account details
$setting = \IPS\Member::loggedIn()->profileFields();
$username = $setting['core_pfieldgroups_2']['core_pfield_2'];

 

I didn't need the require or the front-end session, in fact they crashed my page, but getting the logged in user with $member = \IPS\Member::loggedIn(); worked great for me. I then solved the problem I mentioned above using $member->inGroup();

Link to comment
Share on other sites

  • 1 month later...

Hi! Thanks for an awesome widget!

I wonder if it possible to import images and make them fit to the widget area? I´ve managed to import images but they stay in full size and disappears out of the window area. 

Link to comment
Share on other sites

1 hour ago, mrbo said:

Hi! Thanks for an awesome widget!

I wonder if it possible to import images and make them fit to the widget area? I´ve managed to import images but they stay in full size and disappears out of the window area. 

not sure what mean provide a screenshot please.

Link to comment
Share on other sites

Just now, Square Wheels said:

I added this to my custom.css as I only display ads that I control the size of, it works for me.

#ipsLayout_sidebar {
  min-width: 275px;
  max-width: 275px;
}

if only using ads yeah that fine but many people use widget there other ways like add code image etc or reduce the image so making the sidebar smaller or bigger ? 

Link to comment
Share on other sites

  • 4 weeks later...
On 5/28/2018 at 8:41 PM, Square Wheels said:

I added this to my custom.css as I only display ads that I control the size of, it works for me.

#ipsLayout_sidebar {
  min-width: 275px;
  max-width: 275px;
} 

Hello.

Thanks for your code.

I put 310px and the code dpesn't make the sidebar bigger.

Have you got a way to fix the padding please ?

Edited by Bocar
Link to comment
Share on other sites

On 6/25/2018 at 11:52 AM, Bocar said:

Hello.

Thanks for your code.

I put 310px and the code dpesn't make the sidebar bigger.

Have you got a way to fix the padding please ?

Trying work out what trying to do ? As said PM I don't support any tweak to themes that default or third party 

Link to comment
Share on other sites

10 minutes ago, Bocar said:

I am tring to make a banner appears right on the block I created with a good padding.

15px by default is too much. 1px is great.

https://invisioncommunity.com/forums/topic/434890-txt-php-widget/?do=findComment&comment=2703247

the answer there just change the code for padding and id number the plugin has.

Edited by Pete T
Link to comment
Share on other sites

On 8/1/2017 at 12:51 PM, Pete T said:

yes please as used the plugin over my own site and removed the widget find from the front end so happy take look see if we do have a bug.

 

add this to custom.css

.ipsWidget[data-blockid="plugin_2_sodTxtWidget_0o20nmyug"] {   
    border: 0px solid #000 !important;
}

please let me know if that worked or not.

Hello.

I put :
.ipsWidget[data-blockID='plugin_3_sodPhpWidget_9ool06bo1'] {   
    padding: 1px !important;
}

Doesn't work for padding.

Edited by Bocar
Link to comment
Share on other sites

  • 2 weeks later...
23 hours ago, Bocar said:

Hello.

Can you tell how to do this please ?

Look I say it again and again I don't support custom tweaks to your theme I provided you CSS tweak it or look the inspect code via chrome and see if will get your end result but I am not going be provide support for your request.

Link to comment
Share on other sites

  • 2 weeks later...
On 7/18/2018 at 1:19 AM, im_mortal said:

Hello,

Getting this when opening left-hand widget menu with the plugin enabled:

image.png.90824489d83ed9095e38f2815c3b8505.png

IPS Support says PHP & TXT Widget uses invalid php code:

image.thumb.png.4cdc4154fd6330d3e0a71382145c4c7e.png

if read correctly you added php code into block yes or no ? if yes its that breaking your site not my plugin as there no invalid code in my plugin.

Link to comment
Share on other sites

Hi.

I am having a problem in that I cannot edit the block - (see photo below of upper right block).  I need to edit the block to place an https protocol in it.

I tried to uninstall the block, however, it still shows up and then people cannot sign up or open an account.  Even when I turn this plugin off, it still shows.  The block is up to date.  Also, I cannot move the block's position .

How can I fix this or uninstall manually? 

THANKS for you help. 

78050177_ScreenShot2018-07-22at4_59_36PM.thumb.png.4198e0122f4b5818524858a633596439.png

Edited by jackflash
Link to comment
Share on other sites

12 hours ago, jackflash said:

Hi.

I am having a problem in that I cannot edit the block - (see photo below of upper right block).  I need to edit the block to place an https protocol in it.

I tried to uninstall the block, however, it still shows up and then people cannot sign up or open an account.  Even when I turn this plugin off, it still shows.  The block is up to date.  Also, I cannot move the block's position .

How can I fix this or uninstall manually? 

THANKS for you help. 

78050177_ScreenShot2018-07-22at4_59_36PM.thumb.png.4198e0122f4b5818524858a633596439.png

 

if uninstalled would have drop all the data so little unsure why showing have cleared your cache ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...