Jump to content

Twitter embed problems


Recommended Posts

Got this note from one of several of my users. Anyone else ever seen this and know how to solve it?

"At work (which uses Internet Explorer), I'm having the problem others have mentioned (elsewhere than this thread) where if someone posts an embedded Twitter link on a page, the page literally won't hold still.    You'll be trying to read or type a response on that page, and the entire page will be scrolling up and you can't stop it."

Link to comment
Share on other sites

  • 3 weeks later...

I am having a similar problem with embedding Twitter links.  I am using the default theme (no changes) and when pasting a Twitter URL in my post, an iframe object is created with a 403 page from my web server.   Chrome browser, so this isn't an IE-specific issue.  Same result when attempting with Safari under iOS 10.2

When the link to the tweet is pasted, the following HTML is placed in the post:

<div class="ipsEmbeddedOther" contenteditable="false">
	<iframe data-controller="core.front.core.autoSizeIframe" scrolling="no" src="http://www.mydomain.com/forums/index.php?app=core&amp;module=system&amp;controller=embed&amp;url=https://twitter.com/kszn_15/status/816350325070249984" style="height: 230px; overflow: hidden;"></iframe>

The iframe appears to expand one line at a time - which is rather strange behavior.

Any assistance would be appreciated.

Link to comment
Share on other sites

My particular issue has been resolved - which was placing a 403 message in place of the Twitter content. I was unable to find any reference to a 403 error being generated by the httpd server (perhaps via mod_security) in my log files, so had to do a bit more digging.

My IPBoards forum is installed in a directory under a Wordpress site (e.g., 'mysite.com/forums'), which uses the "All in One Wordpress Security" plugin to provide security and firewall features for the site. As it sits 'above' the IP Board installation, .htaccess rules defined for the WP site apply to subdirectories 'below' it.

One of the firewall features is to filter "Bad Query Strings" (WPDashboard --> WP Security --> Firewall --> Additional Firewall Rules) - meant to filter malicious queries via XSS. Enabling the feature adds options to the site's .htaccess file that look for these 'bad query strings'.

Disabling the feature, therein removing the rules from the .htaccess file, resolved the problem.

Hopefully, this will give others with this issue a place to start looking.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...