Jump to content

Newsletters


HeadStand

Recommended Posts

12 hours ago, AlexWebsites said:

Is there anyway to change the sync time and does that run off the server time?

Distribution times are calculated according to GMT. Time now is 02/09/2017 01:47 AM

I just changed my server time and its not that. It's actually php time zone if anyone is looking. 

Edited by AlexWebsites
Did not work.
Link to comment
Share on other sites

49 minutes ago, HeadStand said:

That's why I put the "time now is" message, so that you can figure out where the server is. ;) 

I've changed the server time and php time settings to America/New_York and verified it's changed. However, I am still getting the same time output in newsletter distribution settings.

I did see that in the language settings the time zone text seems to be Distribution times are calculated according to GMT. Time now is %s. The time zone isn't set as a variable so I just want to make sure it's not manually set. Any ideas? Not a huge deal, but I'd like to sync with my time if possible.

Link to comment
Share on other sites

I scheduled my first weekly newsletter and received complaints that it sent every hour for up to 10 hours. Is there a log that shows this or has this happened to anyone else? I'm assuming it has something to do with the hourly task, but my settings show weekly distribution. I've disabled it and will run some checks sending to the admin group, but something went funky here. Members complained of spamming...:(

Maybe the issue is that the PublishNewsletters task is set to send hourly but the PruneDistributionHistory is set daily?  i also notice that after it sent the next distribution time did not change, which should have been one week from now. I manually ran the PruneDistributionHistory task but it did not change. 

EDIT:

I just noticed that my next distribution did not change to next week with the weekly interval setting. The daily and weekly intervals act the same for the next distribution time. I changed it to every two weeks in the interval setting and now the distribution time shows a week from now....funky.

So I took a look at some of the files and not sure if this is the reason or not. Looks like in  /applications/newsletters/sources/Newsletter/Newsletter.php you have the code below:

 switch( $this->publish_interval )
        {            
	case static::PUBLISH_DAILY:
           case static::PUBLISH_WEEKLY:
                $day += $daysToAdd;
                break;
            case static::PUBLISH_WEEKS:
                $day += $daysToAdd;
                $day += 7;
                break;
            case static::PUBLISH_MONTHLY:
                $month++;
                break;
            case static::PUBLISH_ANNUALLY:
                $year++;
                break;
        }

My choices are Daily, Weekly, Every Two Weeks, Monthly, Annually, and Manually when in settings. I seem to only be able to get a weekly +7 days by choosing Every two weeks which is your Publish_weeks in the code above?  every 2 weeks should be +14 and weekly I would imagine should be +7 like;

 switch( $this->publish_interval )
        {            
	case static::PUBLISH_DAILY:
            case static::PUBLISH_WEEKLY:
                $day += $daysToAdd;
		$day += 7;
                break;
            case static::PUBLISH_WEEKS:
                $day += $daysToAdd;
                $day += 14;
                break;
            case static::PUBLISH_MONTHLY:
                $month++;
                break;
            case static::PUBLISH_ANNUALLY:
                $year++;
                break;
        }

When I change this, it shows correctly in my "next distribution" when picking weekly. I would have the weekly with just a start date and from there +7 days send it weekly and then on the Daily, to actually pick the days of the week to send. But that's me..

If you have weekly, and pick two or more days it'll actually send in an interval that's less that a week. I think this is what happened to me. I accidentally had Friday and Saturday checked off under weekly because I was messing around with it the day before. Since the task sends every hour and the distribution time only updates once a day, it kept going even though I assumed it would only send once a week regardless.

I also think that update distribution time should be changed to hourly if the send is hourly.

Edited by AlexWebsites
Follow up to this post and issue
Link to comment
Share on other sites

On 2/9/2017 at 9:50 AM, AlexWebsites said:

I've changed the server time and php time settings to America/New_York and verified it's changed. However, I am still getting the same time output in newsletter distribution settings.

I did see that in the language settings the time zone text seems to be Distribution times are calculated according to GMT. Time now is %s. The time zone isn't set as a variable so I just want to make sure it's not manually set. Any ideas? Not a huge deal, but I'd like to sync with my time if possible.

Just to follow up, I put my actual time in the distribution time (matches my server time and php time I set) and the newsletter sent according to that and not the GMT time that it shows on the distribution setup page. I guess it would be good to change that or just put in the php or server time. Just a suggestion because it was a bit confusing.

Link to comment
Share on other sites

Update distribution time is not a task. That occurs immediately when the distribution is triggered  (to prevent exactly the above scenario). I will take a look at this bug tomorrow.... you're the first to report this. 

The idea here is that when the newsletter is published, it loads the queue with everyone who should receive it, then recalculates the next distribution time, then triggers the actual distribution process. The "prune" does nothing to the newsletter itself, it only clears out the logs, so running that task will not help you. 

I think I know the problem.... you're not quite right about the daily/weekly logic, although that is the problem area. The real issue, I think, is that the STARTING point is off. Instead of calculating from current time, I should add 24 hours and start from there (because the current time will read as a valid time). Since we just distributed now, the soonest we would send again is 24 hours later. 

You can expect a fix tomorrow. Sorry... I just can't get to a pc tonight. 

Link to comment
Share on other sites

Yes that sounds like it could be the issue. Thanks for the reply on this. As far as selecting weekly and daily, what's the difference if you are selecting the days in each? 

Just so I understand, If I select daily and check off Monday and Thursday it will send every Monday and Thursday?

If so, what's the difference if I select weekly and check off Monday and Thursday? Same or different?

Link to comment
Share on other sites

6 minutes ago, TheSkyLounge.tv said:

@NoGi still willing to share the template you have? It looks really really bland as default and I hate to think I spent $50 for something I won't use. Some pre-populated styling would have been a really nice plus.

PM me your email and I'll forward you what mine looks like. I've just used the default stuff and have not customised anything. 

Link to comment
Share on other sites

This is literally the only settings I changed for the content parts:

58a241b108bca_Contenttemplate.thumb.PNG.91a4f562914d2ce46c6e367ef3bc0288.PNG

You also need to put some static content into the header and footer sections like your logo etc..

Oh, don't forget to clear your cache and make sure you are running the latest version.

Link to comment
Share on other sites

Just now, HeadStand said:

It doesn't look like that by default anymore. I redid the default templates so that they look a little better than that.

I can confirm this @HeadStand ! I just updated and WHEW! Much better. I have a really nice email template from another CMS, would you like to see it for inspiration? Feel free to PM me email.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...