Jump to content

Newsletters


HeadStand

Recommended Posts

Hi Esther, I just purchased your app but im unsure of the templates, i would like to greet members at the beginning and have the Unsubscribing link at the bottom but im not sure where to put the tags to make this work i have tried a few things with no luck, see screen shot

48618060_template.thumb.PNG.776bbaea41eede17970ab93294859c50-Copy.PNG.3bb8a7447950b6bb978d50f4091cb48b.PNG

Link to comment
Share on other sites

On 3/11/2020 at 10:44 PM, Noble~ said:

Hi Esther, I just purchased your app but im unsure of the templates, i would like to greet members at the beginning and have the Unsubscribing link at the bottom but im not sure where to put the tags to make this work i have tried a few things with no luck, see screen shot

48618060_template.thumb.PNG.776bbaea41eede17970ab93294859c50-Copy.PNG.3bb8a7447950b6bb978d50f4091cb48b.PNG

You want to set up your newsletter with a Manual Content piece first. You wouldn't do this in the template, you would do this when you build your newsletter content.

The download includes full documentation for this modification. Please take a look at the "Newsletter Content" section beginning on page 7. If you have further questions, feel free to PM me or post them here.

Link to comment
Share on other sites

Hello,

Installed and configured Newsletters. I'm looking forward to playing with the template and getting it looking like I want.  😉 

I've set it up to send all new content on a daily basis, which is what my members have asked for.  I'm having two issues:

1. I must've set a switch wrong somewhere, as it does not run automatically every day.  I have to go in and click "Publish" to generate a newsletter.  Any ideas what I may have done wrong?  I notice on the Newsletters control panel it has a red icon saying "disabled".  Is that a clue to what I've messed up?

2. Although I set it for new content, on Forums where there is no new content it's listing old content (same things day after day).  Any suggestions on how to fix this?  I'd prefer it say "No new content" or leave that section blank or omit it if there is no new content.

Thanks,

Scotty

Link to comment
Share on other sites

On 3/25/2020 at 12:34 PM, Scotty Hutto said:

Hello,

Installed and configured Newsletters. I'm looking forward to playing with the template and getting it looking like I want.  😉 

I've set it up to send all new content on a daily basis, which is what my members have asked for.  I'm having two issues:

1. I must've set a switch wrong somewhere, as it does not run automatically every day.  I have to go in and click "Publish" to generate a newsletter.  Any ideas what I may have done wrong?  I notice on the Newsletters control panel it has a red icon saying "disabled".  Is that a clue to what I've messed up?

2. Although I set it for new content, on Forums where there is no new content it's listing old content (same things day after day).  Any suggestions on how to fix this?  I'd prefer it say "No new content" or leave that section blank or omit it if there is no new content.

Thanks,

Scotty

Nevermind, I figured it out.  

1. Hit "Publish" again and it went to "Enabled" and distributed automatically this morning.  🙂

2. Had the Cutoff Days set to "0" (which apparently means forever).  Changed that to "1" and now I'm only getting content submitted that day.

Scotty

Link to comment
Share on other sites

  • 2 weeks later...

Back again. Newsletter is running well!  My members love it. 

Currently it appears by default posts are sorted in chronological order; either newest to oldest or oldest to newest. Is it possible to sort by heading, or to group all posts on a topic (thread) together? The only complaints I’ve gotten have been that it’s difficult to follow a topic on a day when we have 40-50 posts. 
 

Thanks,

Scotty

Link to comment
Share on other sites

  • 2 weeks later...
On 4/7/2020 at 1:20 AM, Scotty Hutto said:

Back again. Newsletter is running well!  My members love it. 

Currently it appears by default posts are sorted in chronological order; either newest to oldest or oldest to newest. Is it possible to sort by heading, or to group all posts on a topic (thread) together? The only complaints I’ve gotten have been that it’s difficult to follow a topic on a day when we have 40-50 posts. 
 

Thanks,

Scotty

Not without some significant code changes. Unfortunately I can't promise any development at this time - I'm significantly behind schedule with work.

Link to comment
Share on other sites

Esther,

I have been successfully using Newsletters for several weeks now. 

Last week I added a second “Weekly” digest in addition to my daily digest. 

I published and enabled it Thursday or Friday of last week and immediately began receiving reports of members getting multiple copies of the newsletter, in some cases 30-40 per day. 

This weekend I disabled the Weekly Digest hoping to stop the multiple copies issue, but it continues. 

I contacted Invision support for help in stopping the batch process, but they said the issue is Newsletters and I needed to contact you for assistance. 

I am getting the following error message:

Locked Task: queue 
One of the routine maintenance tasks which run in the background has failed several times, which may indicate a configuration issue.

Application/Plugin
System 
Task
queue 
Runs background queue tasks. 
Last Run
6 hours ago 
You should check the logs for any indication of the issue or attempt to run it manually. If the task does not run successfully and you require further assistance, please contact support. 
 

Please help!  Let me know if you need ACP access.

Scotty Hutto

Link to comment
Share on other sites

  • 3 months later...

hi again @HeadStand

just in case missed, am still waiting for a reply to pms detailing possible bugs from march 2020

 

another possible bug

if you delete an issue of a newsletter

then afterwards if you follow any links to the deleted issue rather than give a 404 the app gives an error 500 and reports Error code: 1FNNI/1

thanks

 

 

Edited by sound
Link to comment
Share on other sites

@HeadStand,

Hello! I hope you're doing well. I just upgraded to Invision 4.5, under the mistaken impression from reading the changelog that it was a relatively minor under the hood optimization sort of update.

EDIT: I would not have updated to 4.5 if the release notes had been more clear about what a major change it was.

I'm now getting an ominous error when I try to interact with Newsletters in the AdminCP.

Quote

2S119/1 The CSRF protection key did not match. This may indicate a plugin or theme is out of date. Please contact technical support for more information.

I've never seen this before when updating a plugin. Is there something I can do on my end to try to fix it? It says it's some sort of permissions error.

Did this happen to anyone else?

Edited by John T Davis
Link to comment
Share on other sites

The newsletter application is not yet compatible with version 4.5. It's the next one on my list to update, but it will be a couple of days.

On 8/13/2020 at 7:41 AM, sound said:

hi again @HeadStand

just in case missed, am still waiting for a reply to pms detailing possible bugs from march 2020

 

another possible bug

if you delete an issue of a newsletter

then afterwards if you follow any links to the deleted issue rather than give a 404 the app gives an error 500 and reports Error code: 1FNNI/1

thanks

 

 

All will be included in the next update (with 4.5 compatibility).

Link to comment
Share on other sites

On 8/19/2020 at 5:33 AM, HeadStand said:

The newsletter application is not yet compatible with version 4.5. It's the next one on my list to update, but it will be a couple of days.

All will be included in the next update (with 4.5 compatibility).

@HeadStand Thanks so much for working on this update, especially in such a wild time. I saw your message from April and hope that you are doing well and things have calmed down a bit even in the midst of the current human malware crisis.

I've also discovered that my newsletters are still going out as they should, and I can apparently still change the subscription settings in my user's Account Settings (not sure if those changes are effective, but will know later today). I just can't access the admin controls.

Thanks again!

Link to comment
Share on other sites

1 hour ago, John T Davis said:

I've also discovered that my newsletters are still going out as they should, and I can apparently still change the subscription settings in my user's Account Settings (not sure if those changes are effective, but will know later today). I just can't access the admin controls.

Ditto...  Life goes on and my Newsletter goes out, but the next update will be most welcome! :-)

Link to comment
Share on other sites

  • 3 weeks later...
18 hours ago, Vegan Gaymer said:

I was JUST coming to check on this. Because it is out of date, it is blocking all new registrations for some reason, causing EXO errors. Thank you for your hard work!

It's still pending, unfortunately. They kicked it back to me twice to fix some minor things to meet some of the IPS new requirements for marketplace submissions. The last time I resubmitted was Monday night. Hopefully it gets approved today?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...