Jump to content

Community

Recommended Posts

  • Replies 604
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

It's been uploaded to the marketplace and is currently pending approval.

Just got this. The email preview, is this how it really looks?    Looks really bad, was expecting better D:   Anyone got any templates I could use, that matches the IPS emails

I don't have any integration with Clubs at this time. I would like to, and it's something I plan on adding, but it's not there yet.  I have a whole list of features I've been meaning to add to th

Posted Images

I'm having a bug in the newsletter in certain email clients.  In Gmail, the newsletter renders properly.  In Outlook, somehow I get an extra logo image. 

The second heart you see in this image is part of a transparent gif and the lettering is white like above.2018-07-09.thumb.png.96577fd39a0812db5136546995d60d7d.png

 

The exact same email in the exact same account, but rendered through the Gmail client, comes out as expected.

1053328723_2018-07-09(1).thumb.png.ad3549fbc3ecf9ad788b906ec52f9285.png

Link to post
Share on other sites
On 7/5/2018 at 11:25 PM, Josiah Wallingford said:

There is no error because the link is unclickable (displays as a different color like a link would but is not actually a clickable link).

I THINK the beta version will correct your issue. Hard to tell, because I could never reproduce it, but I did find one possible place that might be causing it. So... fingers crossed?

Link to post
Share on other sites

 

hi

using the latest newsletter release and php 7.1.17

when trying the 'opt in' option  am getting the following error logged in the system logs

Newsletter has no subscribers

looking deeper it seems to be an issue with 

the protected function getSubscriberEmails()

   

// are we already in the list?
            $index = array_search( $row['email'], $emails['html'] );

 

this doesn't appear to return the right result if no results were returned 

so the $index == -1 check fails

 

 

Link to post
Share on other sites
1 hour ago, sound said:

 

hi

using the latest newsletter release and php 7.1.17

when trying the 'opt in' option  am getting the following error logged in the system logs

Newsletter has no subscribers

looking deeper it seems to be an issue with 

the protected function getSubscriberEmails()

   


// are we already in the list?
            $index = array_search( $row['email'], $emails['html'] );

 

this doesn't appear to return the right result if no results were returned 

so the $index == -1 check fails

Sorry, I don't understand the issue. You said 

Quote

this doesn't appear to return the right result if no results were returned 

which means you agree that no results are returned. What result are you expecting? Why do you think this check is failing?

You chose opt-in, which means that by default, no one will receive the newsletter unless they specifically go to the newsletter page (or their account settings) and sign up. So if you just created the newsletter, then it is highly likely that the newsletter has no subscribers.

Everything sounds correct to me.

Link to post
Share on other sites

hi again

ok will try again

1. I Start up a new test newsletter with options for opt-in and no default group

2.  A test member account signs up (opts-in) to the test newsletter

3.  When I goto publish  the test newsletter the error 'Newsletter has no subscribers' is logged and no emails are sent to the test account

4.  Looking at the database table newsletters_queue  there is  no entry for the 'test member' 

at this stage the newsletter is not working ( I also experienced similar with existing newsletters and opts-in option as well ) it is not emailing members who have opted-in

 

 

ok so far?

 

if I now goto that routine (mentioned in earlier post) and bypass the $index check then the newsletter will work 

the 'test member' gets entered into the database table and the email newsletter gets sent to the member

 

going by that I think there is an actual  issue with the $index check

hope helps ?

 

 

Edited by sound
error
Link to post
Share on other sites
On 7/12/2018 at 9:57 AM, sound said:

yep, a test account signs up for the opt-in test newsletter 

I am unable to reproduce this issue. An opt-in newsletter works perfectly for me and does not give an empty subscriber list. It's possible that this was inadvertently fixed with the beta version (which is what I tested with), but I don't believe so.

By any chance, did the user you are testing with agree to "send news and information"?

Link to post
Share on other sites
3 hours ago, HeadStand said:

I am unable to reproduce this issue. An opt-in newsletter works perfectly for me and does not give an empty subscriber list. It's possible that this was inadvertently fixed with the beta version (which is what I tested with), but I don't believe so.

By any chance, did the user you are testing with agree to "send news and information"?

thanks for the reply

yep the user was someone who has agreeded  

for your info 

to get it working 

i replaced 

 if( $index != -1 )

with

if( false === $index )
            
as per comments on the php manual notes for  array_search and it seems to work ok now

 

Link to post
Share on other sites
2 hours ago, sound said:

thanks for the reply

yep the user was someone who has agreeded  

for your info 

to get it working 

i replaced 

 if( $index != -1 )

with

if( false === $index )
            
as per comments on the php manual notes for  array_search and it seems to work ok now

 

Will be fixed in the next version.

Link to post
Share on other sites
58 minutes ago, HeadStand said:

Still looking for a second beta tester, specifically for testing Clubs integration. This is nearly ready for release, I would just feel better if I had another set of eyes on that piece.

I modified the content templates for a little different layout. Increased picture size, swapped in the teaser paragraph instead of content, added a call to action.

 Thank you for the updates, this is what I was looking for.

2018-07-18.thumb.png.daea918f338b845715a1c2c86ea35310.png

Link to post
Share on other sites

I've started getting this error in my dashboard. I reported it to IPS and they referred me back to you:

The following tasks appear to be locking frequently: PublishNewsletters.

Is there something I can do to fix this? No one has been receiving newsletters for days. Thanks!

When I try to "run manually," I get this:

Error: Access to undeclared static property: IPS\core\Statuses\Status::$containerNodeClass (0)
#0 /var/www/html/r269298/applications/newsletters/sources/Newsletter/Content.php(239): IPS\newsletters\extensions\newsletters\NewsletterContent\_Core->getData(Array)
#1 /var/www/html/r269298/applications/newsletters/sources/Newsletter/Newsletter.php(529): IPS\newsletters\Newsletter\_Content->build('plain', Array)
#2 /var/www/html/r269298/applications/newsletters/sources/Newsletter/Newsletter.php(606): IPS\newsletters\_Newsletter->buildContent('plain', Array)
#3 /var/www/html/r269298/applications/newsletters/tasks/PublishNewsletters.php(65): IPS\newsletters\_Newsletter->publish()
#4 /var/www/html/r269298/system/Task/Task.php(248): IPS\newsletters\tasks\_PublishNewsletters->execute()
#5 /var/www/html/r269298/applications/core/modules/admin/settings/advanced.php(624): IPS\_Task->run()
#6 /var/www/html/r269298/system/Dispatcher/Controller.php(85): IPS\core\modules\admin\settings\_advanced->runTask()
#7 /var/www/html/r269298/applications/core/modules/admin/settings/advanced.php(34): IPS\Dispatcher\_Controller->execute()
#8 /var/www/html/r269298/system/Dispatcher/Dispatcher.php(146): IPS\core\modules\admin\settings\_advanced->execute()
#9 /var/www/html/r269298/admin/index.php(14): IPS\_Dispatcher->run()
#10 {main}

 

Edited by Vegan Gaymer
Link to post
Share on other sites

A new version has been uploaded to the Marketplace. Changes include:

  • New content types for "New Clubs", "Popular Clubs"
  • Images wherever possible. Blog entries, pages records, gallery albums, downloads screenshots, nexus products.
  • Additional filters in the content types - pinned/unpinned, locked/unlocked
  • Advertising - Configure an advertising space with all your other ads and then include that in the newsletter.
  • Club Newsletters. See documentation for details.
  • Newsletter templates now use a codemirror instead of a text area
  • Newsletter templates now include tags for all available variables
  • Header/Footer editors now include tags for all available variables

IMPORTANT NOTE: Club Newsletters have not been beta tested. Please feel free to report any issues you find with that feature.

On 7/20/2018 at 10:55 AM, Vegan Gaymer said:

I've started getting this error in my dashboard. I reported it to IPS and they referred me back to you:

The following tasks appear to be locking frequently: PublishNewsletters.

Is there something I can do to fix this? No one has been receiving newsletters for days. Thanks!

When I try to "run manually," I get this:


Error: Access to undeclared static property: IPS\core\Statuses\Status::$containerNodeClass (0)
#0 /var/www/html/r269298/applications/newsletters/sources/Newsletter/Content.php(239): IPS\newsletters\extensions\newsletters\NewsletterContent\_Core->getData(Array)
#1 /var/www/html/r269298/applications/newsletters/sources/Newsletter/Newsletter.php(529): IPS\newsletters\Newsletter\_Content->build('plain', Array)
#2 /var/www/html/r269298/applications/newsletters/sources/Newsletter/Newsletter.php(606): IPS\newsletters\_Newsletter->buildContent('plain', Array)
#3 /var/www/html/r269298/applications/newsletters/tasks/PublishNewsletters.php(65): IPS\newsletters\_Newsletter->publish()
#4 /var/www/html/r269298/system/Task/Task.php(248): IPS\newsletters\tasks\_PublishNewsletters->execute()
#5 /var/www/html/r269298/applications/core/modules/admin/settings/advanced.php(624): IPS\_Task->run()
#6 /var/www/html/r269298/system/Dispatcher/Controller.php(85): IPS\core\modules\admin\settings\_advanced->runTask()
#7 /var/www/html/r269298/applications/core/modules/admin/settings/advanced.php(34): IPS\Dispatcher\_Controller->execute()
#8 /var/www/html/r269298/system/Dispatcher/Dispatcher.php(146): IPS\core\modules\admin\settings\_advanced->execute()
#9 /var/www/html/r269298/admin/index.php(14): IPS\_Dispatcher->run()
#10 {main}

 

This should be fixed in the latest version.

Edited by HeadStand
Link to post
Share on other sites
8 hours ago, Adam_S said:

Hi @HeadStand

After the recent update to Newsletters, i'm now getting broken images appearing in my newsletters.

For example

74640365_2018-07-2516_47_14-WeeklyAdelaideNewsletter-deejaymadd@gmail.com-Gmail.jpg.f9a7d5a1d81b0981ca7af5c0dff08cdc.jpg

It appears regardless which browser or app I view the emails in.

Any ideas?

Thanks

From a screenshot? No. I'd need to see the HTML source to see where the images are pointing to. Do you have a customized template for your content type?

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy