Jump to content

(NE) Hide replies from guests


Nathan Explosion

Recommended Posts

@Philip Krasilnikov again - please post in here if you need support on the application. I do not provide support in the first instance via PM.

Provide more detail on the issue (exactly what you have done, clearly indicating what you have clicked on to insert the image), screenshot your settings from the ACP and provide a link to the post in question.

Once you have provided that information, I can then perform my own testing with the same settings as you have and then go from there.

Edited by Nathan Explosion
Link to comment
Share on other sites

@Philip Krasilnikov - please provide more details on your issue, as I cannot reproduce a problem using default IPS functionality in conjunction with my application. Any images added, either as an attachment or as a link, obtain the correct css class which I target for hiding the element.

This is what you posted in the review:

Quote

Hello! I have installed the extension at my forum and set up to hide images and attachments for guests. So when I attach file to the post it is hidden, but if I insert the image at toolbar inside of the post, than the image is shown to guests. Could you please help me to resolve the issue?

What does the highlighted text mean? Are you using a ckeditor plugin in your editor? If so, what one? If not, provide more detail on how to reproduce this.

Edited by Nathan Explosion
Link to comment
Share on other sites

  • 3 weeks later...

Quick question about this application.

Is it possible to configure it in such a way that ONLY the posts from a certain user group are displayed to user group X?

I mean, I want new users to see only the posts written by the administrator and moderators... And hide from them the posts written by other user groups.

Thanks so much

 

Link to comment
Share on other sites

  • 2 weeks later...

Hello, a quick question and well a little bug.

When there is a new answer in a topic, a toast is shown indicating that there are new answers, when you click the answer is loaded by ajax I suppose and the hidden content can be displayed despite not having permissions for it.

I leave you an image so that you can see what it is about.

 

 

photo_2021-10-20_18-48-36.jpg

Link to comment
Share on other sites

That doesn't show me anything other than what appears to be a notification, which doesn't contain any content from the post. And 'answer' implies that this is in a 'Q&A' topic, but it could just be your wording for a 'comment' being added to a topic...so...

Full reproduction steps please, or a video explaining it better, saves me wasting time trying to figure out what you are reporting 

 

Edited by Nathan Explosion
Link to comment
Share on other sites

So wasted 30 minutes of my time...I think these are your reproductions steps:

  1. Login to one browser as user A
  2. Login to another browser as user B
  3. Configure app to hide content for group that user B is in.
  4. Reply to a topic as user A
  5. User B, reading the topic, is displayed a notification as the base of the screen and clicks on it.
  6. Loaded content is not hidden by the application.

If that matches to what you are reporting, then please confirm.

If it is then it's not a bug, as that area of code isn't touched by my app. I'll add it in as a new feature whenever I next work on this application.

Edited by Nathan Explosion
Link to comment
Share on other sites

  • 1 month later...

Hi @Nathan Explosion, any way to add the ability to only hide content posted by certain usergroups? So if I wanted to apply hiding forum topics and posts created by one or two usergroups to guests, is there a way to achieve this or can it be added as a feature in the future?

So right now you have Hide From, but maybe another usergroup selection box to pick content from usergroups you want to hide.

image.png.500772c0b37c151385b52f30bfa99bf9.png

 

What I'm trying to achieve and thinking of doing is adding a subscription/membership package that comes with the privacy of having your content hidden from guests and non-logged in users.

Link to comment
Share on other sites

  • 4 weeks later...
On 9/24/2021 at 1:59 PM, Nathan Explosion said:

@Philip Krasilnikov - please provide more details on your issue, as I cannot reproduce a problem using default IPS functionality in conjunction with my application. Any images added, either as an attachment or as a link, obtain the correct css class which I target for hiding the element.

This is what you posted in the review:

What does the highlighted text mean? Are you using a ckeditor plugin in your editor? If so, what one? If not, provide more detail on how to reproduce this.

Hello, when I switch on the extension I have sometimes at my forum php error (I'll drop a screenshot once I have it)

In spite of the extension is on set up to hide images, it shows images if they were inserted in the body of the message and once it was aligned. Here is the example of such behavior: https://sexforum.xyz/index.php?/topic/20-test-topic-with-image-inside/#comment-54

Link to comment
Share on other sites

26 minutes ago, Philip Krasilnikov said:

I'll drop a screenshot once I have it)

I've accessed the link and I can see that message - what version of PHP are you using? (Exact version)

26 minutes ago, Philip Krasilnikov said:

In spite of the extension is on set up to hide images, it shows images if they were inserted in the body of the message and once it was aligned

Back to this issue - I need information from you on HOW you are adding the image; what actions are you performing to add the image? I'm not interested in the image in a post - more interested in how it was put there. How was the post constructed? What actions did you perform to create the content? If I understand that, then I can work on the issue.

This is what I see on the post - so, it has detected an image in the post, and it is hiding that. But it also showing an image, which based on a quick look it should be - so, if I know more about the post content and how you created it then I can reproduce and work on it.

And provide the screenshots of your settings, as also requested previously.

 

image.thumb.png.6240299535129b43b412bf94ab7a4e9c.png

Edited by Nathan Explosion
Link to comment
Share on other sites

23 minutes ago, Nathan Explosion said:

I've accessed the link and I can see that message - what version of PHP are you using? (Exact version)

Back to this issue - I need information from you on HOW you are adding the image; what actions are you performing to add the image? I'm not interested in the image in a post - more interested in how it was put there. How was the post constructed? What actions did you perform to create the content? If I understand that, then I can work on the issue.

This is what I see on the post - so, it has detected an image in the post, and it is hiding that. But it also showing an image, which based on a quick look it should be - so, if I know more about the post content and how you created it then I can reproduce and work on it.

And provide the screenshots of your settings, as also requested previously.

 

image.thumb.png.6240299535129b43b412bf94ab7a4e9c.png

Here is the php error:

133877273_2021-12-2117_40_46.thumb.png.c1c4690e6313a121e3d607a9ea7d6f9a.png

I have PHP 8.0.10 (alt)

I just upload the image and once it is uploaded I press "insert" and then doule click it and then I align it to the left/right. After that I see that the image is shown to the guests (but should be hidden)

 

P.S. For now I disabled the extension.

P.P.S> From your screen you can see that one image is hidden and other one is not

Edited by Philip Krasilnikov
Link to comment
Share on other sites

36 minutes ago, Nathan Explosion said:

Not sure why you are asking that - you can uninstall it if you want, but reinstalling it will have the same issue.

As I said:

"both issues are fixed in dev at the moment"

I still need to test it, and then release the update to the MarketPlace.

Ok, now is clear, please let me know as soon as the update will be done )

Merry Christmas!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...