Jump to content

Application Forms - Supporttopic


Fosters

Recommended Posts

Hi @Fosters

I just purchased your application and installed the 3.2.7 version. I'm currently running my community on the 4.3.6 version of the IPB suite. I'm having this message on my application form (instead of the description):

"[[Template core/global/global/richText does not exist. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]"

The theme version I am using is compatible with my Invision Community Suite version. I also tested with the default theme and I got the same message. I think I need a version prior to 3.2.0 according to the file details?

Edited by Charef
Link to comment
Share on other sites

9 minutes ago, Charef said:

Hi @Fosters

I just purchased your application and installed the 3.2.7 version. I'm currently running my community on the 4.3.6 version of the IPB suite. I'm having this message on my application form (instead of the description):

"[[Template core/global/global/richText does not exist. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]"

The theme version I am using is compatible with my Invision Community Suite version. I also tested with the default theme and I got the same message. I think I need a version prior to 3.2.0 according to the file details?

Yea, I'm only supporting the last recent IPS version.

 

I'll be back in my office on Monday and will try to build you a version for IPS 4.3.x 🙂

Link to comment
Share on other sites

Hi, 

We now have this application working but a Moderator who has access to manage the submissions has mentioned that when he receives a comment from another moderator (within the 'manage' part of a specific submission) the notification that comes through links him to an error page.

759363266_ScreenShot2019-11-05at10_18_43.thumb.png.e5e597b3c114c20761158459dbdb3720.png

It's not a huge problem because he can go through the moderator CP page and find it manually but the link he is given on the notification is dead.

Any ideas? Or is this a bug?

Thanks

Link to comment
Share on other sites

  • 1 month later...

thats great news and made me buy it!

however, there is one addition that would be awesome:

i use the poll feature to create a poll for each application submission. however, i'd like to see who voted what on that poll. there is an option called "Make voter names public?" when i create a poll manually. i'd appreciate if we could set this option for the created poll.

additionally i just discovered that when i enable the "create topic" option that i can not create manual topics in the target forum.. is that intended? i really wanted to use that forum for different kind of polls..

Link to comment
Share on other sites

6 minutes ago, Andr3as said:

additionally i just discovered that when i enable the "create topic" option that i can not create manual topics in the target forum.. is that intended? i really wanted to use that forum for different kind of polls..

Yes, the idea was to replace the create form to provide a very powerful template system for new topics 🙂

I guess it makes sense to create a new option to allow admins to disable this if they want to create normal topics in the same forum and to use a separate link in the navbar or wherever they place it to the application form.

 

Link to comment
Share on other sites

1 minute ago, Fosters said:

I guess it makes sense to create a new option to allow admins to disable this if they want to create normal topics in the same forum and to use a separate link in the navbar or wherever they place it to the application form

oh yeah, the option would be great..

the thing is, i want potentially new users to apply to become a member as well as already existing users to kinda suggest new members. both result in a poll asking to get a new member. however, right now that means two different forums and that isnt really that great as its all the same, semantically..

thanks for considering that as an option.

Link to comment
Share on other sites

17 hours ago, matthew220000 said:

How would I remove the icon from the applications?

You'll have to edit the template  ( front/forms/index ) and remove this part:


                {{if $position->icon}}
                    <img src="{file="$position->icon" extension="applicationform_Icons"}" alt='' class='ipsItemStatus ipsItemStatus_custom applicationFormFormIcon'>
				{{else}}
					<img src="{resource="app.png" app="applicationform" location="front"}" alt='' class='ipsItemStatus ipsItemStatus_custom applicationFormFormIcon'>
                {{endif}}

 

A new version was released 🙂

Quote


  • A new setting was added to the position form, which allows the admin to enable/disable the replacement of the 'create topic' form
  • A new setting was added to enable public polls.

 


 

 

Link to comment
Share on other sites

I use this as a membership application form like many others. I have a "Referrer" field that uses the "Member" option so members can type in a few letters and select whom recruited them. The member name shows in the application submission management page in the ModCP, but it only shows "Guest" in the actual topic. Is that a permissions issue? Or might that be some quirk in the file? Either way, how could I have it show the actual member name (like a @mention link) in the topic? 

Link to comment
Share on other sites

48 minutes ago, Fighting 13th said:

I use this as a membership application form like many others. I have a "Referrer" field that uses the "Member" option so members can type in a few letters and select whom recruited them. The member name shows in the application submission management page in the ModCP, but it only shows "Guest" in the actual topic. Is that a permissions issue? Or might that be some quirk in the file? Either way, how could I have it show the actual member name (like a @mention link) in the topic? 

Sorry about this, this was indeed a bug. This will be resolved in the next release.

Link to comment
Share on other sites

  • 3 weeks later...
On 12/12/2019 at 11:39 PM, Fosters said:

You'll have to edit the template  ( front/forms/index ) and remove this part:



                {{if $position->icon}}
                    <img src="{file="$position->icon" extension="applicationform_Icons"}" alt='' class='ipsItemStatus ipsItemStatus_custom applicationFormFormIcon'>
				{{else}}
					<img src="{resource="app.png" app="applicationform" location="front"}" alt='' class='ipsItemStatus ipsItemStatus_custom applicationFormFormIcon'>
                {{endif}}

ff2b78f9efcea036754cbfd821242fda.thumb.png.a2aaa11aa30dc0ae5583fc9e1a3d3f10.pngNow

I have this huge gap. How do I fix that?

 

Edited by ItzMatt01
Link to comment
Share on other sites

  • 2 weeks later...
  • 5 weeks later...
  • 1 month later...

For whomever may know, I have 2 dummy questions I'm hoping to get answered:

  1. How do I set a time limit on applications to automatically close?  PS, how do I close an application?
  2. How can I extract the data from submissions to an excel spreadsheet? I can view the list but don't see responses or an option to pull the data.
Link to comment
Share on other sites

On 2/14/2020 at 6:41 AM, Lucas Hurst said:

I have now, but where exactly do I access the template? @Fosters

 

16 minutes ago, GolfSpy STUDque said:

For whomever may know, I have 2 dummy questions I'm hoping to get answered:

  1. How do I set a time limit on applications to automatically close?  PS, how do I close an application?
  2. How can I extract the data from submissions to an excel spreadsheet? I can view the list but don't see responses or an option to pull the data.

There's no such feature, but I like the idea. I've added it to my internal todo list. 

A CSV export is already included for the next release. If you need it right now, you could export the data via phpMyAdmin.
The responses can be seen either in the ModCP or the ACP.

Link to comment
Share on other sites

22 hours ago, Fosters said:

 

There's no such feature, but I like the idea. I've added it to my internal todo list. 

A CSV export is already included for the next release. If you need it right now, you could export the data via phpMyAdmin.
The responses can be seen either in the ModCP or the ACP.

OK thanks.  I think I'm going to need to wait for that next release because exporting the data is a little bit beyond my skill set.  Any idea when that may be?

Link to comment
Share on other sites

4 hours ago, GolfSpy STUDque said:

OK thanks.  I think I'm going to need to wait for that next release because exporting the data is a little bit beyond my skill set.  Any idea when that may be?

No sorry. no timeframe yet, but I have to admit that I was planing to wait for IPS 4.5 for the next major version.

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...