Jump to content

Community

Fosters

Application Forms - Supporttopic

Recommended Posts

15 hours ago, Rob Coldwell said:

Hi, 

We would like to allow our staff to be able to submit requests through to our purchasing department (administrators). We have managed to get the form working and submissions can be made by all staff but only read by administrators. We cannot find a way for the administrators to receive a notification without being taken to the following screen however:

1394052450_ScreenShot2019-06-11at14_19_26.thumb.png.99797784531834ad9c949070d0ff9f14.png

This was visible from my account and I have administrator permissions. This has also happened with all other administrators.

Please help!

Could I please get ACP access to take a look at this?

Share this post


Link to post
Share on other sites

Sorry, we can't allow that due to the sensitive nature of our content 😞

Is there any guidance/manual on how to get a notification sent to a particular individual once an application (request form) is submitted please?

Just as a side note, we have no use for the approval of applications - not sure if this helps in this context?!

Thanks in advance

Share this post


Link to post
Share on other sites
On 6/12/2019 at 10:34 AM, Rob Coldwell said:

Sorry, we can't allow that due to the sensitive nature of our content 😞

Is there any guidance/manual on how to get a notification sent to a particular individual once an application (request form) is submitted please?

Just as a side note, we have no use for the approval of applications - not sure if this helps in this context?!

Thanks in advance

Did you set the mod permissions for the admins which are allowed to view the submissions?

I have also improved the error messages, "2applicationform" isn't really helpful to anybody here^^

Share this post


Link to post
Share on other sites
Posted (edited)

Yes, we have some moderators and they receive the above message.

In the form settings, it has also been set so that both administrators and moderators can 'manage submissions.' But it doesn't seem that administrators receive the notifications.

Are there some additional mod settings required?

We've submitted another form request, the moderators get a new notification but when clicking on it they still get the same error message as above...

Edited by Rob Coldwell

Share this post


Link to post
Share on other sites
On 6/17/2019 at 6:41 PM, Rob Coldwell said:

Yes, we have some moderators and they receive the above message.

In the form settings, it has also been set so that both administrators and moderators can 'manage submissions.' But it doesn't seem that administrators receive the notifications.

Are there some additional mod settings required?

We've submitted another form request, the moderators get a new notification but when clicking on it they still get the same error message as above...

Did you fix this issue? I'm having the same thing and can't work it out

Share this post


Link to post
Share on other sites
Posted (edited)

Are your permissions set correct?
1. Check the Mod permissions
2. Check the application form permissions.

 

Please also make sure that the form has "List on the application forms ModCP page" enabled!

 

Edited by Fosters

Share this post


Link to post
Share on other sites

I would like to ask for a few features.

1. Rolldown menu

2. Depending on answers the next question can be different depending on the answer.

3. If an answer is selected then show a text field to give more information.

4. Popup when you hover above an answer then show what is involved like for example Yes/No when hower above Yes you see an explanation (not limited to yes/no)

Share this post


Link to post
Share on other sites
5 hours ago, We are Borg said:

I would like to ask for a few features.

1. Rolldown menu

2. Depending on answers the next question can be different depending on the answer.

3. If an answer is selected then show a text field to give more information.

4. Popup when you hover above an answer then show what is involved like for example Yes/No when hower above Yes you see an explanation (not limited to yes/no)

+1 I'd love these

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/24/2019 at 2:14 AM, Fosters said:

Are your permissions set correct?
1. Check the Mod permissions
2. Check the application form permissions.

 

Please also make sure that the form has "List on the application forms ModCP page" enabled!

 

Moderator permissions are unrestricted
Application form permissions are set correctly. The relevant people have manage perms
List on the ModCP is set

 

EDIT:

ALSO for some reason, despite setting the permissions, guests can make applications

Edited by Earl_of_Berkeley

Share this post


Link to post
Share on other sites

If anybody is missing the positions on the list or in the ModCP , please review the settings and ensure that these settings are enabled:

200936255_Screenshot2019-06-3012_25_27.thumb.png.8b5064159da4d0f68d7c9b0f3bee2db3.png

On 6/26/2019 at 4:04 AM, Earl_of_Berkeley said:

ALSO for some reason, despite setting the permissions, guests can make applications

I can't reproduce this. When I remove the permission to apply, I'm getting the proper error returned:

Quote
You are not allowed to submit this form

Error code: 2app_cant_apply

Could I get ACP access to take a look?

Share this post


Link to post
Share on other sites
On 6/26/2019 at 3:04 AM, Earl_of_Berkeley said:

Moderator permissions are unrestricted
Application form permissions are set correctly. The relevant people have manage perms
List on the ModCP is set

 

EDIT:

ALSO for some reason, despite setting the permissions, guests can make applications

@Earl_of_Berkeley 

Did this get resolved? We're still having issues!

Share this post


Link to post
Share on other sites
10 minutes ago, We are Borg said:

@Fosters if you PM me i can give you access asap, i have the same issue.

Sure, please just create a new member with ACP access , send me a PM with the credentials and URL and I’ll look at this ASAP. (that’s faster then I PM you, you me back asking to register at site x, getting Login credentials, running in circles 😂)

 

thx 

Share this post


Link to post
Share on other sites

@Fosters i have an issue with the applications

Below are the applications i made the first 8 are for everyone the others admins only. But if you look at second image you will see that we are missing a few. Permissions of the 8 are set correctly i checked.

image.thumb.png.2ffdd28c19c072118f42a15db51f777c.png

 

image.thumb.png.59f30518543b139d32e9d9be9f03cb3d.png

 

I have enabled the admin account for you as in the PM from last time.

Share this post


Link to post
Share on other sites

@Fosters i have found the issue, you introduced the switch “List on the application forms Index page” it was not activated for the once that where not there. It where applications i made upgraded and continue the once that did show where made after the update.

Share this post


Link to post
Share on other sites

I hope nothing serious Fosters.

I have rather an important feature request.

We use the system for volunteers to get information and what they want to do this is all handled by the application system. What i want is that when you goto here https://phylogenyexplorerproject.org/modcp/?tab=application_approval&action=viewApplication&id=19

you have the option to comment on the application approval this way we can track everyone inside the application.

The second request is that there is an search option that can searches the applications.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, We are Borg said:

you have the option to comment on the application approval this way we can track everyone inside the application.

 

aladdin GIF

 

 

(That's already implemented for the next release🤐)

Edited by Fosters

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...