Jump to content

Community

opentype

Pages SuperGrid support

Recommended Posts

I currently use SUPERTOPICS,

but recently purchased SUPERGRID..

wondering if i update SUPERGRID templates, will my SUPERTOPICS customizations I made erase?

Example, the output of images were not displaying, I had to get help from the theme developer to remove that mask.

Thanks

~saraJ

Share this post


Link to post
Share on other sites
46 minutes ago, Bitlab Media Group said:

wondering if i update SUPERGRID templates, will my SUPERTOPICS customizations I made erase?

Those products work independently of each other. 

Edited by opentype

Share this post


Link to post
Share on other sites
On 10/21/2018 at 8:12 AM, tommax said:

Hi,

Can you add button for create new topic in mobile version?

I saw it and noted it as feedback. There is no need to bump it. It might come in a future release, but since updating Pages template sets is quite cumbersome for users at this point, I will certainly not push out a new release to 350 clients just to add a button. If the IPS Community Suite 4.4 requires changes to SuperGrid, which I expect, the next release will probably right after the 4.4 release. 

Share this post


Link to post
Share on other sites

Is there an easy way to remove the number of views from being shown publicly? As a business owner I don't want to let the competition know what is popular and what isn't. 

Share this post


Link to post
Share on other sites
4 minutes ago, Chris027 said:

Is there an easy way to remove the number of views from being shown publicly? As a business owner I don't want to let the competition know what is popular and what isn't. 

954071632_Bildschirmfoto2018-11-09um20_24_35.thumb.png.90b9e7baea888547a3ab3068dba9ab81.png

That’s the only easy way. 

 

Edited by opentype

Share this post


Link to post
Share on other sites

Hi, how can I change record template code to show fallback image on record?

 

and how can I reduce space between article and moderation?

ccc.thumb.png.55826e675739634ce3cf46380f7985fb.png

 

Thanks for help

Share this post


Link to post
Share on other sites
26 minutes ago, mardiv said:

Hi, how can I change record template code to show fallback image on record?

and how can I reduce space between article and moderation?

That’s customization and I cannot provide support for that.

Share this post


Link to post
Share on other sites

Hello! I just purchased and installed this plugin, but it isn't working correctly for me. I've had a similar problem with another plugin with database templates, so it's probably a problem with my host or settings or something, but I'm not sure what. Could you help?

I set the templates in the database on this page:

http://worldsmyths.com/ipb/index.php?/library/

Initially I did use the frontpage template, but the page loaded as completely blank, so I switched it back to the default. I have the supergrid templates set for the other options, so you'll see that if you click into a category, it loads a blank page.

The only thing I can think of is that my server currently runs PHP version 5.6.38, but I don't know much about it so I'm sure my thoughts on the problem aren't very creative.

Thank you!

ETA The Record Display template actually works fine... Just not the front page or the category listing.

One more thing, the block template doesn't seem to work for me, perhaps just because I don't see a "database feed" block. I see "record feed" and have been using that, but it doesn't seem to have a template choice dropdown or anything.

Edited by kherezae

Share this post


Link to post
Share on other sites
8 hours ago, kherezae said:

Initially I did use the frontpage template, but the page loaded as completely blank, so I switched it back to the default. I have the supergrid templates set for the other options, so you'll see that if you click into a category, it loads a blank page.

The only thing I can think of is that my server currently runs PHP version 5.6.38, but I don't know much about it so I'm sure my thoughts on the problem aren't very creative.

It means there is a critical PHP error and the page can’t be rendered at all. There are a couple of options:

  • check the Error Logs and System Logs in the Support section of the ACP. Do they show related errors?
  • Turn on the complete error display in the site’s php.ini so instead of a white page it actually shows the error. 
  • switch to 7.x and see it if helps. That’s usually just a few clicks in your host’s backend

Share this post


Link to post
Share on other sites
9 hours ago, opentype said:

It means there is a critical PHP error and the page can’t be rendered at all. There are a couple of options:

  • check the Error Logs and System Logs in the Support section of the ACP. Do they show related errors?
  • Turn on the complete error display in the site’s php.ini so instead of a white page it actually shows the error. 
  • switch to 7.x and see it if helps. That’s usually just a few clicks in your host’s backend

Okay, I switched the PHP version to 7.0, and now instead of a blank page I get an error log:

Error: Call to undefined method IPS\cms\Records2::reputation() (0)
#0 /home/(user)/public_html/ipb/applications/cms/sources/Theme/Theme.php(610) : eval()'d code(779): IPS\Theme\class_cms_database_supergrid_listing->recordRow(Object(IPS\Helpers\Table\Content), Array, Array)
#1 [internal function]: IPS\Theme\class_cms_database_supergrid_listing->categoryTable(Object(IPS\Helpers\Table\Content), Array, Array, NULL, true)
#2 /home/(user)/public_html/ipb/system/Helpers/Table/Table.php(548): call_user_func(Array, Object(IPS\Helpers\Table\Content), Array, Array, NULL, true)
#3 /home/(user)/public_html/ipb/applications/cms/modules/front/database/category.php(533): IPS\Helpers\Table\_Table->__toString()
#4 /home/(user)/public_html/ipb/applications/cms/modules/front/database/category.php(40): IPS\cms\modules\front\database\_category->view()
#5 /home/(user)/public_html/ipb/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\database\_category->manage()
#6 /home/(user)/public_html/ipb/applications/cms/sources/Databases/Dispatcher.php(325): IPS\Dispatcher\_Controller->execute()
#7 /home/(user)/public_html/ipb/applications/cms/widgets/Database.php(130): IPS\cms\Databases\_Dispatcher->run()
#8 /home/(user)/public_html/ipb/applications/cms/sources/Pages/Page.php(1257): IPS\cms\widgets\_Database->render()
#9 /home/(user)/public_html/ipb/applications/cms/sources/Pages/Page.php(2191): IPS\cms\Pages\_Page->getWidgets()
#10 /home/(user)/public_html/ipb/applications/cms/modules/front/pages/page.php(73): IPS\cms\Pages\_Page->output()
#11 /home/(user)/public_html/ipb/applications/cms/modules/front/pages/page.php(43): IPS\cms\modules\front\pages\_page->view()
#12 /home/(user)/public_html/ipb/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\pages\_page->manage()
#13 /home/(user)/public_html/ipb/applications/cms/modules/front/pages/page.php(33): IPS\Dispatcher\_Controller->execute()
#14 /home/(user)/public_html/ipb/system/Dispatcher/Dispatcher.php(146): IPS\cms\modules\front\pages\_page->execute()
#15 /home/(user)/public_html/ipb/index.php(13): IPS\_Dispatcher->run()
#16 {main}

I edited the path to replace the username with (user) because, I dunno, paranoid? But otherwise that's just a copy-paste of the errorlog shown. 

Here's the link to that website page: http://worldsmyths.com/ipb/index.php?/library/public/

I'm going to switch the Homepage Articles template back to the default, but when I switched it to frontpage I got a similar error message:

Error: Call to undefined method IPS\cms\Records2::reputation() (0)
#0 /home/(user)/public_html/ipb/applications/cms/sources/Theme/Theme.php(610) : eval()'d code(697): IPS\Theme\class_cms_database_Supergrid_FrontPage->entry(Object(IPS\cms\Records2), Object(IPS\cms\Databases))
#1 /home/(user)/public_html/ipb/applications/cms/modules/front/database/index.php(142): IPS\Theme\class_cms_database_Supergrid_FrontPage->index(Object(IPS\cms\Databases), Object(IPS\Patterns\ActiveRecordIterator), Object(IPS\Http\Url\Friendly), Array)
#2 /home/(user)/public_html/ipb/applications/cms/modules/front/database/index.php(51): IPS\cms\modules\front\database\_index->view()
#3 /home/(user)/public_html/ipb/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\database\_index->manage()
#4 /home/(user)/public_html/ipb/applications/cms/sources/Databases/Dispatcher.php(325): IPS\Dispatcher\_Controller->execute()
#5 /home/(user)/public_html/ipb/applications/cms/widgets/Database.php(130): IPS\cms\Databases\_Dispatcher->run()
#6 /home/(user)/public_html/ipb/applications/cms/sources/Pages/Page.php(1257): IPS\cms\widgets\_Database->render()
#7 /home/(user)/public_html/ipb/applications/cms/sources/Pages/Page.php(2191): IPS\cms\Pages\_Page->getWidgets()
#8 /home/(user)/public_html/ipb/applications/cms/modules/front/pages/page.php(73): IPS\cms\Pages\_Page->output()
#9 /home/(user)/public_html/ipb/applications/cms/modules/front/pages/page.php(43): IPS\cms\modules\front\pages\_page->view()
#10 /home/(user)/public_html/ipb/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\pages\_page->manage()
#11 /home/(user)/public_html/ipb/applications/cms/modules/front/pages/page.php(33): IPS\Dispatcher\_Controller->execute()
#12 /home/(user)/public_html/ipb/system/Dispatcher/Dispatcher.php(146): IPS\cms\modules\front\pages\_page->execute()
#13 /home/(user)/public_html/ipb/index.php(13): IPS\_Dispatcher->run()
#14 {main}

I could still try 7.1 or 7.2 for the PHP if that matters, or is there something else I should do to fix this?

I appreciate your help.

Edited by kherezae

Share this post


Link to post
Share on other sites
3 hours ago, kherezae said:

Okay, I switched the PHP version to 7.0, and now instead of a blank page I get an error log:

You downloaded an outdated version. Remove all SuperGrid templates and the plugin again. 
Then download and install the files in supergrid_3_0_for_IPS4_3_only.zip

Share this post


Link to post
Share on other sites
1 hour ago, opentype said:

You downloaded an outdated version. Remove all SuperGrid templates and the plugin again. 
Then download and install the files in supergrid_3_0_for_IPS4_3_only.zip

Oh my goodness what a rookie mistake >< I missed the 4 and thought that version was for IPS v3, originally. 

I installed the correct version, and of course it works perfectly! I appreciate your help and your patience.

Share this post


Link to post
Share on other sites

Hi @opentype

Very happy with Supergrid, it looks great. I noticed I have a page showing all categories which is still using the default template, but I wasn't sure if it's my site or not, as the url isn't the usual seo friendly style url.

However I just looked on your demo site and it's the same there.

https://www.opentype.space/supergrid/?show=categories

Do you think it's possible to the Supergrid templates there, too?

Many thanks.

Edited by The Old Man

Share this post


Link to post
Share on other sites
9 minutes ago, The Old Man said:

Do you think it's possible to the Supergrid templates there, too?

That is calling the generic “row template”. There is no setting to change that currently. 
In theory, I could improve that in a future update, but there are no immediate plans. It’s just more custom code to maintain. I would need to carefully think about the cost–benefit ratio. 

Share this post


Link to post
Share on other sites
3 minutes ago, peppefark said:

 but the article does not appear

Not sure what the question is. I see two articles. The only thing missing are the images. Do you have the “record image” field activated and uploaded images for those articles?

Share this post


Link to post
Share on other sites

Can you point me where I am going wrong.

New interviews are being displayed correctly on the main page (latest interview is the Christopher McGrath one) :

https://www.walkingfootball.com/interviews/

But in the categories they are being displayed oldest interview first.

IE - https://www.walkingfootball.com/interviews/walking-football-club-league-officials/

We have setup the database to:

Sort by - Publish Date

Order - Descending

If I change the order to assending, the oldest interviews show on the main page.

Thanks in advance

Share this post


Link to post
Share on other sites
2 hours ago, opentype said:

There are two sorting sections in the database settings—one for the front page, one for the regular listing. You probably haven’t set both as you like them. 

thank you

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...