Jump to content

Spacious ACP/Widgets


Flitterkill

Recommended Posts

  • 3 weeks later...

I'm regretting not forcing re-buys šŸ™‚

Also regretting setting the renewal amount so low back in the day. šŸ„ŗ

Anyone wants to, feel free to tip me out atĀ https://www.paypal.com/paypalme/allastronautsĀ - nevermind the gamers stuff. My PP account is blended with so many things...

I gotta long night (or whenever...) making a new description but you can see the newness in the screenshots at least. Might make a blithery tubevid to cover everything. Maybe.

And throw a show of thx to IPS who, at the end of the day, allowed this through though they did not have to (they really don't want stuff mucking with their ACP anymore)

FYI: I've already spotted a few things that need patching after upgrading a site with a real old Spacious on it. Made it easy to spot some quirks. Also I need to look at the onlineusers widget of mine again as it may be weird with a single member online

Edited by All Astronauts
Link to comment
Share on other sites

4 hours ago, All Astronauts said:

Actually,Ā  you have to have a front end favicon set now for this to work, so check under the acpĀ  customization tab and look for icons and... somethingĀ  option and make sure one is set. On phone now so can't look myself

No, bud.

I mean the icon for the app itself, the one which uses the Font Awesome or whatever it is.

Link to comment
Share on other sites

Can you PM me an ACP login (with your site name as well so I can get there) so I can take a peak? Should not be happening.

There were some changes we were forced to make (and then slightly rescinded but not yet fixed) with how 3rd-party devs include certain forms of resources in their apps. Long story short we had to stick them back into resources which might end up hosted off-site and depending upon your CDN and SSL cert settings and so on, would then get blocked. OrĀ it might be something else, either way the code looks fine here but I'll need to peak really quick to see what's what.

Link to comment
Share on other sites

  • 1 month later...

Heads up that 20.1.0 is inbound. Includes a non-fix to the upgrade routine (I have no idea why there is a version in the MP with an upgrade routine that was not in the final submitted version and I'm afraid to ask - water under the bridge - and I'm chalking it up to the weirdness involved in the approval process and MP early days and leaving well enough alone), preventive removal of hooks on the Support page as IPS has inbound changes there so upgrading to the new version of Invision Community should be noĀ problem when that is released, and a little JS bonus for the System Overview widget: it now auto-updates the 15-5-1 load percentages every two seconds. If you enjoy staring at the dashboard be aware those live load updates will halt after five minutes, otherwise you could walk away from your desktop with this widget up on the dashboard and your session would never time out. That's no good.

Altogether this is just a minor update, not an entirely planned release, but the timing was right to push something out so here it is.

Edited by All Astronauts
Link to comment
Share on other sites

  • 2 weeks later...

Got this earlier today:

A configuration issue has been detected on your community which requires your attention.

Locked Task: spaciousMembersOnline

One of the routine maintenance tasks which run in the background has failed several times, which may indicate a configuration issue.

I'm not giving it a lot of consideration for now.

Link to comment
Share on other sites

  • 2 weeks later...
On 1/6/2021 at 9:16 PM, iacas said:

Got this earlier today:

A configuration issue has been detected on your community which requires your attention.

Locked Task: spaciousMembersOnline

One of the routine maintenance tasks which run in the background has failed several times, which may indicate a configuration issue.

I'm not giving it a lot of consideration for now.

I have same thing, any solution?

image.thumb.png.91721367a1b9ff5c8869850d39d6249b.png

Edited by RangeMachine
Link to comment
Share on other sites

We (@iacas and myself) tracked it down, there is a small hitch with the underlying IPS method for getting these counts.

As for why only some sites only get this, and then only occasionally, remains a mystery...Ā 

I'll push out a "patched" version of Spacious which *should* mitigate this but any subsequent errors would be on the IPS side of things. I doubt you'll see any errors post-patch though as for the most part the IPS task which calls the same method I'm using usually runs error-free so I would assume...

Link to comment
Share on other sites

  • 4 months later...

ads.thumb.PNG.e2f99b2f7e7863350702d77f92aab210.PNG

I should change that text there. It's invert being applied, so whatever you have jacked in there (I assume manually?) - it will be stock on 0 and inverted colors on 1, various grays 0.1 to 0.9 and so on. So the text reads o white, 1 black as the default IPS logo is white.

What do you mean by responsive? Desktop and Tablet views the logo is IPS code. For phone view I insert the logo (IPS has it completely removed in that view). I see *that* logo of mine does not respect the invert settings though. Might have to give that a think though as that top area usually does not match the side bar colors so applying the same invert might not be best. Might need some more settings for that view.

Link to comment
Share on other sites

On 7/4/2021 at 6:58 PM, All Astronauts said:

ads.thumb.PNG.e2f99b2f7e7863350702d77f92aab210.PNG

I should change that text there. It's invert being applied, so whatever you have jacked in there (I assume manually?) - it will be stock on 0 and inverted colors on 1, various grays 0.1 to 0.9 and so on. So the text reads o white, 1 black as the default IPS logo is white.

What do you mean by responsive? Desktop and Tablet views the logo is IPS code. For phone view I insert the logo (IPS has it completely removed in that view). I see *that* logo of mine does not respect the invert settings though. Might have to give that a think though as that top area usually does not match the side bar colors so applying the same invert might not be best. Might need some more settings for that view.

My logo is much larger as a custom logo upload, taking more of the area - than it would if I replaced the actual IPS login logos with the same exact image.

The custom logo doesn't resize to fit nicely.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.

Ɨ
Ɨ
  • Create New...