Jump to content

Google map api???


ResPecT My Authoritah
 Share

Recommended Posts

Has anybody had any RECENT luck trying to get the google maps api key to work?  I had it working before but now.. i keep getting this error when i copy the key in

 That API key is not valid or does not have the Google Maps JavaScript API and/or Google Static Maps API enabled. Make sure you have followed all of the steps in the setup instructions. You may have to wait a few minutes after enabling the API for it to take effect.

Link to comment
Share on other sites

Please see this Guide:

and verify that the settings at both Google and your site match exactly as shown.

If that does not resolve the issue, or if the Guide is out of date and there are differences in "choices", please file a ticket to Support.

Thank you.

Link to comment
Share on other sites

I am not sure whether the instruction is matching the actual current google interface. for example step 4. ( Click "Go to Credentials" and create an API key for a web browser. Make sure that "Google Maps Javascript API" is selected) tehre is no option to make sure java Api is selected.

api.jpg

Further in the ACP there is no mention about Google Maps Geocoding API requirement

I have set the APIs as per below

api2.jpg

but the overal API code is still not working in the ACP:

Link to comment
Share on other sites

12 hours ago, ResPecT My Authoritah said:

Exactly what svit said... it worked before but google changed there interface permissions thing so now we need new instructions.. I already made a ticket on this to update it.

really? nothing has changed permission wise, because the map api on my site works fine using the existing instructions.

Edited by MADMAN32395
Link to comment
Share on other sites

9 hours ago, MADMAN32395 said:

really? nothing has changed permission wise, because the map api on my site works fine using the existing instructions.

Did you make a whole new site like I did??  Cause my other site it's still working .. but the site I opened a week ago it's not working.. look at svit screenshots.  I have the same as him and just like he said there's some options missing

Link to comment
Share on other sites

If you can activate the API but it doesn’t work fully, you can check what is wrong by either opening the (broken) map image in a single tab or by checking the web developer console of your browser after an API call. You will see the error message Google sends back and it will tell you what went wrong, e.g. “that specific API [name here] isn’t active. Click here to activate it …” or “that domain isn’t allowed to make request for this API key …”. That helps a lot. 

Link to comment
Share on other sites

  • 4 weeks later...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...