Jump to content
You're invited! Join our 4.6 Live Event on ZOOM 6/24 ×

Community

A different article styles By Pages ( IP.Content )


TAMAN

Recommended Posts

Just now, Josiah Wallingford said:

I am a bit confused on how I can use this with my existing blogs. We have lots of blogs and blog posts and I think this would look great but I would also like my readers to see the other view options available. Will this/can this create a new view option for my blogs (that I can then make the default view)?

If so, how do I do this? Right now I can't even figure out how to assign this to a block. I am getting a message telling me that a page is not assigned to the template when selecting which template to use. As far as I can tell I have selected the correct database and template on the page I have created. Thought I do not want to really create a new page I just want another viewing option to show on my blogs using this as the viewing option.

Hi,

This is Pages database template customization and not blogs or any other apps

Edited by TAMAN
Link to comment
Share on other sites

12 hours ago, TAMAN said:

Blocks are cached, so when you change the block plugin codes it might take time to apply on front-end side

If you want the changes to apply immediately then you need to delete the block and re add it ? otherwise wait a couple minutes after you edit the block plugin codes 

Nope, change this last night and is still the same 8 hours later, have deleted and reissued the articles and still 3 lines showing :smile:

Link to comment
Share on other sites

18 minutes ago, Davyc said:

Nope, change this last night and is still the same 8 hours later, have deleted and reissued the articles and still 3 lines showing :smile:

Then change it directly from the block you created 

edit the block go to content tab and change it from there

 

Link to comment
Share on other sites

1 hour ago, TAMAN said:

Then change it directly from the block you created 

I haven't created any blocks, this is the addon in its base format uploaded as directed.  It all works the way it should, but I cannot reduce (or increase, not that I want to) the number of lines (I would have preferred number of characters, but if it's lines then it's lines)  I've edited the template that controls the block, as noted above, but to no avail.  So, is there anywhere else that needs a change?  If I go to blocks in the ACP under pages I only see two listings there Custom and Plugins - there is nothing in them.  I've scanned all the other templates (even copied and pasted them into another program to do a thorough search for 'lines' and there is nothing.  I'm at a loss - I purchased your Infraskew and Gradient themes and have used the addon from both and they follow the same principles in that the only place that 'lines' appear is in these templates (see image below):

image.png.471259ca8c4e2153f50b9d1835e33077.png

I live in hope that this can be resolved lol

:rolleyes:

Link to comment
Share on other sites

Just now, Davyc said:

  If I go to blocks in the ACP under pages I only see two listings there Custom and Plugins - there is nothing in them.

But, you said

38 minutes ago, Davyc said:

- I'm using the s1_two_column template in Block Plugin section with this code:

how come you dont have any blocks under ACP >  Pages > Block?

anyway, it makes sense now, you're using the styles as a database template and NOT block plugins templates

 

Change the s1_two_column here 

ACP -> Pages -> Templates -> Database templates -> s1_two_column -> entry

0ffdf35368fd31acd2b90e387eaa69e8.png

 

If still doesn't work you can send me a login info with access to pages tab only i can do it for you.

 

 

Edited by TAMAN
Link to comment
Share on other sites

@TAMAN that sorted it - many thanks.  For some reason my search for 'lines' didn't show that up (must get my eyes tested lol).  As soon as I changed that line it showed up immediately.

Many thanks again for your patience - I can understand how it can be frustrating for you when you want to get to the bottom of an issue.

:biggrin:

Link to comment
Share on other sites

Just now, Davyc said:

@TAMAN that sorted it - many thanks.  For some reason my search for 'lines' didn't show that up (must get my eyes tested lol).  As soon as I changed that line it showed up immediately.

Many thanks again for your patience - I can understand how it can be frustrating for you when you want to get to the bottom of an issue.

:biggrin:

No worries!  im glad it is fixed 

 

Let me know if i can help on anything else.

Have a lovely day ? 

Link to comment
Share on other sites

  • 2 weeks later...

Any way to add the "Category" badge instead of "Pinned" or "Featured" to say which category the article is posted in, I know where to edit the template file but I don't know the IPS/PHP for it.

Also, if there is a conditional statement for checking if it's a certain category? ie {{if $category == reviews }}

Thanks

Link to comment
Share on other sites

Just now, Outlaw213 said:

Any way to add the "Category" badge instead of "Pinned" or "Featured" to say which category the article is posted in, I know where to edit the template file but I don't know the IPS/PHP for it.

Also, if there is a conditional statement for checking if it's a certain category? ie {{if $category == reviews }}

Thanks

{$record->container()->_title}

 

Link to comment
Share on other sites

  • 8 months later...

help me please @TAMAN when i try to open an article i receive this message

NOTE: i have update the template

Sorry, there is a problem

Something went wrong. Please try again.

Error code: EX0

TECHNICAL DETAILS

Error: Call to a member function url() on boolean (0)
#0 /home/i125w7do/public_html/applications/cms/modules/front/database/record.php(310): IPS\Theme\class_cms_database_m03_01_19_s1_two_column->record(Object(IPS\cms\Records1), '\n<div data-cont...', NULL, true)
#1 /home/i125w7do/public_html/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\database\_record->manage()
#2 /home/i125w7do/public_html/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
#3 /home/i125w7do/public_html/applications/cms/sources/Databases/Dispatcher.php(347): IPS\Content\_Controller->execute()
#4 /home/i125w7do/public_html/applications/cms/widgets/Database.php(128): IPS\cms\Databases\_Dispatcher->run()
#5 /home/i125w7do/public_html/applications/cms/sources/Pages/Page.php(1281): IPS\cms\widgets\_Database->render()
#6 /home/i125w7do/public_html/applications/cms/sources/Pages/Page.php(2210): IPS\cms\Pages\_Page->getWidgets()
#7 /home/i125w7do/public_html/applications/cms/modules/front/pages/page.php(112): IPS\cms\Pages\_Page->output()
#8 /home/i125w7do/public_html/applications/cms/modules/front/pages/page.php(43): IPS\cms\modules\front\pages\_page->view()
#9 /home/i125w7do/public_html/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\pages\_page->manage()
#10 /home/i125w7do/public_html/applications/cms/modules/front/pages/page.php(33): IPS\Dispatcher\_Controller->execute()
#11 /home/i125w7do/public_html/system/Dispatcher/Dispatcher.php(152): IPS\cms\modules\front\pages\_page->execute()
#12 /home/i125w7do/public_html/index.php(13): IPS\_Dispatcher->run()
#13 {main}

Link to comment
Share on other sites

12 hours ago, ntrivilino@alice.it said:

help me please @TAMAN when i try to open an article i receive this message

 

Hello,

You need to update

download the latest version in marketplace and check the documentation file on how to update

Edited by TAMAN
Link to comment
Share on other sites

Version 2.0.5

  • VERSION -2.0.5: Support for IPS 4.4.x.
  • Fixed a bug when the records throw an error if the database reviews option is enabled.
  • VERSION -2.0.5: Deleted unused templates from the Display Groups Template & Listing Groups Template.
  • VERSION -2.0.5: Display Groups Template  has now only one template S1 Display records.

 

How to update?

You only need to delete the old templates and then re-Upload it again.

If you don't know how, then please view the Updates section in the documentation file 🙂 

Link to comment
Share on other sites

  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy