Jump to content

Classifieds System


Adriano Faria

Recommended Posts

On 7/29/2021 at 10:18 PM, panzerscope said:

I am possibly being a dummy, but I have had a couple of complaints that users who have sold an item, have not received any form of notification. Is there somewhere I should be enabling this ? 

 

@InvisionHQ

 

On 7/30/2021 at 5:51 AM, Umaar said:

Same here.

Check common settings here:

image.png

 

And for the user:

image.png.913b3a9bd0e4fd2234c0ee6e3924d8a5.png

 

Edited by numis
Link to comment
Share on other sites

22 hours ago, numis said:

 

Check common settings here:

image.png

 

And for the user:

image.png.913b3a9bd0e4fd2234c0ee6e3924d8a5.png

 

Thanks for that, a good shout. However when looking at the notifications, there does not seem to be one that covers a "Buy It Now" or if an Auction were to end with a highest biffing user being the winner. These sorts of notifications do not seem to be covered ? 

Link to comment
Share on other sites

22 minutes ago, panzerscope said:

Thanks for that, a good shout. However when looking at the notifications, there does not seem to be one that covers a "Buy It Now" or if an Auction were to end with a highest biffing user being the winner. These sorts of notifications do not seem to be covered ? 

We started discuss it there https://github.com/netwaretcs/Classifieds/issues/23 

I was going to offer some kind of complete solution, but now due to personal problems I had to abandon all work on my forum.

Link to comment
Share on other sites

Invision Community v4.6.5.1

Classifieds 2.3.1

I have a problem registering new users. When I try to register a new user, I get this error:

Quote

Fatal error: Declaration of IPS\core\modules\front\system\classifieds_hook_newMemberCredit::_createMember($values, $profileFields, $postBeforeRegister, $form) must be compatible with IPS\core\modules\front\system\_register::_createMember($values, $profileFields, $postBeforeRegister, &$form) in /xxx/init.php(902) : eval()'d code on line 11

P.S.

The problem is only with php8, passed on php7 and everything is fine.

Edited by Aveliky
Link to comment
Share on other sites

On 8/6/2021 at 9:17 AM, Aveliky said:

Invision Community v4.6.5.1

Classifieds 2.3.1

I have a problem registering new users. When I try to register a new user, I get this error:

P.S.

The problem is only with php8, passed on php7 and everything is fine.

working on it thx for reporting on GitHub

Link to comment
Share on other sites

Thanks for the quick replay, but doesn't work:

Switched to 2.2.2

https://invisioncommunity.com/files/file/8311-classifieds-system/?changelog=25102

4.5 chosen

Response is 

Quote

This application is not compatible with the chosen version.

1213433483_Bildschirmfoto2021-08-19um09_54_57.png.d20e0627899e5e210fddf52af85d0180.png

Link to comment
Share on other sites

  • 3 weeks later...

I got an important question. here is scenario:

for example I make 3 packages. free, silver and gold.

I create an advert and choose free package.

after its time runs out I want to renew it and I ONLY can renew it as a free package. I CANT UPGRADE the same advert to silver or gold.

This is bad because 1. I would loose all my reviews and comments of the advert. 2. I would need to waste time and post same advert again and choose another package. Why package can't be changed more easily? This seems like a fundamental flaw.

- also can expired classifieds can be reached only with a direct link and not be publically listed?

Link to comment
Share on other sites

On 9/14/2021 at 11:50 AM, Maxxius said:

after its time runs out I want to renew it and I ONLY can renew it as a free package. I CANT UPGRADE the same advert to silver or gold.

You are right, but at the moment the package upgrade/downgrade functionality is not supported.

Quote

- also can expired classifieds can be reached only with a direct link and not be publically listed?

have you tried with?
1434059849_Schermata2021-09-26alle13_00_51.png.fedbc6c1e11fa772cf95970554b53bb9.png

Link to comment
Share on other sites

21 minutes ago, InvisionHQ said:

You are right, but at the moment the package upgrade/downgrade functionality is not supported.

have you tried with?
1434059849_Schermata2021-09-26alle13_00_51.png.fedbc6c1e11fa772cf95970554b53bb9.png

I will try to change the setting.

Well do you plan to introduce package upgrade/downgrade functionality? It would make all the sense in the world to include it. Imagine people constantly selling their items/services and once they decided to upgrade they loose all the positive reviews/comments of the add. Major bummer.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...