Jump to content

Accidentally deleted "Google" from "Login Handler"


goodnightworld
 Share

Recommended Posts

Try this

Open in cPanel PHP myadmin table "core_login_handlers

Click INSERTION in navigation menu above

Add in Columne 'login_key' - google

Add in Columne 'login_enabled' - 0

Add in Columne 'login_settings'

{"client_id":"","client_secret":"","real_name":true}

and uncheck mark

Add in Columne 'login_order' - 8 and uncheck mark

Add in 'login_acp' - 0

login_google.png

Link to comment
Share on other sites

15 hours ago, Daniel F said:

And then you'll have to run the support tools to rebuild your cache because the login handlers are cached.

Thanks @Adlago and @Daniel F

How do I rebuild my cache?

 

I had problem setting up google api. Please help me and advise me.

Got this error...

Error: redirect_uri_mismatch

Application: PokemonGoGYM web client

You can email the developer of this application at:kaiweichua@gmail.com

The redirect URI in the request, http://forums.pokemongogym.sg/applications/core/interface/google/auth.php, does not match the ones authorized for the OAuth client. Visit https://console.developers.google.com/apis/credentials/oauthclient/360797674663-id4use8ln8ra16f4hvhpjlhv302huq8a.apps.googleusercontent.com?project=360797674663 to update the authorized redirect URIs.

Edited by goodnightworld
Link to comment
Share on other sites

31 minutes ago, goodnightworld said:

Thanks @Adlago and @Daniel F

How do I rebuild my cache?

 

I had problem setting up google api. Please help me and advise me.

Got this error...

Error: redirect_uri_mismatch

Application: PokemonGoGYM web client

You can email the developer of this application at:kaiweichua@gmail.com

The redirect URI in the request, http://forums.pokemongogym.sg/applications/core/interface/google/auth.php, does not match the ones authorized for the OAuth client. Visit https://console.developers.google.com/apis/credentials/oauthclient/360797674663-id4use8ln8ra16f4hvhpjlhv302huq8a.apps.googleusercontent.com?project=360797674663 to update the authorized redirect URIs.

To rebuild cache go to System -> Support -> Something isn't working correctly -> Continue

Link to comment
Share on other sites

Just now, Nick Boyett said:

@Nick Boyett how do i find my authorized redirect URIs? I stated http://localhost on it but it still came out as http://forums.pokemongogym.sg/applications/core/interface/google/auth.php, 

 

Link to comment
Share on other sites

no matter what i change @  https://console.developers.google.com/apis/credentials/oauthclient/360797674663-id4use8ln8ra16f4hvhpjlhv302huq8a.apps.googleusercontent.com?project=360797674663  it just won't reflect/update. what should i do? @Nick Boyett

6 minutes ago, Nick Boyett said:

I think for your site the autorized redirect uri would be

http://forums.pokemongogym.sg/applications/core/interface/google/auth.php

make sure there isn't a comma at the end of it

It's okay now! Thanks for the great help!

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...