Jump to content
You're invited! Join our 4.6 Live Event on ZOOM 6/24 ×

Community

Mind Theme


Heosforo

Recommended Posts

I have uploaded the latest version which seems to have removed the custom css I had

Normally I thought that was safe when upgrading?

Also I am now trying to upgrade to the latest version of invision and am getting this warning

 

Incompatible Theme

One of your themes is not compatible with the version you are upgrading to because it includes modifications to templates and/or CSS files which this version needs to update.

If you obtained the affected theme from a designer you should contact them to ask if a new version of the theme is available for this version. If there is, continue with the upgrade and then update the theme after. If there is not an update available, you may want to remove that theme or wait until a new version is available before proceeding.

If you modified the affected theme yourself, you can use the links below to review your customisations. If the customisations are no longer required, you can revert them, otherwise you will need to incorporate the changes made by the version you are upgrading to. For more details on the theme changes in this version, see the Theme Differences Documentation.

Link to comment
Share on other sites

Hello @Unlucky

1. To get people faces see this doc

2. You can set buttons link through Theme settings -> Mind header (tab)

texts.thumb.png.250a4d57fe3583d5499656d0a53acda2.png
 

2 hours ago, Unlucky said:

I have uploaded the latest version which seems to have removed the custom css I had

This seems to be happening since the last IPS update, I'm investigating its cause.
I have not made any brutal changes,
so I don't know where this bug comes from :angry:

As soon as I have news, I will keep you updated 👍

Edited by Heosforo
Link to comment
Share on other sites

9 minutes ago, Unlucky said:

ive got the first block working ok but for some reason my trending one remains empty no matter what settings i pick

I have the correct template key added - home_news_trending

Any ideas? 

Please check if you have this option enabled: Theme settings -> Mind (tab)

trendingbar.png.ef0ffd8e4c19f777c3e8ad1817b0272a.png

I can take a look if you want, let me know

 

Theme updated.

- Added URL to buttons (welcome message)
- Option to add CSS, see "MInd tab"

Link to comment
Share on other sites

  • 1 month later...

Hi there! This theme is so nice and it's really cool of you to offer it for free. I installed it on my site, but I ran into a problem with databases.

When the Mind templates are selected, the button to add an article disappears, and even if I try to add an article through the Admin panel it just loads a completely blank page. Have you heard of this problem before, or have any idea what might cause it?

Thank you!

(Oh, notes: I'm viewing the site in Firefox at the moment, and if it matters the PHP version is 5.6.38. Let me know if any other details might help.)

Edited by kherezae
Link to comment
Share on other sites

Hi there!

I changed the site PHP to version 7.0, which seems to have gotten the templates working. However, I still have the problem of there being no "Add Record" button.

In the default templates, under Listing > categoryHeader and under Category Index > index there is this code:

{{if $database->can('add') or \IPS\Member::loggedIn()->member_id}}
	<ul class="ipsToolList ipsToolList_horizontal ipsClearfix ipsSpacer_both ipsResponsive_hidePhone">
		{{if $database->can('add')}}
			<li class='ipsToolList_primaryAction'>
				<a class="ipsButton ipsButton_medium ipsButton_important ipsButton_fullWidth" {{if $database->use_categories}}data-ipsDialog="1" data-ipsDialog-size="narrow" data-ipsDialog-title="{lang="cms_select_category"}"{{endif}} href="{$url->setQueryString( array( 'do' => 'form', 'd' => \IPS\cms\Databases\Dispatcher::i()->databaseId ) )}">{lang="cms_add_new_record_button" sprintf="$database->recordWord( 1 )"}</a>
			</li>
		{{endif}}
	</ul>
{{endif}}

But I can't just copy-paste that into the Mind templates, I'm assuming because the classes references in this code don't exist in the Mind template code?

I can add records from the Admin CP, but this is a database we want members to be able to submit to, so we need a button for it to show up. How would I go about fixing this issue?

Thank you.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy