Jump to content

http to https (SSL-certification)


Recommended Posts


I activated SSL for the domain of my board t5net-forum.de and now I tried to set it from http to https. So far it's a little bit try & error (with searching for some helpful informations in other threads, e.g. like this one).

So at first I edited the index.php from

define( 'IPB_URL', 'http://www.t5net-forum.de/forum' );


define( 'IPB_URL', 'https://www.t5net-forum.de/forum' );

Then I opened the .../forum/conf_global.php and changed all http://-strings to https://.

At last I edited the .../forum/.htaccess and added this code as suggested in the other thread:

# RewriteEngine On
# RewriteCond %{HTTPS} off
# RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

(at the moment it's not active).

So far so good, at the first look everything works fine, but some threads you are not able to open any longer.

Do I have to do something more? Perhaps something like ReBuilding?!

Thanks in advance for you help, with best regards!

Link to comment
Share on other sites

base_url isn't existing, I have

'board_url' => 'https://www.t5net-forum.de/forum',

This is a list of all entries with http-strings:


$INFO = array (

  'board_url' => 'https://www.t5net-forum.de/forum',

  'csite_poll_url' => 'http://www.t5net-forum.de/forum/index.php?showtopic=16466',

  'home_url' => 'http://www.t5net-forum.de/',
  'html_url' => 'http://www.t5net-forum.de/forum/html',

  'upload_url' => 'http://www.t5net-forum.de/forum/uploads',


I tried to run the support tool (" Something isn't working correctly."), but it redirect me directly from step 1 to 3. Is there another way to clear the cache via ACP?

Link to comment
Share on other sites

You can try it with replacing this:

# RewriteCond %{HTTPS} off
# RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]


RewriteCond %{SERVER_PORT} 80 
RewriteRule ^(.*)$ https://www.t5net-forum.de/$1 [R=301,L]

Put the .htaccess in your root direction, run the support tool to clear the cache.

Link to comment
Share on other sites

Hm when I set the .access-file to root before login to ACP I am not able to do this (login not accepted: https-url). When I first login to ACP and then set the .htaccess-file, I can start the support-tool with step 1, but as before it redirects me instant to step 3. I do not know how to use it to clear the cache :(

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...