Jump to content

Kitchen Sink


Flitterkill

Recommended Posts

On 7/14/2018 at 12:02 PM, Dan C said:

This is a new thing I'd like to see included.

IPS 3.x had this ability.   Now that IPS Connect is gone, I'm working on rewriting a Wordpress SSO solution from scratch.  It currently makes use of the IPS login form, but there's no way to redirect the user back to wordpress after logging in.  

I figure me referring users to KS would be a great way for you to sell a few extra copies if you're interested in doing the work.

 

I withdraw this request ?

I got impatient and did the work on my own.   Thank you though for your consideration.  For those that are interested:  

 

Link to comment
Share on other sites

14 hours ago, Dan C said:

I withdraw this request ?

I got impatient and did the work on my own.   Thank you though for your consideration.  For those that are interested:

Is it just not approved yet, or was it taken down or something? I don't see anything there.

Link to comment
Share on other sites

4 minutes ago, iacas said:

Is it just not approved yet, or was it taken down or something? I don't see anything there.

It hasn't been approved yet.    Since it's the weekend and all, I don't expect anyone at Invision to take notice until Monday.   

It's being offered for free, so if you're interested in testing it out before then, that can be arranged.    Hop on my Discord and I'll toss you a link.   

Edited by Dan C
Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...
  • 1 month later...

I’ve installed at least 2 plugins that add buttons to the left of the Multi-Quote button in posts. In both instances, if I have the Multi-Quote button hidden in KS, the buttons for the other plugins don’t show (as if they’ve been hidden), and the Multi-Quote button shows instead (even though it's set to hidden in KS).

It makes no difference if I have KS at the top of the list of plugins or if I have either of those plugins at the top.

I found a replacement for one of the plugins, where it instead adds a link on the right side of that row. There’s no replacement, though, for the other plugin.

As this has happened with two plugins, might I be right in thinking that all plugins that add a button to the left of the Multi-Quote button will encounter the same problem if the Multi-Quote button is hidden in KS? Is it maybe something to do with KS code? Eg: the closest I can find is on line 769 in aa_ks.css, as it contains "first-of-type" for the "commentControls":

[data-role="commentControls"] > li:first-of-type {
        display: none !important;
    }

Might a fix be possible for this please, so that it doesn’t affect other plugins that add buttons in that first position on that row?

Thanks :smile:

Link to comment
Share on other sites

It's still a thing actually. If you use KS to disable the MultiQuote button this will break. It's *not* a problem with KS and it's not a problem with User Posts in Topic. The problem is, pretty sure, the IPS javascript controller that works with the MultiQuote button. If I hide the MultiQuote button, that's fine. But if another button appears there in the first position, the controller throws the multiquote button back in. Or something like that.

I'm looking at other ways of tackling this in the next few days to maybe better lock this down but honestly, unless all you are doing is adding a button to the usercontrols down there, everything else is a nightmare of 3rd party conflicts waiting to happen - and there isn't much room to work around them.

Link to comment
Share on other sites

  • 1 month later...

Hi !

Having problems with  "Display Posts in Forums in Newest to Oldest Order?"  feature.  it works if you select it for all forums, but if you select only a few, the data is not stored.
When you close the window, and click on the widget again, no forum is selected.

 

Using latest version 4.3.6

Link to comment
Share on other sites

  • 4 weeks later...

Hey guys. So devs have had a couple of days at most of hands-on with the 4.4 code and IN_DEV, what we use to work, is a bit wonky.  

So naturally IPS posts that 4.4 is good to go.  🤷‍♂️

Please consider KS not compatible with 4.4 until you hear from me. If you upgrade to 4.4, you are on your own.

Yes, this is insane.

Link to comment
Share on other sites

1 hour ago, All Astronauts said:

Hey guys. So devs have had a couple of days at most of hands-on with the 4.4 code and IN_DEV, what we use to work, is a bit wonky.  

So naturally IPS posts that 4.4 is good to go.  🤷‍♂️

Please consider KS not compatible with 4.4 until you hear from me. If you upgrade to 4.4, you are on your own.

Yes, this is insane.

Good of you to announce this

Link to comment
Share on other sites

1 hour ago, All Astronauts said:

No mention of beta-status.

?????

image.png.2d5624127ea9744f90ee33fd25372399.png

It also says:

Quote

After months of development, over 1650 separate code commits and quite a few mugs of questionable coffee you can now get your hands on the beta release from the client centre.

 

Edited by iacas
added "also" part
Link to comment
Share on other sites

2 minutes ago, All Astronauts said:

You do realise they *just* edited all that to say that it is beta right? See the Lindy comment.

I didn't realize that, because the first time I went there it said "beta." You must have visited it before me. That's all.

I'm glad they're rolling it out over time, too. 🙂

Link to comment
Share on other sites

4 minutes ago, All Astronauts said:

You do realise they *just* edited all that to say that it is beta right?

Nope. It was in the first paragraph the whole time. It was only added to the title too, since apparently too many didn’t bother to read the post itself. 

Edited by opentype
Link to comment
Share on other sites

Our Slack channel pulls in the text, but sure, whatever...

Quote

We're thrilled to announce that Invision Community 4.4 is available to download now.

After months of development, over 1650 separate code commits and quite a few mugs of questionable coffee you can now get your hands on the beta release from the client centre.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...