Jump to content

Community

Facebook Graph API Notice


marklcfc
 Share

Recommended Posts

I received an email tonight

Quote

My site has been making recent API calls to Graph API v2.0, which will reach the end of the 2-year deprecation window on Monday, August 8, 2016. Please migrate all calls to v2.1 or higher in order to avoid potential broken experiences.

We recommend using our new Graph API Upgrade Tool to see which of your calls are affected by this change as well as any replacement calls in newer versions. You can also use our changelog to see the full list of changes.

Has anyone else had this? I clicked the graph api upgrade tool but doesn't seem to be any options in there. Whats the procedure here?

Link to comment
Share on other sites

2 hours ago, Aiwa said:

But you also have user_status, which is depreciated.  

ill disable it, and get back to ya :p

 

EDIT: actually clicked on view graph, viewed between 2.0->2.1 and 2.1 through 2.6, and i'm not producing anything that would cause issues. since I have the 'user_posts' i would assume it is calling through that.... must be a reminder message they are sending that they are removing 'user_status' in version 2.3. https://developers.facebook.com/docs/facebook-login/permissions/#reference-user_status

Edited by MADMAN32395
Link to comment
Share on other sites

3 hours ago, marklcfc said:

So what do I actually have to do?

Nothing. IPS4 makes API requests without including a version number, which means that it defaults to the earliest supported version (it's actually slightly more complicated than that, but for the people who received the email, that is how it works). You were contacted because it's currently defaulting to the API v2.0, but that will go EOL soon, and the requests will be automatically switched to v2.1 of the API (I'm pretty sure, though they haven't said that in the email). v2.1 should be fully supported by IPS4 (because some people are using versions 2.1-2.6 depending on when they registered their facebook app, and it seems to be working fine for them).

If switching API version will cause issues, I expect them to be fixed in the upcoming 4.1.13 release, because IPS are aware of the deprecation notice, so hopefully they will fix any issues if necessary.

Link to comment
Share on other sites

14 hours ago, marklcfc said:

I'm still on 3.4, is this going to cause problems?

No - here is how both versions utilize the Facebook API.

  • IPS4 makes what is called "unversioned" calls - in this instance, Facebook will automatically use the oldest supported API version. Currently, that is 2.0, however that will automatically change to 2.1 in August once the 2.0 API is deprecated.
  • IP.Board 3.x does use a "versioned" API call, and defines that version as 2.1, as of IP.Board 3.4.7.
Link to comment
Share on other sites

26 minutes ago, Ryan Ashbrook said:

No - here is how both versions utilize the Facebook API.

  • IPS4 makes what is called "unversioned" calls - in this instance, Facebook will automatically use the oldest supported API version. Currently, that is 2.0, however that will automatically change to 2.1 in August once the 2.0 API is deprecated.
  • IP.Board 3.x does use a "versioned" API call, and defines that version as 2.1, as of IP.Board 3.4.7.

I use IPS 4, but this question is for people that are still in IPB 3.4.

API 2.1 will also be deprecated in 30 of October this year. Will Invision launch a small update to IPB 3.4 to support API 2.2? Im asking because i know 3.4 have almost reached EOL, and now only security updates are made.

Link to comment
Share on other sites

On 22/06/2016 at 11:57 PM, MADMAN32395 said:

Upgrade as 3.4 is not supported except for security only. 

But I'm getting this for sites running the latest version of IPS 4.1

So, is it a simple case of deactivating a certain setting?

Link to comment
Share on other sites

On June 23, 2016 at 8:36 AM, Ryan Ashbrook said:

No - here is how both versions utilize the Facebook API.

  • IPS4 makes what is called "unversioned" calls - in this instance, Facebook will automatically use the oldest supported API version. Currently, that is 2.0, however that will automatically change to 2.1 in August once the 2.0 API is deprecated.
  • IP.Board 3.x does use a "versioned" API call, and defines that version as 2.1, as of IP.Board 3.4.7.

@Joey_M, in simple terms... This means you do nothing.  IPS 4 doesn't version their API calls, so it's using the oldest API version, which is 2.0.  When 2.0 no longer works, it will automatically switch to 2.1, 2.2, etc.  

Link to comment
Share on other sites

On ‎23‎/‎06‎/‎2016 at 3:04 PM, RevengeFNF said:

I use IPS 4, but this question is for people that are still in IPB 3.4.

API 2.1 will also be deprecated in 30 of October this year. Will Invision launch a small update to IPB 3.4 to support API 2.2? Im asking because i know 3.4 have almost reached EOL, and now only security updates are made.

Versioned calls work in a similar fashion to un-versioned ones, as soon as the API is deprecated Facebook automatically switches them to the next available API version.

At the same time, anyone that has set up Facebook on 3.4 since October 2014 should already be using API 2.2 or newer.

Facebook example:

Quote
  • If your app was created while v2.0 was the latest version available, but not used until after v2.1 had launched, it will only be to use v2.1, and not v2.0.
  • If your app was created while v2.0 was the latest version available, and then used before v2.1 had launched, it will still be able to use v2.0 even after the launch of v2.1.

 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy