Jump to content

Links Directory


Adriano Faria

Recommended Posts

2 minutes ago, ChrisTERiS said:

Hello,

In the categories widget I want to change 2 things to make it same design as all widgets in my site:

1.- To remove the extra background that you've in categories list

2.- To make the total links number same size as link title. Now the numbers are too small.

Thank you

Chris

You’re free to do anything in your install. Just change the templates to whatever you want. You just don’t wait for me to make these changes as they’re not supported. 

Link to comment
Share on other sites

26 minutes ago, Adriano Faria said:

You’re free to do anything in your install. Just change the templates to whatever you want. You just don’t wait for me to make these changes as they’re not supported. 

Having bought 5+ of your apps, I was expecting a better treatment. In any case, that's up to you.

Yes, I know perfectly that design changes are not supporting. But when? They're not supporting as long as you follow IPS (in this case) design standards. And you don't. The categories widget is the only different among all other similar widgets. IPS, and 3nd party addons. Even your Sidebar Forums is using the standard design. Why not the Links Directory?

Link to comment
Share on other sites

43 minutes ago, ChrisTERiS said:

Having bought 5+ of your apps, I was expecting a better treatment. In any case, that's up to you.

Do not support changes on my resources it’s my call, it’s a market/dev decision, regardless the number of purchases someone has on my stuff. 

44 minutes ago, ChrisTERiS said:

Yes, I know perfectly that design changes are not supporting.

Yes, that’s what I’m talking about. 

45 minutes ago, ChrisTERiS said:

But when? They're not supporting as long as you follow IPS (in this case) design standards. And you don't. The categories widget is the only different among all other similar widgets. IPS, and 3nd party addons. Even your Sidebar Forums is using the standard design. Why not the Links Directory?

Then this is not a request to change layout, it’s a bug. Anyway, use the proper channel to report: according to this file’s support info: post in the Tracker if you believed you’ve found a bug. I’ll take a look in next version. 

Create an account, if you haven’t one, with same name from here and you will be allocated in the proper group. 

Link to comment
Share on other sites

One of my users had an issue adding a link to the links directory.  I logged in as the user and added the link without an issue.  Below is the error he got.  Not sure what happened, but I wanted to let you know just in-case it was an issue.

I have my links directory image settings Thumbnails API to only allow Upload.

IPS\Http\Request\CurlException: Resolving timed out after 10000 milliseconds (28)
#0 /home/nginx/domains/xxx.com/public/system/Http/Request/Curl.php(415): IPS\Http\Request\_Curl->_execute()
#1 /home/nginx/domains/xxx.com/public/system/Http/Request/Curl.php(291): IPS\Http\Request\_Curl->_executeAndFollowRedirects('GET', NULL)
#2 /home/nginx/domains/xxx.com/public/applications/links/sources/Link/Link.php(668): IPS\Http\Request\_Curl->get()
#3 /home/nginx/domains/xxx.com/public/system/Helpers/Form/Url.php(207): IPS\links\_Link::IPS\links\{closure}(Object(IPS\Http\Url), NULL)
#4 /home/nginx/domains/xxx.com/public/system/Helpers/Form/FormAbstract.php(165): IPS\Helpers\Form\_Url->validate()
#5 /home/nginx/domains/xxx.com/public/system/Helpers/Form/FormAbstract.php(142): IPS\Helpers\Form\_FormAbstract->setValue(true)
#6 /home/nginx/domains/xxx.com/public/system/Helpers/Form/TextArea.php(66): IPS\Helpers\Form\_FormAbstract->__construct('link_url', '', true, Array, Object(Closure), NULL, NULL, 'link_url')
#7 /home/nginx/domains/xxx.com/public/system/Helpers/Form/Text.php(129): IPS\Helpers\Form\_TextArea->__construct('link_url', '', true, Array, Object(Closure), NULL, NULL, 'link_url')
#8 /home/nginx/domains/xxx.com/public/applications/links/sources/Link/Link.php(675): IPS\Helpers\Form\_Text->__construct('link_url', '', true, Array, Object(Closure), NULL, NULL, 'link_url')
#9 /home/nginx/domains/xxx.com/public/system/Content/Item.php(152): IPS\links\_Link::formElements(NULL, Object(IPS\links\Category))
#10 /home/nginx/domains/xxx.com/public/system/Content/Item.php(102): IPS\Content\_Item::buildCreateForm(Object(IPS\links\Category))
#11 /home/nginx/domains/xxx.com/public/applications/links/modules/front/links/submit.php(83): IPS\Content\_Item::create(Object(IPS\links\Category))
#12 /home/nginx/domains/xxx.com/public/system/Dispatcher/Controller.php(85): IPS\links\modules\front\links\_submit->submit()
#13 /home/nginx/domains/xxx.com/public/applications/links/modules/front/links/submit.php(28): IPS\Dispatcher\_Controller->execute()
#14 /home/nginx/domains/xxx.com/public/system/Dispatcher/Dispatcher.php(152): IPS\links\modules\front\links\_submit->execute()
#15 /home/nginx/domains/xxx.com/public/index.php(13): IPS\_Dispatcher->run()
#16 {main}
#0 /home/nginx/domains/xxx.com/public/init.php(894): IPS\_Log::log('IPS\\Http\\Reques...', 'uncaught_except...')
#1 [internal function]: IPS\IPS::exceptionHandler(Object(IPS\Http\Request\CurlException))
#2 {main}

 

Link to comment
Share on other sites

No the record wasn't added.  The user contact me saying he got an error.

I haven't noticed this error before, though I have seen a few CURL errors, but since I didn't get a report I didn't investigate it further.

I just notice that 2 minutes before the error I posted above, the user got the error below, not sure if it's related.

Error: Call to a member function contents() on null (0)
#0 /home/nginx/domains/xxx.com/public/system/Helpers/Form/FormAbstract.php(377): IPS\links\Screenshot\Api\_Upload->IPS\links\Screenshot\Api\{closure}(NULL)
#1 /home/nginx/domains/xxx.com/public/system/Helpers/Form/Upload.php(739): IPS\Helpers\Form\_FormAbstract->validate()
#2 /home/nginx/domains/xxx.com/public/system/Helpers/Form/FormAbstract.php(165): IPS\Helpers\Form\_Upload->validate()
#3 /home/nginx/domains/xxx.com/public/system/Helpers/Form/FormAbstract.php(142): IPS\Helpers\Form\_FormAbstract->setValue(true)
#4 /home/nginx/domains/xxx.com/public/system/Helpers/Form/Upload.php(151): IPS\Helpers\Form\_FormAbstract->__construct('link_image', NULL, '1', Array, Object(Closure), NULL, NULL, 'link_image')
#5 /home/nginx/domains/xxx.com/public/applications/links/sources/Screenshot/Api/Upload.php(47): IPS\Helpers\Form\_Upload->__construct('link_image', NULL, '1', Array, Object(Closure), NULL, NULL, 'link_image')
#6 /home/nginx/domains/xxx.com/public/applications/links/sources/Link/Link.php(713): IPS\links\Screenshot\Api\_Upload->form()
#7 /home/nginx/domains/xxx.com/public/system/Content/Item.php(152): IPS\links\_Link::formElements(NULL, Object(IPS\links\Category))
#8 /home/nginx/domains/xxx.com/public/system/Content/Item.php(102): IPS\Content\_Item::buildCreateForm(Object(IPS\links\Category))
#9 /home/nginx/domains/xxx.com/public/applications/links/modules/front/links/submit.php(83): IPS\Content\_Item::create(Object(IPS\links\Category))
#10 /home/nginx/domains/xxx.com/public/system/Dispatcher/Controller.php(85): IPS\links\modules\front\links\_submit->submit()
#11 /home/nginx/domains/xxx.com/public/applications/links/modules/front/links/submit.php(28): IPS\Dispatcher\_Controller->execute()
#12 /home/nginx/domains/xxx.com/public/system/Dispatcher/Dispatcher.php(152): IPS\links\modules\front\links\_submit->execute()
#13 /home/nginx/domains/xxx.com/public/index.php(13): IPS\_Dispatcher->run()
#14 {main}
#0 /home/nginx/domains/xxx.com/public/init.php(894): IPS\_Log::log('Error: Call to ...', 'uncaught_except...')
#1 [internal function]: IPS\IPS::exceptionHandler(Object(Error))
#2 {main}

Just check to make sure I hadn't modified any templates, they are all stock.

Edited by Bluto
Link to comment
Share on other sites

@Bluto, will need more info on this. I just managed to add a record with UPLOAD image setting, no error in logs.

IJp6cgl.png

You posted 2 errors. The first one is about timeout:

Quote

IPS\Http\Request\CurlException: Resolving timed out after 10000 milliseconds (28)

I've changed the script to run for a given number of seconds... if can't do it, then will throw an error on submission.

Regarding the second, will need more info. Shows an error in the image; anything special about it? Size? Dimensions?

Edited by Adriano Faria
Link to comment
Share on other sites

On 9/2/2019 at 5:57 AM, ChrisTERiS said:

They're not supporting as long as you follow IPS (in this case) design standards. And you don't. The categories widget is the only different among all other similar widgets. IPS, and 3nd party addons. Even your Sidebar Forums is using the standard design. Why not the Links Directory?

 

On 9/2/2019 at 6:46 AM, Adriano Faria said:

Then this is not a request to change layout, it’s a bug.

@ChrisTERiS, can you point where the difference is in the categories block? I can't see.

 

- Links Directory:

UFB0avb.png

 

- Downloads:

brxfyaB.png

 

- Pages:

dHeRmZ8.png

Link to comment
Share on other sites

Is it possible to remove the blocks which are being used on the LD app main page so they don't show up in the Clubs?  All the other apps / features I'm using in the club (forum, videobox, gallery, blog) don't have the blocks I use in the respected apps.  LD is the only one which has all the blocks from main LD app page.  If I remove any of the blocks from the LD clubs page, it removes them from the main LD page.

Is there a setting or template I could modify so that the blocks from the main LD page won't show up in clubs?

Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...