Jump to content

Community

Adriano Faria

Links Directory

Recommended Posts

At the moment we offer everyone free listings, but if they pay a small fee then they appear at the top of their category and have a box (or colour) highlighting them - it's just an upsell.

Share this post


Link to post
Share on other sites

It would be great if I could charge to feature or pin a link.  After the user enters their free link, they'd be prompted to "upgrade their listing to a featured listing or pin their link".

Share this post


Link to post
Share on other sites

I understand, it was just a potential idea for a future version - as directory software sometimes has these different paid levels. Don't worry if it's not going to happen here though :)

Share this post


Link to post
Share on other sites
On 1/18/2018 at 8:26 PM, AlexWebsites said:

Odd, I got it to work by enabling Store thumbnails locally

Now back to all thumbnails gone, not really sure what the issue is. Tried store images locally, tried all image thumbnail options but can't seem to get it to work now. Has anyone else ran into this? If i uninstall the app, will it delete all the links?  Only changes since I noticed this were an update to IPS and moved from memcache to redis. 

image.thumb.png.2c98e738c3ecdbb57f55d7522d713222.png

Share this post


Link to post
Share on other sites

I'm having this same issue, changing my settings doesn't seem to work, even sneak.pw. I kept changing the settings and using the tool to rebuild and eventually they came back using the "Web Thumbnail" setting. However, new links being added are still not getting the thumbnails automatically and I had to use the rebuild tool again. A little troublesome but workable.

Edited by JTHastings

Share this post


Link to post
Share on other sites

Just rebuilt sll my links. Works fine: http://www.sosinvision.com.br/ips4/index.php?/links/

if you read all pages of this topic, you will see in all pages someone saying that nothing works, everything is bad, etc. then this person disappears in a few hours/day. The app works, otherwise ALL other purchasers would post here.

They’re free services and as such, they will stop working from time to time. There’s absolutely nothing I can do except ask you to wait for their service to become stable again. Just wait!

Ps: I’m not responsible for 3rd-party services. If they stopped working, it’s not my fault. My job is to provide a communication between your forum and a 3rd-party service, WHILE they’re working. 

Share this post


Link to post
Share on other sites
6 minutes ago, Adriano Faria said:

They’re free services and as such, they will stop working from time to time. There’s absolutely nothing I can do except ask you to wait for their service to become stable again.

I'm not saying your application is bad (yes it works), just the 3rd party thumbnail providers and I was trying to add my "2 cents" to the topic as well as my use of the rebuild tool. Just in case anyone wanted to know what frustrations some of us were experiencing. AlexWebsites did ask "Has anyone else ran into this?" and I was trying to say "yes" and here's what I did.

P.S. I edited my post above to be a bit clearer in meaning.

Share this post


Link to post
Share on other sites

Right now a user can purchase a link in a category and once they purchase that link, it remains in the links directory forever (one time cost).

I'm using the paid links option for 1 category called "Sponsored".  Users have the option to purchase a link in the sponsored category or add a link for free in one of the other categories.  Currently, if they purchase a link in the sponsored category it will remain in that category forever - unless a mod moves it.

Would it be possible to add to a future release - few ideas, not all apply to my idea above.

A.  The ability to attach a time limit on the paid links.  I could sell a paid link for X number of days.  After the X number of days expires, the link would auto-hide OR automatically be moved to a free category in the directory (a category determined by the user when he adds the link).

B.  The ability for the user to have an option to list a link for free or paid per category.  A category would have the option of having paid and free links.  If the user decides to go with the paid link, their link would be a sponsored link. 

C.  The ability to only sell X number of paid links per category.  Really popular categories can attract a lot of people who want their link featured (paid).  Being able to limit the number of paid links per category would result in competition between users for the paid exposure (sponsored link).

If I had 10 categories and I offered 2 paid links for each category, those 20 videos I could feature in a widget I created for the index page.  Having the ability to set a time limit on the paid links (time, clicks, or CPM) would allow me to have good turnover of paying customers versus someone who pays one-time for the link and it's featured forever.

Just a suggestion.

 

Share this post


Link to post
Share on other sites
On 1/30/2018 at 10:54 AM, JTHastings said:

I'm having this same issue, changing my settings doesn't seem to work, even sneak.pw. I kept changing the settings and using the tool to rebuild and eventually they came back using the "Web Thumbnail" setting. However, new links being added are still not getting the thumbnails automatically and I had to use the rebuild tool again. A little troublesome but workable.

Same thing for me on all services.I rebuilt and all but still having the issue. I even have Thumbshots enabled with an API key and its not working in full. I also shut off store thumbs locally to test and no thumbs show up. from thumbshots. swicthed back to other services and having similar issues still.

Share this post


Link to post
Share on other sites
42 minutes ago, AlexWebsites said:

Same thing for me on all services.I rebuilt and all but still having the issue. I even have Thumbshots enabled with an API key and its not working in full. I also shut off store thumbs locally to test and no thumbs show up. from thumbshots. swicthed back to other services and having similar issues still.

I’m aware of the Thumbshots issue. Will release a new version as soon as it’s fixed. 

Share this post


Link to post
Share on other sites
On 1/30/2018 at 11:23 AM, Adriano Faria said:

Just rebuilt sll my links. Works fine: http://www.sosinvision.com.br/ips4/index.php?/links/

if you read all pages of this topic, you will see in all pages someone saying that nothing works, everything is bad, etc. then this person disappears in a few hours/day. The app works, otherwise ALL other purchasers would post here.

They’re free services and as such, they will stop working from time to time. There’s absolutely nothing I can do except ask you to wait for their service to become stable again. Just wait!

Ps: I’m not responsible for 3rd-party services. If they stopped working, it’s not my fault. My job is to provide a communication between your forum and a 3rd-party service, WHILE they’re working. 

@Adriano have you tested this with https://? Do you have an install over ssl? For instance, when I am using webthumbnail.org, my installation shows the images as https://api.webthumbnail.org/?width=768..... so I tested that url in my browser and its not over ssl and only shows if I change it to http. Now it also looks like webthumbnails.org has been changed and should be https://api.miniature.io according to https://miniature.io/docs 

sneak.pw is not changing to http but the urls to the images are coming up not found. For instance, here is a sneak.pw generated image url http://api.sneak.pw/api.php?width=768&height=1024&url=http%3A%2F%2Fwww.google.com&output=raw

image.png.ce2715c0be74067f272bfa9bb4c1c63a.png

Webshots free plan (which I have) looks like its not over SSL and may be my issue, I haven't upgraded.

Share this post


Link to post
Share on other sites

@Adriano Faria Thanks!

Just some other thoughts and ideas...

1.  Links Feed Slider Widget

You might also want to consider adding a (Block Manager) widget which uses the same scroller at the Links Directory index page (What's New and Random Links).  None of the existing widgets look like the scrolling widget on the LD index page.  The reason I mention this is that an admin can't add a "featured" or "pinned" widget to the LD index page featuring only "featured" or "pinned" links and have that widget match the existing widgets on the page.  I created a widget in Pages which does exactly this.  I used the LD "Links Feed" plugin and the code below.  Some people might not have pages, so having this as a widget might give admins more options for how they display and list their content.

	<div class='ipsBox'>
		<h2 class='ipsType_sectionTitle ipsType_reset'>{$title}</h2>
		<div class='ipsAreaBackground ipsPad_half'>
			{{if count( $links )}}
				<div class='ipsCarousel ipsClearfix' data-ipsCarousel data-ipsCarousel-showDots>
					<ul class='cDownloadsCarousel' data-role="carouselItems">
						{{foreach $links as $idx => $link}}
							{template="indexBlock" group="browse" app="links" params="$link"}
						{{endforeach}}
					</ul>
					<span class='ipsCarousel_shadow ipsCarousel_shadowLeft'></span>
					<span class='ipsCarousel_shadow ipsCarousel_shadowRight'></span>
					<a href='#' class='ipsCarousel_nav ipsHide' data-action='prev'><i class='fa fa-chevron-left'></i></a>
					<a href='#' class='ipsCarousel_nav ipsHide' data-action='next'><i class='fa fa-chevron-right'></i></a>
				</div>
			{{else}}
				<p class='ipsType_reset ipsType_light ipsPad'>{lang="no_top_links"}</p>
			{{endif}}
		</div>
	</div>
	<br>

 

2.  Index Page Sorting

Looking at the LD template index page, I can see the blocks of code for the various sections / blocks - (What's New, Random Links, Affiliates, and the Categories).

It would be great if these were sortable in the ACP.  Currently, I'd have to manually move the code around in the template.  It would be great if there was an option of how to arrange the blocks on the LD index page.

 

3.  Thumbnail Experience

Just my experience with the thumbnails:  I've had some issues with webthumbnail is the past.  None of the current services offered have I had a 100% success rate.  Either the thumbnail stops showing or the service grabs a bad thumbnail.  Right now I have the thumbnails on manual upload.  It's easier for me to do a screenshot and I actually find people upload better links when they're required to upload a thumbnail (I made the upload required).

There were some other services offered which might offer better options (note: I haven't tried a lot of the services below)

https://screenshotlayer.com/

http://www.page2images.com/

Urlbox - Best Automated Screenshot API | Urlbox.io

Cross Browser Testing - 1500+ Real Browsers & Devices

Shrink The Web - shrinktheweb.com

ScreenshotsCloud - High quality real browser screenshot API

Url2png - Screenshots as a Service

Screenshot Layer - screenshotlayer.com

Screenshot Machine - Website capturing service that REALLY works!

Browshot - Service for real time website screenshots

Capture - Convert HTML to PNG, PDF and Images to GIF

Restpack - Screenshot API

WhoAPI - Screenshot API

RoboThumb - Générateur automatique de screenshots

Webshots Pro - webshotspro.com

Screen.rip - Programmable screenshot API (10,000 shots for $7)

ScreenshotAPI - API To Convert Screenshot with 30,000 free credits

ApiLeap - Chrome Based Screenshot API

Thumbalizr - thumbalizr.com

Snapito - snapito.com

GeoScreenshot - GeoScreenshot

Grabzit - Convert Webpages, URL's or HTML into PDF's, images or data

SiteSnapr - screenshots as a service

Sneak.pw - SNEAK PREVIEWS | Professional Web Thumbnails

Page2Images - Website Screenshot Generator & API

Linkpeek - Website Screenshot - Webpage Snapshot - Screenshot Service

Pagelr - pagelr.com

Web-Capture - Online full length web site screenshots for free

Edited by Bluto

Share this post


Link to post
Share on other sites
18 minutes ago, Adriano Faria said:

No, I don’t have. 

I’ll take a look in SSL stuff in the app.

Not sure if its related, but I would have a look at this setting as well. 

image.thumb.png.330ba9f330f570fdaac088573b769226.png

Edited by AlexWebsites

Share this post


Link to post
Share on other sites

I just started to review all these API and will probably replace them or fix the ones who can be fixed. The problem here is that the vast majority is paid or the free package is very limited.

Example: I just added Screenshotmachine. Works very nice but it has only 100 screenshots per month in the free plan.

IfuQVxl.png

 

xOasUWS.png

H83Rots.png

 

@AlexWebsites, yes, all APIs handle SSL already:

		$apiUrl = \IPS\Request::i()->isSecure() ? 'https://' : 'http://';
		$apiUrl .= "api.webthumbnail.org/?";

Except Thumbshots. Will change it to make some tests in a client's board.

Share this post


Link to post
Share on other sites
43 minutes ago, Adriano Faria said:

I just started to review all these API and will probably replace them or fix the ones who can be fixed. The problem here is that the vast majority is paid or the free package is very limited.

Example: I just added Screenshotmachine. Works very nice but it has only 100 screenshots per month in the free plan.

IfuQVxl.png

 

xOasUWS.png

H83Rots.png

 

@AlexWebsites, yes, all APIs handle SSL already:


		$apiUrl = \IPS\Request::i()->isSecure() ? 'https://' : 'http://';
		$apiUrl .= "api.webthumbnail.org/?";

Except Thumbshots. Will change it to make some tests in a client's board.

On my end, if you fetch a url with api.webthumbnail.org over https:// chrome does not display which is maybe why the thumbs do not come up. If you once allow it it and the browser recognizes that, it seems to work. The issue seems to be because they are moving away from the webthumbnail.org url to the new one that has a certificate in place.

image.thumb.png.e99f926f1ac44f167cb4e5fe82656b15.png

If you change it to  api.miniature.io it does fetch over https://

image.png.9b759f41b3119202b2bf277f0c6aca22.png

Where are you changing that $apiUrl, I can test on my end if you like.

 

Share this post


Link to post
Share on other sites
Just now, AlexWebsites said:

If you change it to  api.miniature.io it does fetch over https://

Yes, I'm doing this right now.

Just now, AlexWebsites said:

Where are you changing that $apiUrl, I can test on my end if you like.

I will send you a new version today later, so you can test it out.

See:

a96rLwf.png

Share this post


Link to post
Share on other sites

@AlexWebsites, will send you a PM now with a new version so you can test. What was done:

- Regarding APIs:

  • Switched from Webthumbnail.org to Miniature.io
  • dropped Sneak.pw (it seems to be paid now but their site is TOO confusing that I coudn't even find the API to test it out in a trial)
  • Fix the Thumbshots API
  • Added 2 new APIs:
    • Screenshotmachine: allows you to have 100 free screenshots per month. There are paid plans.
    • Urlbox.io: paid service.

- New settings:

  • You now can set how many links you want to show and define its ordering (random or links submission) in Display 'Other links from this category' block? setting.

--------------------------------------------------------------------------------------------------------

Let me know if anyone else wants to try it out (since you have purchased this resource).

:)

Edited by Adriano Faria

Share this post


Link to post
Share on other sites
6 minutes ago, Adriano Faria said:

@AlexWebsites, will send you a PM now with a new version so you can test. What was done:

- Reguarding APIs:

  • Switched from Webthumbnail.org to Miniature.io
  • dropped Sneak.pw (it seems to be paid now but their site is TOO confusing that I coudn't even find the API to test it out in a trial)
  • Fix the Thumbshots API
  • Added 2 new APIs:
    • Screenshotmachine: allows you to have 100 free screenshots per month. There are paid plans.
    • Urlbox.io: paid service.

- New settings:

  • You now can set how many links you want to show and define its ordering (random or links submission) in Display 'Other links from this category' block? setting.

Let me know if you want to try it out (since you have purchased this resource).

:)

Nice! webshots is now working for me and also tested Miniature.io and its is also working without storing files locally. Thank you. 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...