Jump to content

Community

Adriano Faria

Links Directory

Recommended Posts

Hi,

We have just got round to using this and added a facebook and a twitter link#

Both of them are NOT showing thumbnails and in the error log we have errors like this

01/05/2017 04:07 PMlinksIPS\Http\Request\CurlException (28) Operation timed out after 10001 milliseconds with 0 bytes received

When opening up the errors we have the following info in backtrace field

 

#0 /home/public_html/chat/system/Http/Request/Curl.php(280): IPS\Http\Request\_Curl->_execute()
#1 /home/public_html/chat/applications/links/sources/Screenshot/Api/Webthumbnail.php(40): IPS\Http\Request\_Curl->get()
#2 /home/public_html/chat/applications/links/sources/Screenshot/Screenshot.php(69): IPS\links\Screenshot\Api\_Webthumbnail->cacheThumb()
#3 /home/public_html/chat/applications/links/sources/Link/Link.php(481): IPS\links\_Screenshot->getImage()
#4 /home/public_html/chat/system/Patterns/ActiveRecordIterator.php(52): IPS\links\_Link::constructFromData(Array)
#5 /home/public_html//chat/system/Theme/Theme.php(760) : eval()'d code(1536): IPS\Patterns\_ActiveRecordIterator->current()
#6 [internal function]: IPS\Theme\class_links_front_browse->index(Object(IPS\Patterns\ActiveRecordIterator), Array, Object(IPS\Patterns\ActiveRecordIterator))
#7 /home/public_html/chat/system/Theme/SandboxedTemplate.php(57): call_user_func_array(Array, Array)
#8 /home/public_html//chat/applications/links/modules/front/links/browse.php(82): IPS\Theme\_SandboxedTemplate->__call('index', Array)
#9 /home/public_html//chat/applications/links/modules/front/links/browse.php(82): IPS\Theme\SandboxedTemplate->index(Object(IPS\Patterns\ActiveRecordIterator), Array, Object(IPS\Patterns\ActiveRecordIterator))
#10 /home/public_html/chat/applications/links/modules/front/links/browse.php(38): IPS\links\modules\front\links\_browse->_index()
#11 /home/public_html/chat/system/Dispatcher/Controller.php(96): IPS\links\modules\front\links\_browse->manage()
#12 [internal function]: IPS\Dispatcher\_Controller->execute()
#13 /home/public_html/chat/init.php(443) : eval()'d code(14): call_user_func_array('parent::execute', Array)
#14 /home/public_html//chat/system/Dispatcher/Dispatcher.php(129): IPS\Dispatcher\hook26->execute()
#15 /home/public_html/chat/index.php(13): IPS\_Dispatcher->run()
#16 {main}

 

Share this post


Link to post
Share on other sites

I would be it is something related to Webthumbnail. It comes acting weird from time to time.

Webthumbnail:

Capturar.png

 

No thumb and the page remains loading for a while...


Capturar1.png

- This one is from sneak.pw; works as it should. As FB requires login, it doesn't show the page.

1 minute ago, Unlucky said:

Saw an earlier post and swapped to using sneak.pw and it seems to be working

We're almost posted together. :)

1 minute ago, Unlucky said:

is there any downside to using sneak.pw compared to webthumbnail?

Not that I'm aware, no.

Share this post


Link to post
Share on other sites

Hello ! :)

I'm using version 5.0.3.1. Is it useful to upgrade to the last version ?

Anyway, my Links Directory doesn't appear in the "Out of date" section in my ACP... So I don't know how to upgrade...

Thank you for your help ! :)

Share this post


Link to post
Share on other sites

I have another problem which occured after I upgraded to IPB version 4 and began using the new Links Directory : many links no longer work... I get an error message :
 

Quote

 

Sorry, there is a problem

We could not locate the item you are trying to view.

Error code: 2LDVIEW/2

 

The stats say I have 528 links... I checked in the database and saw like they do exist.

So I tried to find out more looking at a link which doesn't work :

 

For example, the url looks like this :

mywebsite/links/link/2-des-idées-d39activités-en-arts-plastiques-sur-rustrelfreefr/

I see numbers (39) and accentuated characters (é)

 

In the database, for the above example, I have this :

link_pb.png

 

It seems like the problem is linked to the characters in the url ?...

How can I fix this ?

Thank you. :)

 

Edited by SecondSight

Share this post


Link to post
Share on other sites

Ok, I've found out what is wrong : the problem was linked to the sub-categories.

I used to have two level of categories. For instance : links/category1/sub-category1. And the links which are in the sub-categories no longer worked. They also no longer appeared in Links Directory categories page, but if you ran a search you found them and they also appeared in the Random Links section, and in the database.

When I looked in the ACP/Community/Links Directory/Categories content, I noticed that all sub-categories were disabled. I simply re-enabled them and now everything's ok. :)

Share this post


Link to post
Share on other sites

Hello !:)

I get an error when I try to add a new category in Links Director (in my ACP) :

Quote

 

A configuration or server error has occurred

EX1364 Something went wrong. Please try again.

INSERT INTO `ibf_links_categories` ( `category_position` ) VALUES ( 27 )
IPS\Db\Exception: Field 'category_notes' doesn't have a default value (1364)
#0 /home/myboard/public_html/system/Db/Db.php(695): IPS\_Db->preparedQuery('INSERT INTO `ib...', Array)
#1 /home/myboard/public_html/system/Patterns/ActiveRecord.php(458): IPS\_Db->insert('links_categorie...', Array)
#2 /home/myboard/public_html/system/Node/Model.php(2014): IPS\Patterns\_ActiveRecord->save()
#3 /home/myboard/public_html/applications/links/sources/Category/Category.php(257): IPS\Node\_Model->save()
#4 /home/myboard/public_html/system/Node/Controller.php(383): IPS\links\_Category->formatFormValues(Array)
#5 /home/myboard/public_html/applications/links/modules/admin/links/categories.php(36): IPS\Node\_Controller->form()
#6 [internal function]: IPS\links\modules\admin\links\_categories->form()
#7 /home/myboard/public_html/system/Dispatcher/Controller.php(85): call_user_func(Array)
#8 /home/myboard/public_html/system/Node/Controller.php(63): IPS\Dispatcher\_Controller->execute()
#9 /home/myboard/public_html/applications/links/modules/admin/links/categories.php(31): IPS\Node\_Controller->execute()
#10 /home/myboard/public_html/system/Dispatcher/Dispatcher.php(129): IPS\links\modules\admin\links\_categories->execute()
#11 /home/myboard/public_html/admin/index.php(13): IPS\_Dispatcher->run()
#12 {main}

 

What can be the reason for this error ?

Thank you ! :)

Share this post


Link to post
Share on other sites

It only happens on index. I would say is a couple of links (maybe there are more) whch doesn't has thumbs and the app is trying to grab it from the API site. See an example:

Capturar.png

Links:

  • Grimsby Ancient Ma...
  • Feltham old offenders

Actually, those without thumbs in the index. Go to those links and edit them and use the option Refresh Thumbnails.

Share this post


Link to post
Share on other sites
34 minutes ago, Unlucky said:

Now it would appear when trying to load the links directory it takes a long time to load

I experienced the same problem and I have many missing thumbnails... As for you Links Directory, it loaded very fast for me. :)

Share this post


Link to post
Share on other sites
5 minutes ago, Unlucky said:

I just switched from sneak.pw to  webthumbnail - rebuilt thumbs and now it seems to be alot faster

Wow, so it's back?

5 minutes ago, Unlucky said:

maybe sneak.pw does not like https sites?

Not sure. It was missing thumbs, that was the issue.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...