Jump to content

Default Photo per Group


BomAle
 Share

Recommended Posts

This plugin will set a default photo for members who have yet to select one. Each group has your own image. If a photo of an specific group is not found, the defult photo from theme will be displayed.

Configuration:

  • Uploads the xml plugin file into AdminCP > System > Plugins (it insert 3 default image: default_photo_6.png for moderators, default_photo_3.png for members, default_photo_4.png for administrators)
  • Go into Themes > on right Menu > Manage resources > Add Resources, follow this istruction:
    • Location: global
    • Folder: plugins
    • Application: System
    • Resource, file name must have this format: default_photo_ID.png (replace ID with group id of the group that must have uploaded photo)

I have uploaded also a .psd file for customize as you wish the photo and three image included on xml file.

 

Edited by BomAle
Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
On 25/6/2016 at 1:10 AM, BomAle said:

This is not available by default a "multi-upload" of resources... but this could be a feature for future version of IPS.

I know it's not possible in resources but I was talking about you uploaded your images to a folder on the FTP, and then in settings you typed in the address to that folder. If you have a look at the old mod for IPB V3 you can see what I'm talking about: https://invisionpower.com/files/file/6137-default-photo-per-group/

Edited by Cabola
Link to comment
Share on other sites

  • 1 month later...

This is probably a setting outside of your plugin, but I can't seem to figure it out.  When I add a resource the file name is changing.

This is what the file name shows after I upload it 

default_photo_4_57aeccfe62541.png

Also, probably another stupid question, how do I tell what the group id's are?

Thanks!

Link to comment
Share on other sites

  • 1 year later...
12 hours ago, Zanime said:

Doesn't seem to work. It still displays the default letter avatar/photo.

Try new version, it work on demo website (read into file description)

On 13/8/2016 at 9:38 AM, Circo said:

This is probably a setting outside of your plugin, but I can't seem to figure it out.  When I add a resource the file name is changing.

This is what the file name shows after I upload it 

default_photo_4_57aeccfe62541.png

Also, probably another stupid question, how do I tell what the group id's are?

Thanks!

Did you check that there was no other photo with the same name (it must be unique or system append a md5 string)?

Can you try with IPS 4.2+? Sorry for delay

Edited by BomAle
Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...