Jump to content

Installation Error


GFLRoy
 Share

Recommended Posts

Hello everybody, I am trying to install a fresh IPS 4 (4.1.12.1) on one of my new machines. However, I am running into an issue every time I start the installation.

It first says "Setting Up Databases" and then goes straight to a "<hostname> has redirected too many times" page error (on Google Chrome). After investigating, I found that this error has been spammed in the error_log:

[28-May-2016 02:38:52 UTC] PHP Fatal error:  Uncaught exception 'IPS\Db\Exception' with message 'Table '******.core_sessions' doesn't exist' in /home/******/public_html/system/Db/Db.php:388
Stack trace:
#0 /home/******/public_html/system/Db/Db.php(688): IPS\_Db->preparedQuery('REPLACE INTO `c...', Array)
#1 /home/******/public_html/system/Session/Front.php(300): IPS\_Db->replace('core_sessions', Array, true)
#2 [internal function]: IPS\Session\_Front->write('20b87717065f066...', '')
#3 {main}
  thrown in /home/******/public_html/system/Db/Db.php on line 388

 

I've tried different versions of IPS 4 and I am still getting the same error (4.1.11.1, 4.1.12, and 4.1.12.1). With that said, I've tried writing another PHP script to see if it's an issue with the MySQL server, however, the script ran queries on the MySQL server fine. Therefore, the connection between IPS 4 and the database should be okay.

 

Does anybody have any idea what could cause this? I have opened a ticket with the Invision Power staff, but I do not know how long it will take them to reply (I am trying to get this fixed ASAP).

 

Thanks.

Edited by GFLCommunity
Link to comment
Share on other sites

17 minutes ago, CalvinK said:

Does the core_sessions table exist in your database?

No. Although, why should it? It should be creating the tables (since this is a new IPS 4 installation), not executing queries on tables. Please correct me if I am wrong though (I may be). 

 

Thanks.

Link to comment
Share on other sites

4 minutes ago, GFLCommunity said:

No. Although, why should it? It should be creating the tables (since this is a new IPS 4 installation), not executing queries on tables. Please correct me if I am wrong though (I may be). 

 

Thanks.

I wasn't expecting it to exist, don't worry!

It's just so we can clarify that the core sessions table hasn't been created yet the install obviously thinks it has been created as it's trying to write a session to it.

Link to comment
Share on other sites

2 hours ago, CalvinK said:

I wasn't expecting it to exist, don't worry!

It's just so we can clarify that the core sessions table hasn't been created yet the install obviously thinks it has been created as it's trying to write a session to it.

You are correct about it thinking there are tables in the database already. I found another log file (uploads/logs) and it seems to think all of the tables exist. Here is one entry (out of many others):

Sat, 28 May 2016 15:12:22 +0000
Table '********.ips4_core_sys_conf_settings' doesn't exist
SELECT conf_key, conf_default, conf_value FROM `ips4_core_sys_conf_settings` AS `core_sys_conf_settings`
 | File                                                                       | Function                                                                      | Line No.          |
 |----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------|
 | /system/Db/Db.php                                                          | [IPS\Db\_Exception].__construct                                               | 388               |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
 | /system/Db/Select.php                                                      | [IPS\_Db].preparedQuery                                                       | 346               |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
 | /system/Db/Select.php                                                      | [IPS\Db\_Select].runQuery                                                     | 244               |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
 | /system/Settings/Settings.php                                              | [IPS\Db\_Select].setKeyField                                                  | 139               |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
 | /system/Settings/Settings.php                                              | [IPS\_Settings].loadFromDb                                                    | 119               |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
 | /system/Dispatcher/Front.php                                               | [IPS\_Settings].__isset                                                       | 39                |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
 | /system/Dispatcher/Dispatcher.php                                          | [IPS\Dispatcher\_Front].init                                                  | 86                |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
 | /index.php                                                                 | [IPS\_Dispatcher].i                                                           | 13                |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
#0 /home/**********/public_html/system/Db/Exception.php(109): IPS\_Log::log('Table '********...', 'sql')
#1 /home/**********/public_html/system/Db/Db.php(388): IPS\Db\_Exception->__construct('Table '********...', 1146, NULL, 'SELECT conf_key...', Array)
#2 /home/**********/public_html/system/Db/Select.php(346): IPS\_Db->preparedQuery('SELECT conf_key...', Array)
#3 /home/**********/public_html/system/Db/Select.php(244): IPS\Db\_Select->runQuery()
#4 /home/**********/public_html/system/Settings/Settings.php(139): IPS\Db\_Select->setKeyField('conf_key')
#5 /home/**********/public_html/system/Settings/Settings.php(119): IPS\_Settings->loadFromDb()
#6 /home/**********/public_html/system/Dispatcher/Front.php(39): IPS\_Settings->__isset('setup_in_progre...')
#7 /home/**********/public_html/system/Dispatcher/Dispatcher.php(86): IPS\Dispatcher\_Front->init()
#8 /home/**********/public_html/index.php(13): IPS\_Dispatcher::i()
#9 {main

 

I also forgot to mention, I am using MariaDB. As far as I am aware, IPS doesn't have any problems with MariaDB since it is very similar to MySQL. 

 

I've also tried doing this through the root user (obviously as a test to see if it works at all), but no luck. I have enabled the general MySQL (MariaDB) log file and it appears to be at least executing some queries during the installation:


160528 11:07:16   906 Connect   *****************@***** as anonymous on *********
                  906 Query     SET NAMES utf8mb4
                  906 Quit
                  907 Connect   *****************@***** as anonymous on *********
                  907 Query     SET NAMES utf8mb4
                  907 Quit
                  908 Connect   *****************@***** as anonymous on *********
                  908 Query     SET NAMES utf8mb4
                  908 Quit
                  909 Connect   *****************@***** as anonymous on *********
                  909 Query     SET NAMES utf8mb4
                  909 Quit
                  910 Connect   *****************@***** as anonymous on *********
                  910 Query     SET NAMES utf8mb4
                  910 Quit
                  911 Connect   *****************@***** as anonymous on *********
                  911 Query     SET NAMES utf8mb4
                  911 Quit
                  912 Connect   *****************@***** as anonymous on *********
                  912 Query     SET NAMES utf8mb4
                  912 Quit
                  913 Connect   *****************@***** as anonymous on *********
                  913 Query     SET NAMES utf8mb4
                  913 Quit
160528 11:07:17   914 Connect   *****************@***** as anonymous on *********
                  914 Query     SET NAMES utf8mb4
                  914 Quit
                  915 Connect   *****************@***** as anonymous on *********
                  915 Query     SET NAMES utf8mb4
                  915 Quit
                  916 Connect   *****************@***** as anonymous on *********
                  916 Query     SET NAMES utf8mb4
                  916 Quit
                  917 Connect   *****************@***** as anonymous on *********
                  917 Query     SET NAMES utf8mb4
                  917 Quit
                  918 Connect   *****************@***** as anonymous on *********
                  918 Query     SET NAMES utf8mb4
                  918 Quit
                  919 Connect   *****************@***** as anonymous on *********

 

As I said before, making a separate test script to insert into the database works fine. This is only an issue with the IPS 4 installer.

 

I will continue to look for solutions. If anybody could give any suggestions, it would be greatly appreciated!

 

Thanks.

Edited by GFLCommunity
Link to comment
Share on other sites

I've never worked with MariaDB (although moving my community onto it is on my todo list), but there's a number of people who have some experience with it. Might be worthwhile just putting "(MariaDB)" in your title so it's clearer ^_^

Link to comment
Share on other sites

2 hours ago, CalvinK said:

I've never worked with MariaDB (although moving my community onto it is on my todo list), but there's a number of people who have some experience with it. Might be worthwhile just putting "(MariaDB)" in your title so it's clearer ^_^

Sadly, I don't see an edit button for the original post.

 

Also, after trying different things to see if IPS 4 would install correctly, I am still stuck. I finally decided to see if IPB 3.4.9 installed, and yes, it did install correctly. It installed all the tables, etc fine using the same database details as the IPS 4 installation.

 

I'm not sure what else the IPS 4 installer requires. I'm running MariaDB 5.5.47 and I hope the IPS 4 installer supports that.

 

Thanks.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...