Jump to content

Unable to translate the word "Yesterday" in AdminCP


Recommended Posts

I've been busy fixing a lot of translations in the forum directly from AdminCP and the word "Yesterday" from system is impossible to translate for unknown reason.

I must've tried at least 20 times before I figured out something was wrong. Other words in same category like "Today" from system worked fine to translate but the only one to behave like this is "yesterday".

I ran the following SQL query to check the database and 'word custom' was null.

SELECT * FROM `core_sys_lang_words` WHERE `word_default` LIKE 'Yesterday';

I manually updated the database and now the translation is correct in the forum, but this must be a bug somewhere so I'm posting it here.

Perhaps it's possible to translate the word "Yesterday" with an xml file, but in AdminCP it's impossible, and there is no error message or similar.

Is this a local issue I'm having or is it a proper bug? I'm running the latest version of IPB btw.

Link to comment
Share on other sites

The query returned the correct "word", I merely put it in the post as to reference the table name e.g.

I updated the field "word_default" to the correct translation in the DB and verified in AdminCP that the translation now was populated.

The problem was/is that the word/key "Yesterday" in app System isn't possible to update in AdminCP. You are able to enter a translation and you get the correct "saved" response, but the translation was never updated in the DB. Other words in app system could be translated as they should but not "Yesterday", hence why I wonder if this was a local problem or a bug?

I can provide more details later as I'm not in the office at the moment.

Link to comment
Share on other sites

  • 1 month later...


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...