Jump to content

Upgrade to IPB 4.1.11 Updater Bug?


jucs
 Share

Recommended Posts

I had no issues using the upgrade system in admin the last update.  Today, it stopped and stated below. The thing is, I have another forum on the same exact dedicated server I did the upgrade minutes earlier.

I went to do the upgrade to IronHistory.com this morning and it stopped and said this:
Manual action required

 

Please download the update and upload the files to your server.

I then tried it again and it gave this error below.  It seems there is some sort of issue with the updater.  I have the same login as a client but own two licenses for two separate forums.  Again, it worked fine in the last update for both forums.

Some of the files were not as expected. They may have been manually modified or not uploaded correctly.

  • /home/ironhist/public_html/forum/system/Text/HtmlPurifierInternalLinkDef.php

 

Link to comment
Share on other sites

I just went back to admin after logging out for another reason and it said "files there for upgrade, want to continue?"

I clicked it and it worked!  So, there is some bug in the upgrader but who knows what that is! LOL

Edited by jucs
Link to comment
Share on other sites

2 hours ago, RevengeFNF said:

Just go to /admin/upgrade

That's not enough, the 'new' version of HtmlPurifierInternalLinkDef.php is not included in the upgrade files.  First (after the automatic upgrade stopped) I manually downloaded the upgrade package but I had the same error. I found that HtmlPurifierInternalLinkDef.php is not in that .zip file.  Then I downloaded the full package and manually copied HtmlPurifierInternalLinkDef.php (dated april 25, 08:36) and after that the upgrade can continue.

Edited by SeaTea
clarify how I upgraded
Link to comment
Share on other sites

4 minutes ago, RevengeFNF said:

Correct. But you only need the new file if you have php 5.4. For upper versions, theres no need for that. 

I'm running PHP 5.6.19 with MariaDB 10.0.24 and had this on both my testforum as normal forum....

(and only on this 4.1.11 upgrade, not on 4.1.10 upgrade)

Edited by SeaTea
Link to comment
Share on other sites

17 minutes ago, RevengeFNF said:

You have 5.6, so you can ignore the warning and proceed with the upgrade. 

That's what I did at first, but when clicking on 'continue' I got the same screen again telling me that HtmlPurifierInternalLinkDef.php is not the correct version and upgrade is not proceeding.  There is a difference in the file which is in the full installation package compared to the installed version.  

I did not try to stop the upgrade and use again the /upgrade url.  But the new file works and as it is in the full-install-package it is probably forgotten in the upgrade file-set.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...