Jump to content

Missing icons - font blocked due to cross-origin policy


Recommended Posts

Some of our users are suddenly reporting that icons are missing. We've noted that ad blockers are sometimes the source of this (for instance, that which ships with iOS) but this is new. In Chrome OSX, here is the error from the console a user reported:



Font from origin 'http://www.rllmukforum.com' has been blocked from loading by Cross-Origin Resource Sharing policy: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'http://rllmukforum.com' is therefore not allowed access.

Any ideas why this would be? It doesn't affect Chrome on either Win 7 or Android for me. I've asked users to try incognito mode or equivalent to ensure content isn't blocked, but this doesn't help. It affects both our parent skin and 2 child skins.

Affected browsers are Firefox on android, Firefox on OSX (yet worked on his iPhone), and Chrome on OSX (but worked on Safari OSX).

I can't seem to locate a common cause. Only changes to the board yesterday were switching tasks to be run from cron.

Link to comment
Share on other sites

I can confirm this problem when visiting your site with Firefox on OSX. 

I’m pretty sure is caused by your server configuration. You serve the site via “www” but also without “www”. So when the site is loaded without “www” and the fonts are called from “www…” (which is what is happening) it will fail, because the fonts come from a different domain. 

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...