Jump to content

Community

Recommended Posts

  • Replies 64
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

@Tom Irons this was a minor conflict with Kitchen Sink. I knew what it was the moment I saw the screenshot. KS grabs all that stuff to let users move it around so if KS isn't at the top of the plugin

I'm working on getting 4.2 installed today, I'll keep you updated.

Got it working, think it would be better placed in the options dropdown though, I don't plan on using it regularly but it appears in every post Also, there was no confirmation screen, it just bann

Posted Images

@Tom Irons this was a minor conflict with Kitchen Sink. I knew what it was the moment I saw the screenshot. KS grabs all that stuff to let users move it around so if KS isn't at the top of the plugin list it will over-write any modifications to that area that happened before the plugin loader gets to KS. Your plugin was just above it in the list.

Already tackled this with @Tripp_UK and he's good to go.

 

Link to post
Share on other sites

Okay I've found another bug. If the topic is deleted or inaccessible (Say to that usergroup) and yet they still have the URL for whatever reason then it'll throw an Out Of Range Exception:

OutOfRangeException:  (0)
#0 /home/site/public_html/system/Content/Content.php(81): IPS\Patterns\_ActiveRecord::load('35')
#1 /home/site/public_html/init.php(434) : eval()'d code(73): IPS\_Content::loadAndCheckPerms('35')
#2 /home/site/public_html/init.php(434) : eval()'d code(89): IPS\forums\modules\front\forums\hook1257->manage()
#3 /home/site/public_html/system/Dispatcher/Controller.php(96): IPS\forums\modules\front\forums\hook1311->manage()
#4 /home/site/public_html/system/Content/Controller.php(46): IPS\Dispatcher\_Controller->execute()
#5 /home/site/public_html/applications/forums/modules/front/forums/topic.php(40): IPS\Content\_Controller->execute()
#6 /home/site/public_html/system/Dispatcher/Dispatcher.php(129): IPS\forums\modules\front\forums\_topic->execute()
#7 /home/site/public_html/index.php(13): IPS\_Dispatcher->run()
#8 {main}

 

Link to post
Share on other sites
  • 1 month later...
On 29/08/2016 at 3:59 PM, Tripp_UK said:

Okay I've found another bug. If the topic is deleted or inaccessible (Say to that usergroup) and yet they still have the URL for whatever reason then it'll throw an Out Of Range Exception:


OutOfRangeException:  (0)
#0 /home/site/public_html/system/Content/Content.php(81): IPS\Patterns\_ActiveRecord::load('35')
#1 /home/site/public_html/init.php(434) : eval()'d code(73): IPS\_Content::loadAndCheckPerms('35')
#2 /home/site/public_html/init.php(434) : eval()'d code(89): IPS\forums\modules\front\forums\hook1257->manage()
#3 /home/site/public_html/system/Dispatcher/Controller.php(96): IPS\forums\modules\front\forums\hook1311->manage()
#4 /home/site/public_html/system/Content/Controller.php(46): IPS\Dispatcher\_Controller->execute()
#5 /home/site/public_html/applications/forums/modules/front/forums/topic.php(40): IPS\Content\_Controller->execute()
#6 /home/site/public_html/system/Dispatcher/Dispatcher.php(129): IPS\forums\modules\front\forums\_topic->execute()
#7 /home/site/public_html/index.php(13): IPS\_Dispatcher->run()
#8 {main}

 

@Tom Irons: This is still an issue and I have over 3,000 objects in the last 30 days now spamming up my system error logs. Is there any update to this issue?

Link to post
Share on other sites
  • 1 month later...
  • 2 months later...

Having the same issue and thought it was related to something else. Response from IPS was as follows : 

The OutOfRangeException errors in the ACP system logs are not related to polls they are caused by a plugin attempting to load a content item that does not exist. Specifically the problem is caused by the "Ban From Topic" Plugin. Please disable this plugin or contact the modification author for assistance.

These are some examples from the logs : 

OutOfRangeException:  (0)
#0 /home/site/public_html/init.php(447) : eval()'d code(73): IPS\_Content::loadAndCheckPerms('29634')
#1 /home/site/public_html/system/Dispatcher/Controller.php(96): IPS\forums\modules\front\forums\hook562->manage()
#2 /home/site/public_html/system/Content/Controller.php(51): IPS\Dispatcher\_Controller->execute()
#3 /home/site/public_html/applications/forums/modules/front/forums/topic.php(40): IPS\Content\_Controller->execute()
#4 /home/site/public_html/system/Dispatcher/Dispatcher.php(129): IPS\forums\modules\front\forums\_topic->execute()
#5 /home/site/public_html/index.php(13): IPS\_Dispatcher->run()
#6 {main}

 

OutOfRangeException:  (0)
#0 /home/site/public_html/system/Content/Content.php(81): IPS\Patterns\_ActiveRecord::load('27106')
#1 /home/site/public_html/init.php(447) : eval()'d code(73): IPS\_Content::loadAndCheckPerms('27106')
#2 /home/site/public_html/system/Dispatcher/Controller.php(96): IPS\forums\modules\front\forums\hook562->manage()
#3 /home/site/public_html/system/Content/Controller.php(51): IPS\Dispatcher\_Controller->execute()
#4 /home/site/public_html/applications/forums/modules/front/forums/topic.php(40): IPS\Content\_Controller->execute()
#5 /home/site/public_html/system/Dispatcher/Dispatcher.php(129): IPS\forums\modules\front\forums\_topic->execute()
#6 /home/site/public_html/index.php(13): IPS\_Dispatcher->run()
#7 {main}

 

Please advise

Link to post
Share on other sites
  • 1 month later...
  • 2 weeks later...
On 4/10/2017 at 5:56 PM, Towal Moore said:

Hello!

I have a question. The current version is banning guest from every topic, even ones in public areas, and I can't seem to remove that ban. Is there a setting somewhere I am missing?

If you wouldn't mind, please try to re-install the plugin. If that doesn't work then I'll dig into the issue.

Also, what version of IPS are you using?

Link to post
Share on other sites
  • 2 weeks later...

@Tom Irons i have a suggestion. Do you think its possible to have temporary ban from topics?

For example, i ban someone from the topic, and it asks if it is indefinitely or to choose a time limit, like 1 hour or 1 day etc. If i choose the time limit, and the person enter the topic, it could say something like: "You are banned from the topic for the next 34 minutes".  

This would be very good to calm down a user.

Edited by RevengeFNF
Link to post
Share on other sites
On 5/3/2017 at 7:53 AM, RevengeFNF said:

@Tom Irons i have a suggestion. Do you think its possible to have temporary ban from topics?

For example, i ban someone from the topic, and it asks if it is indefinitely or to choose a time limit, like 1 hour or 1 day etc. If i choose the time limit, and the person enter the topic, it could say something like: "You are banned from the topic for the next 34 minutes".  

This would be very good to calm down a user.

I really like this idea, I'll have to think about how to structure it. If I can keep it as a plugin I'll be more than happy to add it.

On 5/3/2017 at 6:12 PM, RevengeFNF said:

@Tom Irons just to let you know in advance, that your plugin seems to not be working with 4.2.0 alpha. The button to ban does not appear in the posts.

I don't have the alpha version installed, so I don't know what to tell you about that. I'll see if I can get it installed sometime this weekend.

Link to post
Share on other sites
3 hours ago, Tom Irons said:

I really like this idea, I'll have to think about how to structure it. If I can keep it as a plugin I'll be more than happy to add it.

I don't have the alpha version installed, so I don't know what to tell you about that. I'll see if I can get it installed sometime this weekend.

Thanks you, it would really be a good addition.

Probably its related with the new layout. The Ban from Topic button simple does not appear in the posts.

Link to post
Share on other sites
  • 2 weeks later...
4 minutes ago, RevengeFNF said:

Did you choose who can ban?

 

Uhm.. i have enabled the two ban/unban options for my Administrator group in ACP/Staff/Moderators. I.. do not see the ban option in the posts on a topic..

Edited by LinkMania
Link to post
Share on other sites
1 minute ago, LinkMania said:

Uhm.. i have enabled the two ban/unban options for my Administrator group in ACP/Staff/Moderators.

This ones?

842fd823d6b04a54b3ddefb655152a3a.png

If yes, then you should see the option in the posts, like this:

4e88afe46c8c4a35b4e470b4753535b4.png

If you still don't see it, try changing to the default ips theme. If it appears there, then its an issue between this plugin and your current theme.

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy